1. 股票论坛首页
  2. 股票指标
  3. MACD

MACD背离副图股票公式

副图公式:MACD背离
DIFF : EMA(CLOSE,SHORT) – EMA(CLOSE,LONG);
DEA : EMA(DIFF,M);
MACD : 2*(DIFF-DEA), COLORSTICK,COLOR5454FF;
DD:=C=HHV(C,180);
EE:=DEA< REF(DEA,1) AND REF(DEA< REF(DEA,1),1)=1;
CC:=C> REF(C,1) AND REF(C> REF(C,1),1)=1;
上升背离CC AND EE)*DEA,COLOR00FFFF;
顶背离DD AND EE AND DEA< HHV(DEA,180))*DEA,STICK,LINETHICK3,COLORGREEN;
FF:=C=LLV(C,180);
GG:= DEA> REF(DEA,1) AND REF(DEA> REF(DEA,1),1)=1;
LL:=C< REF(C,1) AND REF(C< REF(C,1),1)=1;
下降背离LL AND GG)*DEA,COLORMAGENTA;
底背离FF AND GG AND DEA> LLV(DEA,180))*DEA,STICK,LINETHICK3,COLORRED;
MM:=IF(MACD< 0,MACD,0);
JJ:=MM> REF(MM,1);
ZZ:=REF(JJ,1)=1;
介入区JJ AND ZZ)*DEA,POINTDOT,COLORRED;{MACD蓝柱缩短—指今日比昨天短}
STICKLINE(介入区=DEA,DEA,DIFF,3,0),COLORRED;
DRAWTEXT(CROSS(DIFF,DEA ),0,’金\N叉’),COLORCYAN;
DRAWTEXT(CROSS(DEA,DIFF ),0,’死叉’),COLORGREEN;

原创文章,作者:TTone,如若转载,请注明出处:https://www.qianglongwang.com/36735.html

联系我们