1. 股票论坛首页
  2. 炒股技巧
  3. 均线

股票公式自用均线

自用均线

ma(c,p1), linethick2;
ma(c,p2)linethick2;
ma(c,p3)linethick2;
ma(c,p4)linethick2;
ma(c,480)linethick2;

close2:=c;h2:=h;l2:=l;o2:=o;
ma1:=ma(c,5),colorff00ff;
ma2:=ma(c,10),color00ff00;
ma3:=ma(c,30),colorffff00;
B1:=REF(close2,1);B2:=REF(close2,2);
SS:=IF(close2>REF(close2,1) AND REF(close2,1)>=REF(close2,2),1,IF(C<REF(close2,1) AND REF(close2,1)<=REF(close2,2),-1,IF(close2>REF(close2,2) AND REF(close2,2)>REF(close2,1),2,IF(close2<REF(close2,2) AND REF(close2,2)<REF(close2,1),-2,0))));
SM:=IF(REF(SS,1)<>0,REF(SS,1),IF(REF(SS,2)<>0,REF(SS,2),IF(REF(SS,3)<>0,REF(SS,3),IF(REF(SS,5)<>0,REF(SS,5),IF(REF(SS,6)<>0,REF(SS,6),IF(REF(SS,7)<>0,REF(SS,7),0))))));
mc:=IF(REF(SS,1)<>0,B2,IF(SM>0,MIN(B1,B2),MAX(B1,B2))),COLOR000000;
aa:=Close > Ref(Close, 1) and Ref(Close, 1) > Ref(Close, 2) and Ref(Close, 1) < Ref(Close, 3) and If(Ref(Close, 3) < Ref(Close, 4), 1, If(Ref(Close, 4) < Ref(Close, 5),Ref(Close, 1) < Ref(Close, 4) or( Ref(Close, 2) < Ref(Close, 4) and Ref(Close, 3) >= Ref(Close, 5) ),If(Ref(Close, 5) < Ref(Close, 6), 1,Ref(Close, 6) < Ref(Close, 7))));
bb:=Close < Ref(Close, 1) and Ref(Close, 1) < Ref(Close, 2) and Ref(Close, 1) > Ref(Close, 3) and If(Ref(Close, 3) > Ref(Close, 4), 1, If(Ref(Close, 4) > Ref(Close, 5),Ref(Close, 1) > Ref(Close, 4) or( Ref(Close, 2) > Ref(Close, 4) and Ref(Close, 3) <= Ref(Close, 5) ),If(Ref(Close, 5) > Ref(Close, 6), 1,Ref(Close, 6) > Ref(Close, 7))));
drawicon(aa and close>ref(open,2),low,4);
drawicon(bb and close<ref(close,2),high,5);

STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,9,0 ),COLOR009900;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,6,0 ),COLOR00cc00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,2.4,0 ),COLOR33ff00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,1.1,0 ),COLOR66ff00;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,9,0 ),COLOr000099;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,6 ,0 ),COLOR0000cc;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2.4 ,0 ),COLOR0000ff;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1.1 ,0 ),COLOR0033ff;
STICKLINE(CLOSE>OPEN,OPEN,LOW,0.5,0 ),COLOr000099;
STICKLINE(CLOSE>OPEN,CLOSE,HIGH,0.5 ,0 ),COLOr000099;
STICKLINE(OPEN>=CLOSE,CLOSE,LOW,0.5 ,0 ),COLOR009900;
STICKLINE(OPEN>=CLOSE,OPEN,HIGH,0.5 ,0 ),COLOR009900;

tttt:=max(ma(c,p1),max(ma(c,p2),max(ma(c,p3),max(ma(c,p4),ma(c,480)))));

tt:=F10FIND(‘主要财务股票指标’,1);
bb1:=f10find(‘每股收益’,tt);
bb8:=f10find(‘净资产收益率(%) ‘,tt);
bb9:=f10find(‘每股经营现金净流量(元)’,tt);
mmmm:=’每股收益:’+f10text(bb1+28,8)+’净资产收益率(%):’+f10text(bb8+28,8)+’每股经营现金净流量(元):’+f10text(bb9+28,8);

pp:=f10find(‘◆ 最新股票指标’,1);
qq:=f10find(‘◆ 概念题材 ◆’,1);

gggg:=F10TEXT(F10FIND(‘总 股 本’,pp),0)+
F10TEXT(F10FIND(‘目前流通’,pp),0)+
F10TEXT(F10FIND(‘最近除权’,pp),0);

w:=F10FIND(‘大股东进出 ‘,1);
EXPLAIN(1,RTRIM(LTRIM(F10TEXT(F10FIND(‘ 1’,w),0)))),colorwhite;
w1:=F10FIND(‘%’,w+100);
EXPLAIN(1,RTRIM(LTRIM(F10TEXT(F10FIND(‘ 2’,w1+1),0)))),,colorwhite;
w2:=F10FIND(‘%’,w1+10);
EXPLAIN(1,RTRIM(LTRIM(F10TEXT(F10FIND(‘ 3’,w2+1),0)))),,colorwhite;
w3:=F10FIND(‘%’,w2+10);
EXPLAIN(1,RTRIM(LTRIM(F10TEXT(F10FIND(‘ 4’,w3+1),0)))),,colorwhite;
w4:=F10FIND(‘%’,w3+10);
EXPLAIN(1,RTRIM(LTRIM(F10TEXT(F10FIND(‘ 5’,w4+1),0)))),,colorwhite;
w5:=F10FIND(‘%’,w4+10);
EXPLAIN(1,RTRIM(LTRIM(F10TEXT(F10FIND(‘ 6’,w5+1),0)))),,colorwhite;
w6:=F10FIND(‘%’,w5+10);
EXPLAIN(1,RTRIM(LTRIM(F10TEXT(F10FIND(‘ 7’,w6+1),0)))),,colorwhite;
w7:=F10FIND(‘%’,w6+10);
EXPLAIN(1,RTRIM(LTRIM(F10TEXT(F10FIND(‘ 8’,w7+1),0)))),,colorwhite;
w8:=F10FIND(‘%’,w7+10);
EXPLAIN(1,RTRIM(LTRIM(F10TEXT(F10FIND(‘ 9’,w8+1),0)))),,colorwhite;
w9:=F10FIND(‘%’,w8+10);
EXPLAIN(1,RTRIM(LTRIM(F10TEXT(F10FIND(’10’,w9+1),0)))),colorwhite;

qgEAKBARS(1,20,1),linethick0;
qd:TROUGHBARS(2,20,1),linethick0;
drawtext(SYSPARAM(2)=BARPOS,c,’距前高点’+NUMTOSTR(ref(h,qg),2)+’元’+numtostr(qg,0)+’天_距前低点’+NUMTOSTR(ref(l,qd),2)+’元’
+numtostr(qd,0)+’天’+’/n’+’历史最高价=’+NUMTOSTR(hhv(h,0),2)+’元_历史最低价=’+NUMTOSTR(llv(l,0),2)+’元_现价=’+
NUMTOSTR(c,2)+’元’),align4,coloryellow;


原创文章,作者:不将就的人生,如若转载,请注明出处:https://www.qianglongwang.com/3784.html

联系我们