1. 股票论坛首页
  2. 炒股技巧
  3. 均线

均线粘合公式

所谓的均线粘合就是5、10、20、30、60、90、120、250日中有两条或三条、四条、五条、六条移动平均成本接近相同,或相差不大。例如三线粘合,我们只需要比较出这三条线中的最大成本和最小成本,把最大成本值和最小成本值之间的差距定义为某一个窄幅波动范围就可以了。
参数名 最小 最大 缺省
M1 0.00 1000.00 5.00
M2 0.00 1000.00 10.00
M3 0.00 1000.00 20.00
M4 0.00 1000.00 60.00
M5 0.00 1000.00 120.00
M6 0.00 1000.00 250.00
A:MAX(MAX(MA(CLOSE,M1),MA(CLOSE,M2)),MA(CLOSE,M3)),LINETHICK0;
B:MIN(MIN(MA(CLOSE,M1),MA(CLOSE,M2)),MA(CLOSE,M3)),LINETHICK0;
三线粘合:IF(RANGE(100*(A-B)/B,0,5),100*(A-B)/B,DRAWNULL),LINETHICK0;
SA:MAX(MAX(MA(CLOSE,M1),MA(CLOSE,M2)),MAX(MA(CLOSE,M3),MA(CLOSE,M4))),LINETHICK0;
SB:MIN(MIN(MA(CLOSE,M1),MA(CLOSE,M2)),MIN(MA(CLOSE,M3),MA(CLOSE,M4))),LINETHICK0;
四线粘合:IF(RANGE(100*(SA-SB)/SB,0,10),100*(SA-SB)/SB,DRAWNULL),LINETHICK0;
WA:MAX((MAX(MA(CLOSE,M1),MA(CLOSE,M2)),MAX(MA(CLOSE,M3),MA(CLOSE,M4))),MA(CLOSE,M5)),LINETHICK0;
WB:MIN((MIN(MA(CLOSE,M1),MA(CLOSE,M2)),MIN(MA(CLOSE,M3),MA(CLOSE,M4))),MA(CLOSE,M5)),LINETHICK0;
五线粘合:IF(RANGE(100*(WA-WB)/WB,0,15),100*(WA-WB)/WB,DRAWNULL),LINETHICK0;
LA:MAX((MAX(MA(CLOSE,M1),MA(CLOSE,M2)),MAX(MA(CLOSE,M3),MA(CLOSE,M4))),MAX(MA(CLOSE,M5),MA(CLOSE,M6))),LINETHICK0;
LB:MIN((MIN(MA(CLOSE,M1),MA(CLOSE,M2)),MIN(MA(CLOSE,M3),MA(CLOSE,M4))),MIN(MA(CLOSE,M5),MA(CLOSE,M6))),LINETHICK0;
六线粘合:IF(RANGE(100*(LA-LB)/LB,0,20),100*(LA-LB)/LB,DRAWNULL),LINETHICK0;
公式注释:
输出A:收盘价的M1日简单移动平均和收盘价的M2日简单移动平均的较大值和收盘价的M3日简单移动平均的较大值,LINETHICK0
输出B:收盘价的M1日简单移动平均和收盘价的M2日简单移动平均的较小值和收盘价的M3日简单移动平均的较小值,LINETHICK0
输出三线粘合:如果100*(A-B)/B位于0和5之间,返回100*(A-B)/B,否则返回无效数,LINETHICK0
输出SA:收盘价的M1日简单移动平均和收盘价的M2日简单移动平均的较大值和收盘价的M3日简单移动平均和收盘价的M4日简单移动平均的较大值的较大值,LINETHICK0
输出SB:收盘价的M1日简单移动平均和收盘价的M2日简单移动平均的较小值和收盘价的M3日简单移动平均和收盘价的M4日简单移动平均的较小值的较小值,LINETHICK0
输出四线粘合:如果100*(SA-SB)/SB位于0和10之间,返回100*(SA-SB)/SB,否则返回无效数,LINETHICK0
输出WA:(收盘价的M1日简单移动平均和收盘价的M2日简单移动平均的较大值,收盘价的M3日简单移动平均和收盘价的M4日简单移动平均的较大值)和收盘价的M5日简单移动平均的较大值,LINETHICK0
输出WB:(收盘价的M1日简单移动平均和收盘价的M2日简单移动平均的较小值,收盘价的M3日简单移动平均和收盘价的M4日简单移动平均的较小值)和收盘价的M5日简单移动平均的较小值,LINETHICK0
输出五线粘合:如果100*(WA-WB)/WB位于0和15之间,返回100*(WA-WB)/WB,否则返回无效数,LINETHICK0
输出LA:(收盘价的M1日简单移动平均和收盘价的M2日简单移动平均的较大值,收盘价的M3日简单移动平均和收盘价的M4日简单移动平均的较大值)和收盘价的M5日简单移动平均和收盘价的M6日简单移动平均的较大值的较大值,LINETHICK0
输出LB:(收盘价的M1日简单移动平均和收盘价的M2日简单移动平均的较小值,收盘价的M3日简单移动平均和收盘价的M4日简单移动平均的较小值)和收盘价的M5日简单移动平均和收盘价的M6日简单移动平均的较小值的较小值,LINETHICK0
输出六线粘合:如果100*(LA-LB)/LB位于0和20之间,返回100*(LA-LB)/LB,否则返回无效数,LINETHICK0

或用下面公式:
MA1:=MA(CLOSE,5);
MA2:=MA(CLOSE,10);
MA3:=MA(CLOSE,20);
MA4:=MA(CLOSE,60);
MA5:=MA(CLOSE,120);
MA6:=MA(CLOSE,250);
A:MAX(MAX(MA1,MA2),MA3),LINETHICK0;
B:MIN(MIN(MA1,MA2),MA3),LINETHICK0;
三线粘合:IF(RANGE(100*(A-B)/B,0,5),100*(A-B)/B,DRAWNULL),LINETHICK0;
SA:MAX(MAX(MA1,MA2),MAX(MA3,MA4)),LINETHICK0;
SB:MIN(MIN(MA1,MA2),MIN(MA3,MA4)),LINETHICK0;
四线粘合:IF(RANGE(100*(SA-SB)/SB,0,10),100*(SA-SB)/SB,DRAWNULL),LINETHICK0;
WA:MAX((MAX(MA1,MA2),MAX(MA3,MA4)),MA5),LINETHICK0;
WB:MIN((MIN(MA1,MA2),MIN(MA3,MA4)),MA5),LINETHICK0;
五线粘合:IF(RANGE(100*(WA-WB)/WB,0,15),100*(WA-WB)/WB,DRAWNULL),LINETHICK0;
LA:MAX((MAX(MA1,MA2),MAX(MA3,MA4)),MAX(MA5,MA6)),LINETHICK0;
LB:MIN((MIN(MA1,MA2),MIN(MA3,MA4)),MIN(MA5,MA6)),LINETHICK0;
六线粘合:IF(RANGE(100*(LA-LB)/LB,0,20),100*(LA-LB)/LB,DRAWNULL),LINETHICK0;
MA1赋值:收盘价的5日简单移动平均
MA2赋值:收盘价的10日简单移动平均
MA3赋值:收盘价的20日简单移动平均
MA4赋值:收盘价的60日简单移动平均
MA5赋值:收盘价的120日简单移动平均
MA6赋值:收盘价的250日简单移动平均
输出A:MA1和MA2的较大值和MA3的较大值,LINETHICK0
输出B:MA1和MA2的较小值和MA3的较小值,LINETHICK0
输出三线粘合:如果100*(A-B)/B位于0和5之间,返回100*(A-B)/B,否则返回无效数,LINETHICK0
输出SA:MA1和MA2的较大值和MA3和MA4的较大值的较大值,LINETHICK0
输出SB:MA1和MA2的较小值和MA3和MA4的较小值的较小值,LINETHICK0
输出四线粘合:如果100*(SA-SB)/SB位于0和10之间,返回100*(SA-SB)/SB,否则返回无效数,LINETHICK0
输出WA:(MA1和MA2的较大值,MA3和MA4的较大值)和MA5的较大值,LINETHICK0
输出WB:(MA1和MA2的较小值,MA3和MA4的较小值)和MA5的较小值,LINETHICK0
输出五线粘合:如果100*(WA-WB)/WB位于0和15之间,返回100*(WA-WB)/WB,否则返回无效数,LINETHICK0
输出LA:(MA1和MA2的较大值,MA3和MA4的较大值)和MA5和MA6的较大值的较大值,LINETHICK0
输出LB:(MA1和MA2的较小值,MA3和MA4的较小值)和MA5和MA6的较小值的较小值,LINETHICK0
输出六线粘合:如果100*(LA-LB)/LB位于0和20之间,返回100*(LA-LB)/LB,否则返回无效数,LINETHICK0


一、选股时间:30分钟K线图
1、移动平均线:把30分钟的移动平均线参数设定为:13、77、99。
特殊图形 一、大前提:以13均线的形态为准,以77均线、99均线基本走平或粘合走平为前提。
二、图形分类:
①高低脚:13 均线出现双底形态,以左脚低,右脚高为有效图形,做右脚时最好无量,试探买入点为在底部形成后,K线以小阴小阳方式运行在13均线之上,同时MACD的DIF已金叉MACD,加仓买入点为出现放量阳线站到三均线之上,MACD的红柱拉长之时。
②三线粘: 所谓“三线粘”不是一个绝对的粘合概念,在观察本图形时请缩小一档图形,只要13、77、99 三均线基本上在一个很小的窄幅范围内水平运行就可,完全粘合最佳,关键是“三线粘其间最好是无量做形态”。本图形又包括三个类型:
A:线上粘:13平均线在77、99 之上平行、水平运行。
B:线中粘:13均线在77、99 两均线之间的空隙中基本水平运行。
C:线下粘:13均线在77、99之下平行、水平运行。本图形的买入点是在粘合运行(或平行运行)的末期,MACD金叉后红柱持续拉长,股价出现放量的中小阳线,放量是相对前面的量相对而言,没有硬指标),站在三均线之上就可以买进.。
③锅底形(也称圆弧底包括二个类型):
A:园锅底:13均线形成一个标准的小圆弧底,股价由锅底外运行到锅底内,即股价由均线下方运行到均线上方,K线以小阴小阳最佳,(阳多阴少更佳),无量做锅底最好。
B:平锅底:13均线形成一个相对平坦的水平底,股价也是由锅底外运行至锅底内,以小阴小阳的方式最佳 (阳多阴少更佳),本图形的试探买入点是股价运行到锅底内,MACD已金叉时可小量买入待涨,加仓买入点是在股价放量站到期77、99均线之上,同时MACD红柱加长之时。
④一线金叉
77日、99日线高度粘合形同一条线,这时13日线由下方上穿这两条线形成金叉,此后股价都有较大涨幅。介入点最好选择在金叉后回调到13日线附近,这样安全可靠。
三、健康良好的均线系统不应“过分”向上发散(尽管这意味强势,单只能是短线强势),而良好的均线形态应是短中长期均线均保持同步平行匀速向上的,这样的涨势长久而稳健。

原创文章,作者:TTone,如若转载,请注明出处:https://www.qianglongwang.com/3873.html

联系我们