1. 股票论坛首页
  2. 股票公式
  3. 同花顺公式

KDJ加强指标公式详解 同花顺KDJ

指标代码及说明:

使用19,8,8参数,其它的跟KDJ没区别

N1:=5;

N2:=10;

N3:=20;

N4:=30;

EMA7:=EMA(C,7);

BBI:=(MA(CLOSE,N1)+MA(CLOSE,N2)+MA(CLOSE,N3)+MA(CLOSE,N4))/4;

//不准

过渡:IF(BBI,10,DRAWNULL),colorwhite,LINETHICK9;

持股:IF(C>BBI AND BBI>REF(BBI,1),10,DRAWNULL), colorred,LINETHICK9;

持币:IF(C<=BBI AND BBI<=REF(BBI,1),10,DRAWNULL),colorgreen,LINETHICK9;

DRAWICON(CROSS(EMA7,BBI),7,1);

DRAWICON(CROSS(BBI,EMA7),0,2);

//19,8,8参数优于9,3,3

//http://www.55188.com/thread-5643012-1-1.html

RSV=(CLOSE-LLV(LOW,19))/(HHV(HIGH,19)-LLV(LOW,19))*100;

a=SMA(RSV,8,1);

b=SMA(a,8,1);

e=3*a-2*b;

IF(a<0) a=0;

IF(a>100) a=100;

IF(b<0) b=0;

IF(b>100) b=100;

IF(e<0) e=0;

IF(e>100) e=100;

K:a,colorwhite;

D:b,color0066FF;

J:e,COLORFF00FF;

//强势区

强:80,colorgray;

//强弱分界

分界:50,colorred;

//弱势区

弱:20,colorgray;

r2:=(WAITBUYMONEY1+BIGBUYMONEY1-BIGSELLMONEY1-WAITSELLMONEY1+WAITBUYMONEY2+BIGBUYMONEY2-BIGSELLMONEY2-WAITSELLMONEY2+WAITBUYMONEY3+BIGBUYMONEY3-BIGSELLMONEY3-WAITSELLMONEY3);

人气总:=r2,coloryellow,nodraw;

R1:=(BIGBUYMONEY1+BIGBUYMONEY2+BIGBUYMONEY3-BIGSELLMONEY1-BIGSELLMONEY2-BIGSELLMONEY3);

人气主动:=r1,colorff00ff,nodraw;

零点:=0;

MA5:=MA(C,5);

流:=SHGZG/100;

总占流:=人气总*10/SHGZG;

人占流:=人气主动*10/SHGZG;

倍数:=总占流/人占流;

玉2:=2;

平:=0.3;

r:=1000000*(ZDMCCS[-1]+BDMCCS[-1]-(ZDMRCS[-1]+BDMRCS[-1]))/(SHGZG/(VOL/VOLAMOUNT));

散户:=r,colorlicyan,nodraw;

玉:=0;

总大:=人气总>人气主动 AND 人气总>零点 AND 人气总>流 AND 人气主动>零点 AND 总占流>平 AND 倍数>玉2 AND 玉>散户;

总大1:=人气总>人气主动 AND 人气总>零点 AND 人气总>流 AND 人气主动>零点 AND 倍数>玉 AND 玉>散户 ;

人气总和:=SUM(人气总,30);

人气主动和:=SUM(人气主动,30);


原创文章,作者:TTone,如若转载,请注明出处:https://www.qianglongwang.com/60993.html

联系我们