1. 股票论坛首页
  2. 股票公式
  3. 通达信公式

通达信凌波微步源码副图无未来函数

以下是通达信凌波微步源码副图无未来函数(无源码的请下载附件导入)


A1A:=EMA(CLOSE, 9);

A1B:=((A1A - EMA(CLOSE, 5)) < 0);

A1C:=((A1A - EMA(CLOSE, 5)) > 0);

A1D:=BARSLAST(A1B);

A1E:=BARSLAST(A1C);

A1F:=IF((A1E > 0),(CLOSE - REF(CLOSE, 1)) / REF(CLOSE, 1) * 100,0);

A20:=SUM(A1F,0);

A21:=IF((A1D > 0),(0 - 2),0);

A22:=IF((A1E > 0),SUM((CLOSE - REF(CLOSE, 1)) / REF(CLOSE, 1) * 100,A1E),0);

A23:=A22 / A1E;

A25:=EMA(EMA(EMA(CLOSE, 3), 3), 3);

多方:((A25 - REF(A25, 1)) + A25)COLOR0000FF,LINETHICK2;

空方:MA(多方, 15)COLORFF49FF;

IF(多方>REF(多方,1),多方,DRAWNULL),COLORFFFFCC,LINETHICK4,POINTDOT;

IF(空方>REF(空方,1),空方,DRAWNULL),COLOR00FFFF,LINETHICK4,POINTDOT;

STICKLINE((多方 > 空方),空方,多方, 0, 0)COLOR00FFFF;

STICKLINE((空方 > 多方),多方,空方, 0, 0)COLORFF0000;

DRAWTEXT(CROSS(空方,多方),多方 * 1.03,'↓卖')COLOR00FF00;

DRAWTEXT(CROSS(多方,空方),空方 * 0.98,'↑买')COLOR0000FF;

DRAWICON(((REF(A21, 1) = (0 - 2)) AND (A21 = 0)),LOW, 5);

DRAWICON(((REF(A1E, 1) > 0) AND (A1E = 0)),HIGH, 6);

大盘指数:INDEXC,NODRAW,COLORLIMAGENTA ;

大盘指数涨跌:(大盘指数-REF(大盘指数,1)),NODRAW;

涨家数:INDEXADV,NODRAW,COLORLIMAGENTA ;

跌家数:INDEXDEC,NODRAW,COLORGREEN;

C3:=REF(C,1);

涨停:=IF((C-C3)*100/C3>=(10-0.01*100/C3),1,0);

STICKLINE(涨停,OPEN,CLOSE,2.5,0),COLORYELLOW;

跌停:=IF((C3-C)*100/C3>=(10-0.01*100/C3),1,0);

STICKLINE(跌停,OPEN,CLOSE,2.5,0),COLORBLUE;

安全线: MA(CLOSE,30),LINETHICK2,COLORBLUE;

VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);

VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VARA:=REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VARB:=REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VARD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);

VARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR12:=REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR14:=REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR16:=REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR18:=REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;

DRAWICON(VAR19,L*0.98,1);

原创文章,作者:TTone,如若转载,请注明出处:https://www.qianglongwang.com/61048.html

联系我们