1. 股票论坛首页
  2. 股票公式
  3. 同花顺公式

金GE测试

指标说明及代码

大机构仓位:100*(1-WINNER(CLOSE)),colorred,LINETHICK3;

VAR2:=1/WINNER(CLOSE);

VAR3:=MA(CLOSE,13);

VAR4:=100-ABS((CLOSE-VAR3)/VAR3*100);

VAR5:=LLV(LOW,120);

VAR6:=HHV(HIGH,120);

VAR7:=(VAR6-VAR5)/100;

VAR8:=SMA((CLOSE-VAR5)/VAR7,20,1);

VAR9:=SMA((OPEN-VAR5)/VAR7,20,1);

VARA:=3*VAR8-2*SMA(VAR8,10,1);

VARB:=3*VAR9-2*SMA(VAR9,10,1);

VARC:=100-VARB;

VARE:=REF(LOW,1)*0.9;

VARF:=LOW*0.9;//强龙网www_qianglongwang_com

VAR10:=(VARF*VOL+VARE*(CAPITAL-VOL))/CAPITAL;

VAR11:=EMA(VAR10,30);

VAR12:=CLOSE-REF(CLOSE,1);

VAR13:=MAX(VAR12,0);

VAR14:=ABS(VAR12);

VAR15:=SMA(VAR13,7,1)/SMA(VAR14,7,1)*100;

VAR16:=SMA(VAR13,13,1)/SMA(VAR14,13,1)*100;

VAR17:=BARSCOUNT(CLOSE);

VAR18:=SMA(MAX(VAR12,0),6,1)/SMA(ABS(VAR12),6,1)*100;

VAR19:=(-200)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+100;

VAR1A:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;

VAR1B:=SMA((SMA(VAR1A,4,1)-50)*2,3,1);

VAR1C:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;

VAR1D:=SMA(VAR1C,4,1);

VAR1E:=SMA(VAR1D,3,1);

VAR1F:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;

VAR20:=VAR18<=25 AND VAR19<-95 AND VAR1F>20 AND VAR1B<-30 AND VAR1E<30 AND VAR11-CLOSE>=-0.25 AND VAR15<22 AND VAR16<28 AND VAR17>50;

VAR21:=(HIGH+LOW+CLOSE)/3;//强龙网www_qianglongwang_com

VAR22:=(VAR21-MA(VAR21,14))/(0.015*AVEDEV(VAR21,14));

VAR23:=(VAR21-MA(VAR21,70))/(0.015*AVEDEV(VAR21,70));

VAR24:=IF(VAR22>=150 AND VAR22<200 AND VAR23>=150 AND VAR23<200,10,0);

VAR25:=IF(VAR22<=-150 AND VAR22>-200 AND VAR23<=-150 AND VAR23>-200,-10,VAR24);

STICKLINE(VAR20,0,80,5,0),LINETHICK4,colorred;

DRAWTEXT(CROSS(VAR20,0.5) AND COUNT(VAR20=1,10)=1,90,'超级主力建仓!') , colorred;

VARE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;

VARF:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA

((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);

VAR10:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA

((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);

VAR11:=VARF<REF(VAR10,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);

DRAWTEXT(VAR11 AND COUNT(VAR11,30)=1,70,'大资金进场'),LINETHICK1,colorlimagenta;

STICKLINE(VAR11 AND COUNT(VAR11,30)=1,1,60,5,0),colorlimagenta,LINETHICK4;

v1:=(C*2+H+L)/4*10;

V2:=EMA(V1,13)-EMA(V1,34);

V3:=EMA(V2,5);

V4:=2*(V2-V3)*5.5;

V5:=(HHV(INDEXH,8)-INDEXC)/(HHV(INDEXH,8)-LLV(INDEXL,8))*8;

V6:=EMA(3*V5-2*SMA(V5,18,1),5);

V7:=(INDEXC-LLV(INDEXL,8))/(HHV(INDEXH,8)-LLV(INDEXL,8))*10;

V8:=(INDEXC*2+INDEXH+INDEXL)/4;

V9:=EMA(V8,13)-EMA(V8,34);

VA:=EMA(V9,3);

VB:=(V9-VA)/2;

V11:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);

V12:=(EMA(V11,3)-REF(EMA(V11,3),1))/REF(EMA(V11,3),1)*100;

准备现金: STICKLINE(EMA(V11,3)<=13,0,15,5,0),colorlired;

AA:=(EMA(V11,3)<=13) AND FILTER((EMA(V11,3)<=13),15);

DRAWTEXT (AA,-10,'准备现金'),colorlired;

买入股票: STICKLINE(EMA(V11,3)<=13 AND V12>13,0,50,5,0),LINETHICK3,colorred;

BB:= (EMA(V11,3)<=13 AND V12>13) AND FILTER((EMA(V11,3)<=13 AND V12>13),10);

DRAWTEXT (BB,60,'主力进'),colorwhite;

卖临界: STICKLINE(EMA(V11,3)>60 AND EMA(V11,3)>REF(EMA(V11,3),1),100,95,15,1),colorgreen;

CC:=(EMA(V11,3)>=90 AND V12) AND FILTER((EMA(V11,3)>=90 AND V12),10);

DD:=(EMA(V11,3)>=120 AND V12) AND FILTER((EMA(V11,3)>=120 AND V12),10);

STICKLINE(IF(VB>=0,VB,0) AND EMA(V11,3)<13,0,15,5,0),colorlired;

STICKLINE(IF(VB<=0,VB,0) AND EMA(V11,3)>90,0,10,10,0),colorgreen;

STICKLINE( IF(V4>=0,V4,1) AND EMA(V11,3)<13,0,15,5,0),colorlired;

STICKLINE(IF(V4<=0,V4,1) AND EMA(V11,3)>90,0,10,10,0),colorliblue,LINETHICK1;

DRAWTEXT (CC,20,'主力减仓'),colorliblue;

V10:=PEAKBARS(3,15,1)<10; V12:=IF(V10=1,50,0);

头部:= IF(V12=50,100,0);

卖:IF(IF(V12=50,100,0)>REF(IF(V12=50,100,0),1),40,0),colorgreen,LINETHICK3;

DRAWTEXT(卖,50,'主力清仓 '),colorgreen;

V9:=TROUGHBARS(3,15,1)<10; V11:=IF(V9=1,50,0);

底部:= IF(V11=50,50,0);

买:IF( 底部>REF(底部,1),40,0),colorred,LINETHICK4;

DRAWTEXT(买,50,'主力抄底 '),colorred;

V7:=TROUGHBARS(3,15,1)<10; V9:=IF(V7=1,50,0);

AA:=(O+H+L+C)/4;

BB:=MA(AA,3);

CC:=SUM(IF(AA>REF(AA,1),AA*VOL,0),4)/SUM(IF(AA<REF(AA,1),AA*VOL,0),4);

DD:=REF(100-(100/(1+CC)),1);

a1:=HHV(AA,10);

a2:=LLV(AA,30);

a3:=a1-a2;

a4:=EMA((AA-a2)/a3,1)*100;

b1:=HHV(AA,16);

b2:=LLV(AA,90);

b3:=b1-b2;

b4:=EMA((AA-b2)/b3,1)*100;

C1:=HHV(AA,30);

C2:=LLV(AA,240);

C3:=C1-C2;

C4:=EMA((AA-C2)/C3,1)*100;

STICKLINE(a4>90 AND b4>70,86,94,6,0),coloryellow;

STICKLINE(a4<5 AND b4<30,0,15,6,0),colorwhite;

DRAWTEXT((a4>90 AND b4>70)=1, 85,'拉'),coloryellow;

D:=CROSS(ZIG(3,50/5)*1,MA(ZIG(3,50/5)*1,2))*1,colorred;

W:=CROSS(MA(ZIG(3,50/5)*1,2),ZIG(3,50/5)*1)*1,colorblue;

Var1:=(2*CLOSE+HIGH+LOW+OPEN)/5;

Var2:=LLV(LOW,34);

Var3:=HHV(HIGH,34);

多: EMA((Var1-Var2)/(Var3-Var2)*100,13),colorred,LINETHICK2;

空: EMA(多,3),colorgreen,LINETHICK1;

DRAWTEXT(W=1,多*-0.1,'▼下跌确立' ),colorgreen;

DRAWTEXT(D=1,多*-0.31,'▲上涨确立'),colorred;

原创文章,作者:TTone,如若转载,请注明出处:https://www.qianglongwang.com/61053.html

联系我们