1. 股票论坛首页
  2. 股票公式
  3. 通达信公式

通达信三周期观察买入点副图源码

以下是通达信三周期观察买入点副图源码(无源码的请下载附件导入)

AA:=(O+H+L+C)/4;

BB:=MA(AA,3);

CC:=SUM(IF(AA>REF(AA,1),AA*VOL,0),4)/SUM(IF(AA<REF(AA,1),AA*VOL,0),4);

DD:=REF(100-(100/(1+CC)),1);

A1:=HHV(AA,15);

A2:=LLV(AA,15);

A3:=A1-A2;

A4:=EMA((AA-A2)/A3,2)*100;

B1:=HHV(AA,60);

B2:=LLV(AA,60);

B3:=B1-B2;

B4:=EMA((AA-B2)/B3,2)*100;

C1:=HHV(AA,240);

C2:=LLV(AA,240);

C3:=C1-C2;

C4:=EMA((AA-C2)/C3,2)*100;

短期:A4,COLORGREEN;

中期:B4,COLORYELLOW;

长期:C4,COLORFF00FF;

STICKLINE(短期>90 AND 中期>70,86,94,6,0),COLOR00FF00;

STICKLINE(短期<5 AND 中期<30,0,8,6,0);

IF(FILTER(中期<REF(中期,1)AND 中期>90 AND BB<REF(BB,1),5),80,100),COLORBLUE,LINETHICK2;

IF(FILTER(中期>REF(中期,1)AND 中期<5 AND C>REF(C,1),5),20,0),COLORRED,LINETHICK2;

D1:=中期>REF(中期,1)AND 短期>REF(短期,1)AND 长期>REF(长期,1)AND 长期<8 AND 中期<10 AND 短期<15;

D2:=CROSS(短期,中期)AND 中期<8;

D3:=CROSS(短期,长期)AND 长期<8 AND 中期<20;

DRAWICON(FILTER((D1 OR D2 OR D3) AND DD<15 AND C>REF(C,1),5),5,1);

DRAWICON(FILTER((中期<REF(中期,1)AND 短期<REF(短期,1)AND 长期<REF(长期,1)AND 中期>95 AND 短期>85)OR (长期>100 AND 中期>100 AND 短期>100),5),95,2);

强弱分界:50, POINTDOT,COLORWHITE;

警戒区:90,LINETHICK1,COLORWHITE;

安全区:20,COLORFFFF00;

原创文章,作者:TTone,如若转载,请注明出处:https://www.qianglongwang.com/61123.html

联系我们