1. 股票论坛首页
  2. 股票公式
  3. 通达信公式

稳健追涨

指标说明及代码

MA1:=EMA(CLOSE,5),COLOR00FF00; MA2:=EMA(CLOSE,10),COLORFFCC66; MA3:=EMA(CLOSE,15); MA4:=EMA(CLOSE,30),COLORFF00FF; MAA:=EMA(CLOSE,60),COLORBLUE,LINETHICK2; MA5:IF(MA1<MA4,MA1,MA4),COLOR00FF00; IF(MA1<MA4,MA4,MA1),COLORYELLOW; MA10:IF(MA2<MA4,MA2,MA4),COLORFFCC66; IF(MA2<MA4,MA4,MA2),COLOR0099FF; MA15:IF(MA3<MA4,MA3,MA4),COLORWHITE; IF(MA3<MA4,MA4,MA3),COLORBLUE; MA30:IF(MA4<MAA,MA4,MAA),COLORFF00FF; IF(MA4<MAA,MAA,MA4),COLORRED,LINETHICK2; MA60:IF(MA4>MAA,MAA,MAA),LINETHICK2,COLORBLUE; VAR1:=MAX(MA1,MAX(MA2,MAX(MA3,MA4))); VAR2:=MIN(MA1,MIN(MA2,MIN(MA3,MA4))); VAR3:=(VAR1-VAR2)/VAR2*1000; VAR4:=MA1>REF(MA1,1) AND MA2>REF(MA2,1) AND MA3>REF(MA3,1) AND MA4>REF(MA4,1) AND MA5>REF(MA5,1); VAR5:=VAR3<5; VAR6:=COUNT(VAR5=1,5)>0; VAR7:=CROSS(MA1,MA4); VAR8:=VAR4 AND VAR6 AND VAR7; VAR9:=VAR4 AND VAR5<3; DRAWICON(VAR3<2 AND VAR4,LOW,1); DRAWICON(VAR8,LOW*0.99,1); VAR1A:=CROSS(MA(CLOSE,5),MA(CLOSE,30)); DRAWICON(VAR1A,LOW-LOW*0.01,1); {////强龙网www_qianglongwang_com} DRAWTEXT(VAR1A AND CLOSE>MA(CLOSE,250),LOW-LOW*0.03,'少量买 '),COLORWHITE; DRAWTEXT(VAR1A AND CLOSE>=MA(CLOSE,60) AND CLOSE<=MA(CLOSE,250),LOW-LOW*0.02,'半仓买'),COLORYELLOW; DRAWTEXT(VAR1A AND CLOSE<MA(CLOSE,60),LOW-LOW*0.03,'全仓买 '),COLORFF00FF;

原创文章,作者:TTone,如若转载,请注明出处:https://www.qianglongwang.com/61195.html

联系我们