1. 股票论坛首页
  2. 股票公式
  3. 通达信公式

通达信丑小鸭主图指标源码

以下是通达信丑小鸭主图指标源码(无源码的请下载附件导入)


丑小鸭(主图)-指标公式源码

MA5:MA(CLOSE,5),COLORRED;

A:=IF(MA5>REF(MA5,1), MA5,REF(MA5,1)),COLORRED;

A1:=IF(MA5<=REF(MA5,1), MA5,REF(MA5,1)),COLORBLUE;

DRAWBAND(MA5,RGB(250,0,0),A,RGB(0,0,255));

DRAWBAND(MA5,RGB(250,0,0),A1,RGB(0,0,255));

MA20:MA(CLOSE,20),COLORRED;

B:=IF(MA20>REF(MA20,1), MA20,REF(MA20,1)),COLORRED;

DRAWBAND(MA20,RGB(250,0,0),B,RGB(250,0,0));

MA60:MA(CLOSE,60),COLORBLUE;

BB:=IF(MA60>REF(MA60,1), MA60,REF(MA60,1)),COLORBLUE;

DRAWBAND(MA60,RGB(0,0,250),BB,RGB(0,0,255));

VAR1:=CLOSE/MA(CLOSE,20)*100<80;
VAR2:=CLOSE/MA(CLOSE,40)*100<78;
VAR3:=CLOSE/MA(CLOSE,60)*100<72;
VAR4:=HIGH>LOW*1.051;
VAR5:=VAR4 AND COUNT(VAR4,5)>1;

蛋:=VAR5 AND (VAR1 OR VAR2 OR VAR3)AND FILTER(VAR5 AND (VAR1 OR VAR2 OR VAR3),10);

DRAWTEXT(蛋,LOW*0.93,'蛋'),COLORFF00FF;

STICKLINE(蛋,L*0.97,LOW*0.93,0,0), COLORYELLOW;

N:=BARSLAST(蛋);

蛋价:=REF(L,N),COLORGREEN;

生:=(C=蛋价 OR CROSS(C,蛋价) OR CROSS(蛋价,L)OR CROSS(蛋价,C));

DRAWTEXT(生,LOW*0.93,'生'),COLORRED;

STICKLINE(生,L*0.97,LOW*0.93,0,0), COLORYELLOW;

丑小鸭:=CROSS(C,REF(HHV(HIGH,N),1))AND REF(HHV(HIGH,N),1)=REF(HHV(HIGH,N),2)AND REF(HHV(HIGH,N),2)=REF(HHV(HIGH,N),3)AND REF(HHV(HIGH,N),3)=REF(HHV(HIGH,N),4);

DRAWTEXT(丑小鸭,H*1.05,'鸭'),COLORYELLOW;

STICKLINE(丑小鸭,H*1.02,H*1.05,0,0), COLORYELLOW;

DRAWKLINE(HIGH,OPEN,LOW,CLOSE);

原创文章,作者:TTone,如若转载,请注明出处:https://www.qianglongwang.com/61319.html

联系我们