1. 股票论坛首页
  2. 股票公式
  3. 同花顺公式

同花顺 提示买卖点¥ 同花顺说买就买 源码

指标说明及代码

//提示买卖点¥ 同花顺说买就买

Var3:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;

Var4:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;

Var5:=(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100;

Var6:=(Var3+Var4+Var5)/3;

Var7:=EMA(Var6,5);

指标: EMA(EMA(Var3,5),5)*3, COLORSTICK;

Var8:=IF(Var6<=-20,10,0);

Var9:=HHV(Var8,10);

STICKLINE(Var8=10,20,10,5,0),COLOR6666FF;

VarA:=IF(Var9 AND CROSS(MA(CLOSE,3),MA(CLOSE,5)),20,0);

DRAWTEXT(VarA=20,15,'底部'),linethick1,colorwhite;

STICKLINE((VarA=20),0,10,5,0),colorwhite;

VARC:=(ZIG(3,5)>REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2)) AND (REF(ZIG

(3,5),2)<=REF(ZIG(3,5),3));

VARD:=(ZIG(3,5)<REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)>=REF(ZIG(3,5),2)) AND (REF(ZIG

(3,5),2)>=REF(ZIG(3,5),3));

STICKLINE((VARC=1),(-14),0,4,0),Color0000FF;

DRAWTEXT((VARC=1),(-14),'建议买入'),Color0000FF;

STICKLINE((VARD=1),14,0,4,0),Color00FF00;

DRAWTEXT((VARD=1),18,'建议卖出'),Color00FF00;

VarE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;

VarF:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA

((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);

Var10:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA

((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);

Var11:=VarF<REF(Var10,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);

DRAWTEXT(Var11 AND COUNT(Var11,30)=1,15,'大资金活动'),linethick1,COLORff00ff;

STICKLINE(Var11 AND COUNT(Var11,30)=1,1,10,5,0),colorff00ff;

Var12:=(HIGH+LOW+CLOSE)/3;

Var13:=(Var12-MA(Var12,14))/(0.015*AVEDEV(Var12,14));

Var14:=(Var12-MA(Var12,70))/(0.015*AVEDEV(Var12,70));

Var15:=IF(Var13>=150 AND Var13<200 AND Var14>=150 AND Var14<200,10,0);

Var16:=IF(Var13<=-150 AND Var13>-200 AND Var14<=-150 AND Var14>-200,-10,Var15);

Var17:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;

Var18:=100-ABS(Var17);

Var19:=IF(Var18<90,Var18,100);

原创文章,作者:(大熊)与水晶,如若转载,请注明出处:https://www.qianglongwang.com/61356.html

联系我们