1. 股票论坛首页
  2. 股票公式
  3. 同花顺公式

同花顺 杨氏MACD面积 源码

指标说明及代码

DIFF :EMA(CLOSE,12) - EMA(CLOSE,26),COLOR0000FF,LINETHICK2;

DEA :EMA(DIFF,9),COLOR00FFFF,LINETHICK2;

MACD := 2*(DIFF-DEA);

ZERO:0;

STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,16,0),COLORB50FA8;

STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,15,0),COLORFF00FF;

STICKLINE(MACD>0 AND MACD<REF(MACD,1),MACD,0,15,0),COLOR0000FF;

STICKLINE(MACD>0 AND MACD<REF(MACD,1),MACD,0,15,0),COLOR00FFFF;

STICKLINE(MACD<0 ,MACD,0,16,0),COLOR007500;//强龙网www_qianglongwang_com

STICKLINE(MACD<0 AND MACD>REF(MACD,1),MACD,0,16,0),COLORFF0000;

B:=ZIG(3,15/5)*100,colorwhite;

G:=MA(B,2),coloryellow;

D:=CROSS(B,G)*1000,colorred;

W:=CROSS(G,B)*1000,colorblue;

DRAWGBK( W=1000 ),colorblue;

DRAWGBK( D=1000 ),colorlired;

遵:IF(DIFF>=DEA,DIFF,DRAWNULL),colorred,LINETHICK3;

守:IF(DEA>=DIFF,DEA,DRAWNULL),COLORFF9900,LINETHICK3;

纪:IF(DIFF>=DEA,DEA,DRAWNULL),COLOR00FFFF,LINETHICK3;

律:IF(DEA>=DIFF,DIFF,DRAWNULL),COLOR00FF00,LINETHICK3;

FILLRGN(DIFF,DEA,DIFF>DEA AND DIFF>0 AND DIFF>REF(DIFF,1) AND DEA>REF(DEA,1),colorlired);

FILLRGN(DIFF,DEA,DIFF>DEA AND DIFF>0 AND DIFF>REF(DIFF,1) AND DEA<REF(DEA,1),colorwhite);

FILLRGN(DIFF,DEA,DIFF>DEA AND DIFF>0 AND DIFF<=REF(DIFF,1) AND DEA>REF(DEA,1),colorwhite);

FILLRGN(DIFF,DEA,DIFF>DEA AND DIFF>0 AND DIFF<=REF(DIFF,1) AND DEA<REF(DEA,1),colorwhite);

FILLRGN(DIFF,DEA,DIFF>DEA AND DIFF<0 AND DIFF>REF(DIFF,1) AND DEA>REF(DEA,1),colorred);

FILLRGN(DIFF,DEA,DIFF>DEA AND DIFF<0 AND DIFF>REF(DIFF,1) AND DEA<REF(DEA,1),colorwhite);

FILLRGN(DIFF,DEA,DIFF>DEA AND DIFF<0 AND DIFF<=REF(DIFF,1) AND DEA>REF(DEA,1),colorwhite);

FILLRGN(DIFF,DEA,DIFF>DEA AND DIFF<0 AND DIFF<=REF(DIFF,1) AND DEA<REF(DEA,1),colorwhite);

FILLRGN(DIFF,DEA,DIFF<DEA AND DIFF>0 AND DIFF<REF(DIFF,1) AND DEA>REF(DEA,1),colorwhite);

FILLRGN(DIFF,DEA,DIFF<DEA AND DIFF>0 AND DIFF<REF(DIFF,1) AND DEA<REF(DEA,1),colorgreen);

FILLRGN(DIFF,DEA,DIFF<DEA AND DIFF>0 AND DIFF>=REF(DIFF,1) AND DEA>REF(DEA,1),colorwhite);

FILLRGN(DIFF,DEA,DIFF<DEA AND DIFF>0 AND DIFF>=REF(DIFF,1) AND DEA<REF(DEA,1),colorwhite);

FILLRGN(DIFF,DEA,DIFF<DEA AND DIFF<0 AND DIFF<REF(DIFF,1) AND DEA>REF(DEA,1),colorwhite);

FILLRGN(DIFF,DEA,DIFF<DEA AND DIFF<0 AND DIFF<REF(DIFF,1) AND DEA<REF(DEA,1),colorblue);

FILLRGN(DIFF,DEA,DIFF<DEA AND DIFF<0 AND DIFF>=REF(DIFF,1) AND DEA>REF(DEA,1),colorwhite);

FILLRGN(DIFF,DEA,DIFF<DEA AND DIFF<0 AND DIFF>=REF(DIFF,1) AND DEA<REF(DEA,1),colorwhite);

原创文章,作者:(大熊)与水晶,如若转载,请注明出处:https://www.qianglongwang.com/61366.html

联系我们