1. 股票论坛首页
  2. 股票公式
  3. 通达信公式

通达信时空规则买卖*主图附图指标

以下是通达信时空规则买卖*主图附图指标(无源码的请下载附件导入)


时空规则买卖*
是取某一时间段高低点“浪型”用“黄金分割 与1/3 ,2/3 及 涨幅度线”对下跌或上涨过程中的支撑与压力预期值的预判!!
在图上的彩带是任意均价线与EMA17的值间以彩带呈现。调整均价线>EMA17时均价线与EMA17间呈红。

并有【RSI>76或RSI>80股价大于布林线上轨线 KD MACD一些性质】以图标作为提示。如图!!

{RQ1(1990,3000,2010),RQ2(1,12,1),RQ3(1,31,1),RQA(1990,3000,2010),RQB(1,12,1),RQC(1,31,1),XG(0,3,0),HF(0,1,0),GF(0,5,0),P(0,255,3),P1(0,255,3)}
RQG:=(RQ1-1900)*10000+RQ2*100+RQ3;

AH:=REF(H,BARSLAST(DATE<=RQG )),NODRAW;

高价:IF(DATE>=RQG AND XG>=1,AH,DRAWNULL),COLOR00FFFF;

RQD:=(RQA-1900)*10000+RQB*100+RQC;{
DRAWTEXT(ISLASTBAR,AH,'【创与2011/02/28の草根】'),COLOR0000FF;}
DJ:=REF(L,BARSLAST(DATE<=RQD )),NODRAW;

低价:IF(DATE>=RQD AND XG>=1,DJ,DRAWNULL),COLORFFFF00;

FU:=C-低价;

低到当前幅度:FU/低价*100,NODRAW,COLOR00FFFF;

FUGA:=高价-低价;

高到低价幅度%:FUGA/高价*100,NODRAW,COLOR00FFFF;

AS:=(O+H+L+C)/4;

SY:=EMA(AS,P);

BL:=EMA(AS,17);

DRAWBAND(SY,RGB(139,10,10),BL,RGB(0,100,0));

STICKLINE(C>=O,LOW,HIGH,0,0),COLOR0000FF;

STICKLINE(C>=O,CLOSE,OPEN,2.8,1),COLOR1020EE;

STICKLINE(C<=O,LOW,HIGH,0,0),COLORFF8800;

STICKLINE(C<=O,CLOSE,OPEN,2.8,0),COLORFFCC00;

低价A:IF(DATE>=RQD AND GF>=1,DJ*1.03,DRAWNULL),COLOR999999;

低价B:IF(DATE>=RQD AND GF>=1,DJ*1.05,DRAWNULL),COLOR999999;

低价C:IF(DATE>=RQD AND GF>=2,DJ*1.08,DRAWNULL),COLOR999999;

低价D:IF(DATE>=RQD AND GF>=2,DJ*1.13,DRAWNULL),COLOR999999;

低价E:IF(DATE>=RQD AND GF>=3,DJ*1.18,DRAWNULL),COLOR999999;

低价F:IF(DATE>=RQD AND GF>=3,DJ*1.25,DRAWNULL),COLOR999999;

低价G:IF(DATE>=RQD AND GF>=4,DJ*1.34,DRAWNULL),COLOR999999;

低价H:IF(DATE>=RQD AND GF>=4,DJ*1.37,DRAWNULL),COLOR999999;

DRAWTEXT(ISLASTBAR AND GF>=1,DJ*1.03,'3%'),COLOR208FFF;

DRAWTEXT(ISLASTBAR AND GF>=1,DJ*1.05,'5%'),COLOR208FFF;

DRAWTEXT(DATE<=RQD AND GF>=2,低价C,'8%'),COLOR208FFF;

DRAWTEXT(DATE<=RQD AND GF>=2,低价D,'13%'),COLOR208FFF;

DRAWTEXT(DATE<=RQD AND GF>=3,低价E,'18%'),COLOR208FFF;

DRAWTEXT(DATE<=RQD AND GF>=3,低价F,'25%'),COLOR208FFF;

DRAWTEXT(DATE<=RQD AND GF>=3,低价G,'34%'),COLOR208FFF;

DRAWTEXT(DATE<=RQD AND GF>=3,低价H,'37%'),COLOR208FFF;

STICKLINE(DATE<=RQG,低价,高价,0,0),COLOR00FF00;

STICKLINE(DATE<=RQD,高价,低价,0,0),COLORFF00FF;

Q1:=(低价+(高价 - DJ) * 0.191)/高价;
Q2:=(低价+(高价 - DJ) * 0.382)/高价;
Q3:=(低价+(高价 - DJ) * 0.50)/高价;
Q4:=(低价+(高价 - DJ) * 0.618)/高价;
Q5:=(低价+(高价 - DJ) * 0.809)/高价;

Q6:=(低价+(高价 - DJ) * 0.333)/高价;
Q7:=(低价+(高价 - DJ) * 0.667)/高价;

ZH:=IF(HF,DATE<=RQG,DATE<=RQD),NODRAW;

高价A:IF(DATE>=RQD AND XG>=2,AH*Q1,DRAWNULL),COLOR007777,DOTLINE;

高价B:IF(DATE>=RQD AND XG>=2,AH*Q2,DRAWNULL),COLOR007777,DOTLINE;

高价C:IF(DATE>=RQD AND XG>=2,AH*Q3,DRAWNULL),COLOR007777,DOTLINE;

高价D:IF(DATE>=RQD AND XG>=2,AH*Q4,DRAWNULL),COLOR007777,DOTLINE;

高价E:IF(DATE>=RQD AND XG>=2,AH*Q5,DRAWNULL),COLOR007777,DOTLINE;

高价F:IF(DATE>=RQD AND XG>=2,AH*Q6,DRAWNULL),COLOR007700,LINETHICK3;

高价G:IF(DATE>=RQD AND XG>=2,AH*Q7,DRAWNULL),COLOR007700,LINETHICK3;

DRAWNUMBER(ZH,高价*Q1*1.008,高价*Q1),COLOR00FFFF;

DRAWNUMBER(ZH,高价*Q2*1.008,高价*Q2),COLOR00FFFF;

DRAWNUMBER(ZH,高价*Q3*1.008,高价*Q3),COLOR00FFFF;

DRAWNUMBER(ZH,高价*Q4*1.008,高价*Q4),COLOR00FFFF;

DRAWNUMBER(ZH,高价*Q5*1.008,高价*Q5),COLOR00FFFF;

DRAWNUMBER(ZH,高价*Q6*0.999,高价*Q6),COLOR00FF00;

DRAWNUMBER(ZH,高价*Q7*1.01,高价*Q7),COLOR00FF00;

SYA:EMA(AS,P1),LINETHICK2,COLORCCAACC;

LJ2:=(C-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;

LJF2:=(EMA(LJ2,3));

低:=18;

DI:=EMA(CLOSE,10) - EMA(CLOSE,22);

XG:=CROSS(LJF2,低);

DRAWICON(XG,L,11);

DRAWNUMBER(ISLASTBAR AND SYA,SYA*1.005,SYA);

BLS:= BL+2.58*STDP(C,20);

BL2:= BL+1.96*STDP(C,20);

DRAWICON(CROSS(H,BLS),H,2);

DRAWICON(CROSS(H,BL2),H*1.007,8);

DRAWNUMBER(ISLASTBAR AND BL,BL*1.005,BL);

XGM:=CROSS(SY,BL);

DRAWICON(CROSS(C,BL) AND BL>REF(BL,1) AND DI>REF(DI,1),L,9);

LC := REF(CLOSE,1);

RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;

GB:IF(RSI1>76,H*1.001,DRAWNULL),CIRCLEDOT,LINETHICK3,COLORFFFF00;

GBB:IF(RSI1>80,H*1.002,DRAWNULL),CROSSDOT,LINETHICK3,COLOR0000FF;

{
请设置计算参数:
时间高定位: PARAM#0 (调整年度)
时间高定位: PARAM#1 (调整月份)
时间高定位: PARAM#2 (调整日期)
时间低定位: PARAM#3 (调整年度)
时间低定位: PARAM#4 (调整月份)
时间低定位: PARAM#5 (调整日期)
调整数值1-2:: PARAM#6 显示高低点线及黄金分割线
调整数值0-1:: PARAM#7 调整前后低点转换显示数值
调整数值0-5:: PARAM#8 (显示百分比涨幅度线)
调整数值1-255:: PARAM#9 任意均价线与17EMA间色带
调整数值1-255:: PARAM#10 (显示任意均价线)}

原创文章,作者:TTone,如若转载,请注明出处:https://www.qianglongwang.com/61684.html

联系我们