1. 股票论坛首页
  2. 股票公式
  3. 通达信公式

通达信 短线主图 和谐完全加密通达信指标! 源码

指标说明及代码

{公式名称: 短线主图

用法注释:

1、金色K线、黄托底:买入信号;

2、蓝压顶为卖出信号——空心蓝方压顶为上升趋势中的高抛减仓信号,实心蓝方顶伴随中大阴线有效跌破多空线,多为波段下跌清仓卖出信号。股价跌破多空线反抽不过多空线或二次跌破一般是最后的波段卖出点。

3、多空线转红向上为上升趋势,转绿向下为下跌趋势。//整理

公式源码:}

M:=7;

黄底黄K买:0,NODRAW,COLORYELLOW;

蓝顶减仓卖:0,NODRAW,COLORFF9900;

多空线红升绿跌:0,NODRAW,COLORRED;

V1:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);

V2:=(1-6/100)*DMA(CLOSE,V1);

V3:=(1+6/100)*DMA(CLOSE,V1);

VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);

VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VARA:=REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VARB:=REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VARD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);

VARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR12:=REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR14:=REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR16:=REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR18:=REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;

VAR1A:=REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1) AND VARD;

JRH:=HHV(CLOSE,2);

JRL:=LLV(CLOSE,2);

X:=(3*CLOSE+2*LOW+OPEN+HIGH)/7;

多空线:(20*X+19*REF(X,1)+18*REF(X,2)+17*REF(X,3)+16*REF(X,4)+15*REF(X,5)+14*REF(X,6)+13*REF(X,7)+12*REF(X,8)+11*REF(X,9)+10*REF(X,10)+9*REF(X,11)+8*REF(X,12)+7*REF(X,13)+6*REF(X,14)+5*REF(X,15)+4*REF(X,16)+3*REF(X,17)+2*REF(X,18)+REF(X,20))/210,COLORRED;

TDXSTEP269:IF(多空线>REF(多空线,1),多空线,DRAWNULL),COLORRED,LINETHICK4;

TDXSTEP270:IF(多空线<REF(多空线,1),多空线,DRAWNULL),COLORGREEN,LINETHICK3;

【支撑线】:REFDATE(V2,DATE),POINTDOT,COLORCC66FF,LINETHICK4;

【阻力线】:REFDATE(V3,DATE),POINTDOT,COLORGREEN,LINETHICK4;

MA3:=MA((CLOSE+OPEN+2*LOW)/4,4);

MA5:=MA(CLOSE,5);

短线:MA((CLOSE+OPEN+LOW)/3,5);

TDXSTEP271:IF(短线<多空线,短线,DRAWNULL),COLORWHITE;

TDXSTEP272:IF(短线>多空线,短线,DRAWNULL),COLORRED;

涨幅:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;

上穿:=CROSS(CLOSE,多空线*1.01) OR (CROSS(CLOSE,多空线*1.01) AND CROSS(CLOSE,MA5)) OR (LOW<MA5 AND CLOSE>多空线*1.01) AND MA5<多空线;

黄底:=VAR19 AND (CLOSE>多空线 AND 多空线>REF(多空线,1) AND CLOSE>OPEN OR (CLOSE<多空线 AND 涨幅>=9) OR (CROSS(CLOSE,多空线) AND 涨幅>5) OR (CROSS(CLOSE,MA5) AND 涨幅>=8));

TDXSTEP273:STICKLINE(黄底 OR 上穿 AND CLOSE-OPEN>HIGH-CLOSE,LOW*0.995,LOW*0.985,4,0),COLORYELLOW;

TDXSTEP274:DRAWTEXT(VAR19 AND 涨幅>9.97 AND CLOSE<多空线,LOW*0.95,37),COLORMAGENTA;

蓝压顶:=VAR1A AND CLOSE>多空线 AND NOT(黄底 OR 上穿) OR (CROSS(短线,CLOSE) AND REF(VAR1A,1)<1);

TDXSTEP275:STICKLINE(蓝压顶 AND CLOSE>短线 AND HIGH>多空线,HIGH*1.015,HIGH*1.0055,4,1),COLORBLUE;

TDXSTEP276:STICKLINE(蓝压顶 AND CLOSE<短线 AND 涨幅<(-0.8) AND HIGH>多空线,HIGH*1.015,HIGH*1.005,4,1),COLORBLUE;

TDXSTEP277:STICKLINE(VAR1A AND COUNT(上穿,7)>0 AND CLOSE<MA5 AND HIGH>多空线,HIGH*1.013,HIGH*1.007,4,1),COLORBLUE;

TDXSTEP278:STICKLINE(VAR1A AND COUNT(黄底,7)>0 AND CROSS(多空线,CLOSE) AND HIGH>多空线,HIGH*1.014,HIGH*1.006,4,1),COLORBLUE;

A0:=(LOW+HIGH+CLOSE*2)/4;

工作:=EMA(A0,14);

度假:=EMA(A0,25);

A1X:=(工作-REF(工作,1))/REF(工作,1)*100;

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

K:=SMA(RSV,3,1);

D:=SMA(K,3,1);

J:=3*K-2*D;

金叉:=CROSS(J,D);

死叉:=CROSS(D,J);

买1:=VAR14 OR VAR15 AND VAR11;

买2:=VAR14 OR VAR15 AND VAR4;

买3:=VAR14 OR VAR15 AND VAR2;

买4:=VAR2 AND VAR11 OR (VAR4 AND VAR11);

买5:=金叉 AND VAR4 OR (金叉 AND VAR2) OR (金叉 AND VAR11);

TDXSTEP279:DRAWICON(VAR16,LOW-0.02,7);

TDXSTEP280:DRAWICON(买1 OR 买2 OR 买3 OR 买4 OR 买5 AND CLOSE>多空线,LOW-0.01,1);

TDXSTEP281:STICKLINE(死叉 OR VAR12 OR CROSS(40,VAR9) AND CLOSE>多空线 AND CLOSE>MA5,HIGH*1.013,HIGH*1.007,4,1),COLORBLUE;

PJJ:=DMA((HIGH+LOW+CLOSE*2)/4,0.9);

JJ:=REF(EMA(PJJ,3),1);

QJJ:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));

XVL:=IF(CLOSE>OPEN,QJJ*(HIGH-LOW),IF(CLOSE<OPEN,QJJ*(HIGH-OPEN+(CLOSE-LOW)),VOL/2))+IF(CLOSE>OPEN,0-QJJ*(HIGH-CLOSE+(OPEN-LOW)),IF(CLOSE<OPEN,0-QJJ*(HIGH-LOW),0-VOL/2));

ZLL:=VOL/CAPITAL;

HSL1:=IF(ZLL>10,10,ZLL);

HSL:=XVL/20/1.15;

攻击流量:=HSL*0.55+REF(HSL,1)*0.33+REF(HSL,2)*0.22;

GJJ:=EMA(攻击流量,8);

LLJX:=EMA(攻击流量,3);

资金流入:=IF(HSL*0.4+LLJX>0,HSL*0.4+LLJX,DRAWNULL);

资金流出:=IF(HSL*0.4+LLJX<0,HSL*0.4+LLJX,DRAWNULL);

启动:=CROSS(A1X,0) AND CLOSE>多空线 AND 资金流入>0;

TDXSTEP282:STICKLINE(启动,OPEN,CLOSE,3.3,0),COLOR0055FF;

TDXSTEP283:STICKLINE(启动,OPEN,CLOSE,3.3,0),COLOR0077FF;

TDXSTEP284:STICKLINE(启动,OPEN,CLOSE,3,0),COLOR0099FF;

TDXSTEP285:STICKLINE(启动,OPEN,CLOSE,2.2,0),COLOR00BBFF;

TDXSTEP286:STICKLINE(启动,OPEN,CLOSE,1.5,0),COLOR00DDFF;

TDXSTEP287:STICKLINE(启动,OPEN,CLOSE,0.4,0),COLORYELLOW;

TDXSTEP288:STICKLINE(启动 AND LOW<多空线 AND CLOSE>多空线 AND CLOSE-OPEN>(HIGH-CLOSE)*0.99 AND CLOSE-OPEN>HIGH-CLOSE,LOW*0.995,LOW*0.985,4,0),COLORYELLOW;

CC:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);

DD0:=DMA(CLOSE,CC);

上轨:=(1+M/100)*DD0;

下轨:=(1-M/100)*DD0;

短线支撑:=EMA(EMA((2*LOW+CLOSE)/3,5),10);

强弱分水岭:=MA(短线支撑,20);

做多20:=LLV((HIGH+LOW+OPEN+2*CLOSE)/5*2.06-HIGH,8);

见底反弹:=做多20=REF(做多20,1) AND 做多20<强弱分水岭 AND (CROSS(CLOSE,做多20) OR (REF(CLOSE,1)>做多20 AND LOW<做多20 AND CLOSE>做多20)) AND CLOSE>OPEN AND CLOSE>下轨 AND 涨幅<7;

TDXSTEP289:DRAWTEXT(见底反弹 AND 涨幅>9.95,LOW*0.98,39),COLORRED;

VAR21:=4*SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,5,1)-3*SMA(SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,5,1),3.2,1);

VAR22:=8;

QQ:=CROSS(VAR21,VAR22) AND CLOSE>MA(CLOSE,6) AND 涨幅>3;

TDXSTEP290:DRAWTEXT(QQ AND 涨幅>9.97,LOW*0.95,37),COLORMAGENTA;

抄底反弹:=见底反弹 AND 涨幅<7 AND REF(见底反弹,1)<1 AND CLOSE>多空线 OR (QQ AND 涨幅>9.97) OR QQ;

TDXSTEP291:STICKLINE(VAR1A AND CLOSE<多空线 AND (COUNT(QQ,8)>0 OR COUNT(见底反弹,5)>0),HIGH*1.015,HIGH*1.005,4,1),COLORBLUE;

TDXSTEP292:STICKLINE(抄底反弹 AND CLOSE-OPEN>HIGH-CLOSE,LOW*0.995,LOW*0.985,4,0),COLORYELLOW;

破线兰顶:=CROSS(多空线,CLOSE) OR HIGH>多空线 AND CLOSE<多空线*0.984;

TDXSTEP293:STICKLINE(破线兰顶,HIGH*1.017,HIGH*1.004,5,0),COLORBLUE;

原创文章,作者:TTone,如若转载,请注明出处:https://www.qianglongwang.com/61788.html

联系我们