1. 股票论坛首页
  2. 股票公式
  3. 通达信公式

通达信 金龙出水 源码

指标代码及说明:

{金龙出水} LC:=REF(C,1); JJ5:=MA((L+H+2*C)/4,5); MA1:=MEMA(C,5); MA2:=(MA1/REF(MA1,1)-1)*2000; MA3:=IF(MA2>0,MA2,MA2); MA5:MA(C,5),COLOR999999; MA10:MA(C,10),COLORFF9900,LINETHICK1; AMV0:=V*(H+L+2*C+O)/5; 牛熊线:=IF(1=1,SUM(AMV0,89)/SUM(V,89),DRAWNULL),COLORFF66CC,LINETHICK2; 走牛:IF(牛熊线>REF(牛熊线,1),牛熊线,DRAWNULL),COLORFF33FF,LINETHICK2; 走熊:IF(牛熊线<REF(牛熊线,1),牛熊线,DRAWNULL),COLOR00CC00,LINETHICK1; 金龙出水持股:IF(MA10>=REF(MA10,1) AND C>=MA10,MA10,DRAWNULL),COLOR00CCFF, LINETHICK5; 蛟龙入海持币:IF(MA10<=REF(MA10,1) AND C<=MA10,MA10,DRAWNULL),COLORFFBB00, LINETHICK5; VAR1:=C=HHV(C,4) AND (LC>=REF(C,2) OR LC>=REF(C,3)) OR LC=HHV(C,4) AND C >=REF(C,2) OR REF(C,2)=HHV(C,4) AND REF(C,3)=LLV(C,4) AND C>=LC OR REF(C,3)=HHV(C,4) AND C>=LC AND C>=REF(C,2); VAR2:=C=HHV(C,4) AND LC=LLV(C,4); VAR3:=(C=LLV(C,4) AND (LC<REF(C,2) OR LC<REF(C,3))) OR (LC=LLV(C,4) AND C< REF(C,2)) OR (REF(C,2)=LLV(C,4) AND LC=HHV(C,4) AND C<LC) OR (REF(C,3)= LLV(C,4) AND C<LC AND C<REF(C,2)); VAR4:=LC=LLV(C,4) AND C>=REF(C,2) OR REF(C,2)=LLV(C,4) AND LC<=REF(C,3) AND REF(C,2)<REF(C,4) AND C>=LC; VAR5:=LC=HHV(C,4) AND C<REF(C,2) OR (REF(C,2)=HHV(C,4) AND LC>REF(C,3) OR REF(C,3)=HHV(C,4) AND LC>REF(C,2)) AND REF(C,2)>=REF(C,4) AND C<LC; VAR6:=JJ5>REF(JJ5,1) AND REF(JJ5,1)<REF(JJ5,2); VAR7:=100*EMA(EMA(C-LC,6),6)/EMA(EMA(ABS(C-LC),6),6); VAR11:=FILTER((LLV(VAR7,2)=LLV(VAR7,7) AND COUNT(VAR7<0,2) AND CROSS (VAR7,MA(VAR7,2)))=1,5); VAR12:=FILTER((HHV(VAR7,2)=HHV(VAR7,7) AND COUNT(VAR7>50,2) AND CROSS (MA(VAR7,2),VAR7))=1,1); VAR13:=SMA(EMA((C-LC)/LC,5)*100,3,1)*10; VAR14:=FILTER(((CROSS(VAR13,0) OR CROSS(C,EMA(MA(C,10),10))) AND VAR11)=1,3); VAR15:=MA(C,18)>=REF(MA(C,18),3) AND CROSS(C,MA(C,18)); DI:=EMA(C,12)-EMA(C,26); DE:=EMA(DI,9); RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100; K:=SMA(RSV,3,1); D:=SMA(K,3,1); J:=3*K-2*D; 金叉:=CROSS(J,D); 死叉:=CROSS(D,J); 买1:=(VAR14 OR VAR15 OR 金叉) AND (VAR2 OR VAR4 OR VAR11); 买2:=VAR11 AND (VAR2 OR VAR4); DRAWICON(L<HHV(JJ5,10) AND H>HHV(JJ5,10) AND C>LC AND C>O AND COUNT(VAR6,2), L*0.9,7); DRAWICON((买1 OR 买2) AND C>O*0.99,L*0.95,1); DRAWICON(死叉 OR VAR12 OR CROSS(40,VAR7),H+0.01,2); DRAWTEXT(CROSS(DI,DE),L*0.94,'M金叉'),COLORFF33FF; DRAWTEXT(CROSS(DE,DI),H*1.03,'M死叉'),COLOR00FF00; DRAWTEXT(CROSS(K,D),L*0.92,'K金叉'),COLOR00FFFF; DRAWTEXT(CROSS(D,K),H*1.07,'K死叉'),COLORFFFF00; IF(MA10>=REF(MA10,1) AND C>=MA10,MA10,DRAWNULL),CROSSDOT,COLOR00CCFF, LINETHICK4; IF(MA10<REF(MA10,1) AND C<MA10,MA10,DRAWNULL),CROSSDOT,COLORFFBB00, LINETHICK4;

原创文章,作者:TTone,如若转载,请注明出处:https://www.qianglongwang.com/61794.html

联系我们