1. 股票论坛首页
  2. 股票公式
  3. 通达信公式

缠论MACD副图源码 通达信 贴图

指标代码及说明:

							

感觉效果不错,有需要的朋友拿走。

看到一个加密的,并且显示不正常。

现发一个同样未加密的!来源于网络,归还给网络。

{缠论MACD}

SHORT:=12;

LONG:=26;

MID:=9;

TSARROW:=1;

DIFF:=EMA(CLOSE*100,SHORT)-EMA(CLOSE*100,LONG);

DEA:=EMA(DIFF,MID);

MACD2:=(DIFF - DEA)*2;

DIF:DIFF;

DEF:DEA;

MACD:MACD2,NODRAW;

获利比:WINNER(C),NODRAW;

STICKLINE((MACD2>=0),0,MACD2,0,1),COLORRED;

STICKLINE(((MACD2>=0) AND (MACD2 < REF(MACD2,1))),0,MACD2,0,0),COLORMAGENTA;

STICKLINE((MACD2<0),0,MACD2,0,0),COLORGREEN;

STICKLINE(((MACD2<0) AND (MACD2 > REF(MACD2,1))),0,MACD2,0,1),COLORWHITE;

DRAWICON(LONGCROSS(CLOSE,MA(CLOSE,5),17),MACD2,1);

DRAWICON(LONGCROSS(MA(CLOSE,5),CLOSE,17),MACD2,2);

低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1;

JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));

二次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;

DRAWTEXT(二次金叉,0,'二次金叉');

三次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=3,60)=1;

DRAWTEXT(三次金叉,0,'三次金叉');

A1:=IF(MACD2>0,1,-1);

A2:=REF(A1,1);

A3:=A1*A2;

A4:=BARSLAST(A3<0);

A5:=A4+1;

累计面积:SUM(MACD2,A5),NODRAW;

平均力度:SUM(MACD2,A5)/A5,NODRAW;

0,DOTLINE;

WK:="KD.K#WEEK"(9,3,3);

WD:="KD.D#WEEK"(9,3,3);

DK:="KD.K#DAY"(9,3,3);

DD:="KD.D#DAY"(9,3,3);

DRAWICON(CROSS(WK,WD) AND WK<70 AND PERIOD>4,LLV(MACD2,30),9);

DRAWICON(CROSS(DK,DD) AND DK<70 AND PERIOD>4,LLV(MACD2,10),10);

TJ:=MACD2>0;T:=MACD2<0;

A:=LLV(MACD2,50)=MACD2;

DRAWICON(A AND FILTERX(A,20), MACD2,1);

DRAWTEXT(BARSLAST(TJ)=1,MACD2,'1'),COLORYELLOW;

DRAWTEXT(BARSLAST(TJ)=2,MACD2,'2'),COLORYELLOW;

DRAWTEXT(BARSLAST(TJ)=3,MACD2,'3'),COLORYELLOW;

DRAWTEXT(BARSLAST(TJ)=5,MACD2,'5'),COLORYELLOW;

DRAWTEXT(BARSLAST(TJ)=8,MACD2,'8'),COLORYELLOW;

DRAWTEXT(BARSLAST(TJ)=13,MACD2,'13'),COLORYELLOW;

DRAWTEXT(BARSLAST(TJ)=21,MACD2,'21'),COLORYELLOW;

DRAWTEXT(BARSLAST(TJ)=34,MACD2,'34'),COLORYELLOW;

DRAWTEXT(BARSLAST(TJ)=55,MACD2,'55'),COLORYELLOW;

DRAWTEXT(BARSLAST(T)=1,MACD2,'1'),COLORGREEN;

DRAWTEXT(BARSLAST(T)=2,MACD2,'2'),COLORGREEN;

DRAWTEXT(BARSLAST(T)=3,MACD2,'3'),COLORGREEN;

DRAWTEXT(BARSLAST(T)=5,MACD2,'5'),COLORGREEN;

DRAWTEXT(BARSLAST(T)=8,MACD2,'8'),COLORGREEN;

DRAWTEXT(BARSLAST(T)=13,MACD2,'13'),COLORGREEN;

DRAWTEXT(BARSLAST(T)=21,MACD2,'21'),COLORGREEN;

DRAWTEXT(BARSLAST(T)=34,MACD2,'34'),COLORGREEN;

DRAWTEXT(BARSLAST(T)=55,MACD2,'55'),COLORGREEN;

原创文章,作者:(大熊)与水晶,如若转载,请注明出处:https://www.qianglongwang.com/61873.html

联系我们