1. 股票论坛首页
  2. 股票公式
  3. 大智慧公式

大智慧 短线主图 源码

指标说明及代码

{短线主图}

INPUT:M(88,1,200),N1(8,1,60);

STICKLINE((CLOSE>=OPEN),CLOSE,OPEN,8,0),colorred;

STICKLINE((CLOSE>=OPEN),CLOSE,OPEN,6,0),color2828ff;

STICKLINE((CLOSE>=OPEN),CLOSE,OPEN,3,0),color5151ff;

STICKLINE((CLOSE>=OPEN),CLOSE,OPEN,1,0),colorb7b7ff;

天:(SMA(HIGH,21,2) * 1.05),LINETHICK2,colorFFFFFF;

地:(SMA(LOW,21,2) * 0.95),LINETHICK2,color00FF00;

中:SMA(LOW,5,1),LINETHICK4,color99FFFF;

FFTT1:((ATT2 AND ATT3) AND ATT4) AND ATT5,linethick0;

STICKLINE(FFTT1,HIGH,LOW,0.5,0),colorGreen;

STICKLINE(FFTT1,OPEN,CLOSE,9,6),linethick2,colorGreen;

DRAWICON(FFTT1,LOW,7),linethick3;

DRAWTEXT(88>0 and ref(o,1)/ref(c,1)>1.04 and ref(l,1)<=688 and o>ref(c,1)and c<ref(o,1)and c/o>=1.01,l-l*0.02,'★关'),linethick1;

DRAWTEXT(c-o>=0 and o/l>1.05 and l<=llv(l,20),l,' D底'),colorblue, linethick1;

DRAWICON(FILTER(CROSS(-"W&R.wr1",(0 - 81)),10),L-0.2,1),align1;{笑脸};

{短线A}

短线A:=(CLOSE*0.97)/REF(CLOSE,1)>1 AND ((VOL*3/REF(VOL,1))<1);

DRAWTEXT(短线A,L*0.97,'短'),COLOR0000FF;

{注意买入}

VF1:=MA(CLOSE,60)-MA(CLOSE,5)/3.2;

varwA:=(CLOSE-REF(OPEN,29))/REF(OPEN,29)*100;

varwB:=EMA(0.667*REF(varwA,1)+0.333*varwA,5);

注意买入:=VOL>=1.3*MA(VOL,5) AND COUNT(varwA>=varwB AND varwA<-32,3);

DRAWTEXT(注意买入,L*1.272,'注'),COLORyellow;

{快逃}

快逃:=IF(CROSS((3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)) *100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1)),90),20,0);

drawtext(快逃,h*1.031,'S'),colorwhite;

{逃}

RSVy:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;

Ky:=SMA(RSVy,3,1);

Dy:=SMA(Ky,3,1);

Jy:=3*Ky-2*Dy;

BDGDy:=HHV(Jy,2)=HHV(Jy,8) AND Jy>80;

注意:=IF(CROSS(REF(Jy-0.01,1),Jy) AND REF(BDGDy,1),1,0);

STICKLINE(注意,h,h*1.06,1,0),COLORgreen;

DRAWTEXT(注意,h*1.08, '逃'),ALIGN1,COLORgreen;

{b}

A1d:=C/REF(C,1)>1.04;

A2d:=C/HHV(H,34)<0.7;

A3d:=MAX(FORCAST(COST(24)/L,3),SMA(COST(24)/L,3,1))>1.39 ;

A4d:=LOW=LLV(LOW,10) OR REF(LOW,1)=LLV(REF(LOW,1),30) OR REF(LOW,2)=LLV(REF(LOW,2),30);

买:=A1d AND A2d AND A3d and A4d;

DRAWTEXT(买,L*1.35,'A买'),ALIGN1,COLOR0000ff;

{B}

Bq:=C/REF(C,1)>1.038 AND V/REF(V,1)<0.33;

DRAWTEXT(bQ,L*1.396,'C买'),ALIGN1,COLORRED;

{黄金分割里面的逃}

上通道:=(EMA(EMA(EMA(HIGH,5),5),5) * 1.05);

DRAWTEXT(FILTER(((HIGH > 上通道) AND (CLOSE < 上通道)),3),(HIGH * 1.01),'逃'),ALIGN1,VALIGN2,colorEE00FF;

{神奇黑马}

Var1u:=INDEXC;

Var2u:=MA(Var1u,6);

Var3u:=MA(Var1u,24);

Var4u:=MA(Var1u,32);

Var5u:=MA(Var1u,62);

Var6u:=MA(Var1u,105);

Var7u:=Var5u<REF(Var5u,1) AND Var6u<REF(Var6u,1) AND Var5u<Var6u*0.98;

Var8u:=Var4u>Var2u*1.11 AND Var3u>Var2u*1.095;

Var9u:=Var2u>Var1u*0.95;

VarAu:=CLOSE/MA(CLOSE,48)*100<67;

VarBu:=CLOSE/MA(CLOSE,50)*100<69;

VarCu:=HIGH>LOW*1.078;

VarDu:=VarCu AND COUNT(VarCu,4)>2;

神奇黑马:=VarDu AND (VarAu OR VarBu) or Var7u AND Var8u

AND Var9u AND CLOSE/COST(8)<=0.8 AND (CLOSE>OPEN OR CLOSE<OPEN)

AND (REF(CLOSE,1)>REF(OPEN,1) OR REF(CLOSE,1)<REF(OPEN,1));

DRAWTEXT(神奇黑马,L*1.95,'黑'),ALIGN1,COLORyellow;

{金矿石一}

金矿石一:=(CLOSE-REF(CLOSE,2))/REF(CLOSE,2)>=0.2 AND (CLOSE-REF(CLOSE,2))/REF(CLOSE,2)<=0.27 AND (CLOSE-REF(CLOSE,10))/REF(CLOSE,10)>=0.3 AND CLOSE=HHV(HIGH,60);

DRAWTEXT(金矿石一,L*0.97,'金1'),ALIGN1,COLOryellow;

{金矿石组合}

金矿石一:=(CLOSE-REF(CLOSE,2))/REF(CLOSE,2)>=0.2 AND (CLOSE-REF(CLOSE,2))/REF(CLOSE,2)<=0.27 AND (CLOSE-REF(CLOSE,10))/REF(CLOSE,10)>=0.3 AND CLOSE=HHV(HIGH,60);

ET1:=(CLOSE-REF(CLOSE, 1))/REF(CLOSE, 1)*100;

ET2:=MA((CLOSE-REF(OPEN, 29))/REF(OPEN, 29), 1)*100;

ET3:=VOL/CAPITAL*100;

ET4:=REVERSE(SUM(ET3, 30));

ET5:=ET2/ET4;

ET6:=CLOSE<0.980*REF(CLOSE, 1);

金矿石二:=ET5>95/100 AND ET2<-25 AND ET1>6 OR COUNT(ET5>95/100 AND ET2<-25 AND ET1>6, 12) AND ET6;

ET7:=C<=MA(C,45)*0.75;

ET8:=1/(WINNER(C*1.2)-WINNER(C*0.8))>=10;

金矿石三:=ET7 AND ET8 AND C>llV(L,3);

ET9:=(CLOSE-MA(CLOSE,48))/MA(CLOSE,48)*100<-25;

ET10:=(CLOSE-MA(CLOSE,70))/MA(CLOSE,70)*100<-27;

ET11:=ET9 AND ET10;

ET12:=VOL<

REF(VOL,1)*2.8 OR CLOSE<MA(CLOSE,48)*0.7

AND (COUNT(CLOSE<OPEN*0.97,2)=2 AND "DPO">-3.7 OR COUNT(HIGH/LOW>1.065,5)>3);

金矿石四:=ET11 AND (CLOSE>OPEN*1.06 OR CLOSE>REF(CLOSE,1)*1.038) AND ET12;

股道金矿:=金矿石一 OR 金矿石二 OR 金矿石三 OR 金矿石四;

DRAWTEXT(股道金矿,L*0.95,' 金'),ALIGN1,COLORwhitE;

{杀}

Ddf:=MA(CLOSE,80)-MA(CLOSE,10)/3;

杀:=CLOSE<Ddf and VOL/240>MA(VOL,5)/240 AND CLOSE>REF(CLOSE,1)*1.08 AND CLOSE<MA(CLOSE,13)*1.3;

DRAWTEXT(杀,L*1.22,'杀'),ALIGN1,COLORyellow;

{提取完美买卖}

DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);

DEA:=EMA(DIFF,9);

A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));

B1:=REF(C,A1+1)>C AND REF(DIFF,A1+1)<DIFF AND CROSS(DIFF,DEA);

A2:=BARSLAST(REF(CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3)),1));

B2:=REF(C,A2+1)>C AND REF("KDJ.K"(9,3,3),A2+1)<"KDJ.K"(9,3,3) AND CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3));

A3:=BARSLAST(REF(CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1));

B3:=REF(C,A3+1)>C AND REF("RSI.RSI1"(6,12,24),A3+1)<"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));

B4:=CROSS(DIFF,DEA) AND CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3));

DRAWTEXT(B4,L+2.00,'金叉'),COLOR0099FF;

VarA:=IF(CLOSE and MA(VOL, 5)/240 AND CLOSE>REF(CLOSE, 1)*1.0 AND CLOSE,88,0);

VarB:=IF(CLOSE/REF(CLOSE, 1)>1.050 AND VOL/CAPITAL*100<10 AND CLOSE<17 AND HIGH/CLOSE<1.010 AND VarA>0, 91, 0);

STICKLINE(VarB>90,L*0.99,L*0.98,5,0);

DRAWTEXT(VarB>90,LOW*1.58,' 追'),COLORYELLOW;

市场成本:=DMA(AMOUNT/V/100,V/CAPITAL);

DRAWtext(CROSS(C,市场成本),L-1.20,'穿');

{底背离}

QTMX:=EMA(C,2);

YTMX:=EMA(SLOPE(C,21)*20+C,42);

BU:=cross(QTMX,YTMX);

SEL:=cross(YTMX,QTMX);

drawtext(bu,LOW*0.999,'DB'),colorred,linethick3;

DRAWTEXT(bu,LOW,'﹉'),Color208FFF,LINETHICK3;

DRAWTEXT(sel,HIGH,'﹉'),ColorFFFF00,LINETHICK3;

drawtext(sel,HIGH*1.008,'DB'),colorffff00,linethick3;

VTTAR1:=MA(CLOSE,5);

VTTAR2:=MA(CLOSE,10);

VTTAR3:=MA(CLOSE,20);

VTTAR4:=MA(CLOSE,30);

VTTAR5:=MA(CLOSE,60);

FTTT1:=VTTAR1>REF(VTTAR1,1);

FTTT2:=VTTAR2>REF(VTTAR2,1);

FTTT3:=VTTAR2>REF(VTTAR2,1);

FTTT4:=VTTAR2>REF(VTTAR2,1);

FTTT5:=VTTAR2>REF(VTTAR2,1);

x1:=EMA(C,7);

drawtext(filter(vTTar3 and vTTar2 and count(x1<ref(x1,1),5)>2 and x1>ref(x1,1),3),l+1.01,'短'),ColorFFFFFF;

{提取绝佳顶底}

LC:=REF(CLOSE,1);

RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;

DRAWTEXT(CROSS(80,RSI),high+0.5,'见顶'),colorgreen;

主力:=EMA( (CLOSE-MA(CLOSE,7))/MA(CLOSE,7)*480,2);

散户:=EMA( (CLOSE-MA(CLOSE,11))/MA(CLOSE,11)*480,7);

DRAWTEXT(CROSS(主力,散户) AND 主力<-10,low-0.5,'升');

{提取周买月买}

DRAWTEXT(CROSS("KDJ.K#WEEK"(9,3,3),"KDJ.D#WEEK"(9,3,3)) ,low+2.0,'ZM'),align1,COLORred;

DRAWTEXT(CROSS("KDJ.K#MONTH"(9,3,3),"KDJ.D#MONTH"(9,3,3)) ,low+3.0,'YM'),align1,COLORMAGENTA;

{红牛}

QVAR1:=LLV(LOW,21);

QVAR2:=HHV(HIGH,21);

QAK1:=EMA((((CLOSE - QVAR1) / (QVAR2 - QVAR1)) * 100),5);

QAK:=EMA((((CLOSE - QVAR1) / (QVAR2 - QVAR1)) * 50),13);

QAB:=CROSS(QAK1,QAK);

DRAWTEXT((QAB = 1),(LOW * 1.199),'牛窝'),colorYELLOW;

VERTLINE((BARSLAST((LOW = (LLV(LOW,240)))) = 30),1),POINTDOT,colorWhite;

VERTLINE((BARSLAST((LOW = (LLV(LOW,240)))) = 60),1),POINTDOT,colorWhite;

VERTLINE((BARSLAST((LOW = (LLV(LOW,240)))) = 90),1),POINTDOT,colorWhite;

VERTLINE((BARSLAST((LOW = (LLV(LOW,240)))) = 120),1),POINTDOT,colorWhite;

VERTLINE((BARSLAST((LOW = (LLV(LOW,240)))) = 150),1),POINTDOT,colorWhite;

VERTLINE((BARSLAST((LOW = (LLV(LOW,240)))) = 180),1),POINTDOT,colorWhite;

VERTLINE((BARSLAST((LOW = (LLV(LOW,240)))) = 210),1),POINTDOT,colorWhite;

VERTLINE((BARSLAST((LOW = (LLV(LOW,240)))) = 2400),1),POINTDOT,colorWhite;

{LX32}

Dq:=MA(CLOSE,80)-MA(CLOSE,10)/3;

追涨:=CLOSE<Dq and VOL/240>MA(VOL,5)/240 AND CLOSE>REF(CLOSE,1)*1.08

AND CLOSE<MA(CLOSE,13)*1.3;

DRAWTEXT(追涨,l*1.393,'追32'),colorred;

{LX系列 福星高照}

买了发:=CLOSE=OPEN AND CLOSE=HIGH AND CLOSE=LOW AND CLOSE/REF(CLOSE,1)>1.044 AND VOL/CAPITAL*1000<4;

DRAWTEXT(买了发,l*1.295,'福'),colorred;

{LX50}

lsj:=c/ref(c,1)>1.09 and c=h and between(forcast(V,3),0.17*forcast(v,13),1.4*forcast(v,13));

Var1j:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;

Var2j:=SMA(Var1j,3,1);

Var3j:=(c+h+l)/3;

Var4j:=LLV(LOW,30);

Var5j:=HHV(HIGH,30);

Bj:=EMA((Var3j-Var4j)/(Var5j-Var4j)*100,8);

B1j:=EMA(Bj,3);

nnj:=(Bj-B1j)>0;

CZM:=(filter(lsj,23) and nnj )*50;

DRAWTEXT(CZM,LOW*0.9395,'追50'),COLOR00F0F0;

Var1ty:=(REF(HIGH,1)+REF(LOW,1))/2;

Var2ty:=MA(CLOSE,20)+2*STD(CLOSE,20);

DRAWTEXT(CROSS(Var1ty,Var2ty),HIGH*1.035,'卖1'),COLORYELLOW;

Var3ty:=REF(CLOSE,1);

Var4ty:=SMA(MAX(CLOSE-Var3ty,0),7,1)/SMA(ABS(CLOSE-Var3ty),7,1)*100;

Var5ty:=CROSS(79,Var4ty);

Var6ty:=FILTER(Var5ty,4);

DRAWTEXT(Var6ty,HIGH*1.02,'卖2'),COLORGREEN;

原创文章,作者:(大熊)与水晶,如若转载,请注明出处:https://www.qianglongwang.com/61883.html

联系我们