1. 股票论坛首页
  2. 股票公式
  3. 通达信公式

通达信绝佳买卖点副图指标公式源码

以下是通达信绝佳买卖点副图指标公式源码(无源码的请下载附件导入)

VAR1:=(HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9))*100-70;
VAR2:=SMA(VAR1,9,1)+100; VAR3:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100; 
VAR4:=SMA(VAR3,3,1); VAR5:=SMA(VAR4,3,1)+100; VAR6:=VAR5-VAR2; 
趋势: IF(VAR6>45,VAR6-45,0); 
STICKLINE(REF(趋势,1)< 趋势, 趋势,REF(趋势,1),5,0),colorff00ff; 
STICKLINE(REF(趋势,1)> 趋势, 趋势,REF(趋势,1),5,0),color00ff00; 
强弱分界:50,POINTDOT,Colorffffcc; 
0,Color00Ffff; 
20,POINTDOT,COlORFFAA66,linethick1; 
80,POINTDOT,COlORFFAA66,linethick1; 
100,Colorffff33; v1:=llv(low,10); v2:=hhv(h,25); 
价位线:=ema((c-v1)/(v2-v1)*4,4); 
DRAWTEXT(CROSS(价位线,0.3),7,'●'),ColorFFFfff; 
DRAWTEXT(CROSS(3.5,价位线),102,'●'),ColorFFFfff; Var2q:=REF(LOW,1); 
Var3q:=SMA(ABS(LOW-Var2q),3,1)/SMA(MAX(LOW-Var2q,0),3,1)*100; 
Var4q:=EMA(IF(CLOSE*1.3,Var3q*10,Var3q/10),3); 
Var5q:=LLV(LOW,30); 
Var6q:=HHV(Var4q,30); 
Var7q:=IF(MA(CLOSE,58),1,0); 
Var8q:=EMA(IF(LOW<=Var5q,(Var4q+Var6q*2)/2,0),3)/618*Var7q; 
Var9q:=IF(Var8q>100,100,Var8q); 
吸筹:STICKLINE(Var9q>-120,0,Var9q,6,1),coloryellow; 
AA3:=(HHV(HIGH,21)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,21))*100-10; 
AA4:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100; 
AA5:=SMA(AA4,13,8); 
走势:=CEILING(SMA(AA5,13,8)); 
AA6:=SMA(AA3,21,8); 
卖临界:STICKLINE(走势-AA6>85,103,100,15,1),Color0000ff,linethick2;

原创文章,作者:TTone,如若转载,请注明出处:https://www.qianglongwang.com/61901.html

联系我们