1. 股票论坛首页
  2. 股票公式
  3. 通达信公式

通达信王道

以下是通达信王道-135均线源码附图(无源码的请下载附件导入)


王道-135均线源码附图

VOLUME:VOL,VOLSTICK;

MA5:MA(VOLUME,M1);

MA35:MA(VOLUME,M2);

MA135:MA(VOLUME,M3);

VAR1:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));

成交量:VOL,POINTDOT,COLORYELLOW;

买盘:IF(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE<OPEN,VAR1*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2)),COLORRED,POINTDOT;

卖盘:IF(CLOSE>OPEN,VAR1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,VAR1*(HIGH-LOW),VOL/2)),COLOR00FF00,POINTDOT;

TOTAL:=IF(PERIOD=1,5,IF(PERIOD=2,15,IF(PERIOD=3,30,IF(PERIOD=4,60,IF(PERIOD=5,240,1)))));

MTIME:=MOD(FROMOPEN,TOTAL);

CTIME:=IF(MTIME<0.5,TOTAL,MTIME);

VVOL:IF(CURRBARSCOUNT=1,VOL*TOTAL/CTIME,DRAWNULL),NODRAW;

成交量比%:买盘/VOL*100,COLORWHITE,NODRAW;

VAR22:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;

获利盘: WINNER(CLOSE)*100;

VAR33:=SMA(VAR22,3,1);

VAR44:=SMA(VAR33,9,1);

VAR55:=3*VAR33-2*VAR44;

VAR66:=VOL;

量比: VOL/MA(VOL,5);

涨幅: (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;

角度: (CLOSE-REF(OPEN,29))/REF(OPEN,29)*100;

换手: VOL/CAPITAL*100;

VAR77:=SUM(换手,30);

VAR88:=LLV(INDEXL,5);

VAR99:=HHV(INDEXH,5);

VARAA:=EMA((INDEXC-VAR88)/(VAR99-VAR88)*100,4);

VARBB:=MA(EMA(0.667*REF(VARAA,1)+0.333*VARAA,2),9);

VARCC:=MA(VARBB,30);

VARDD:=EMA(获利盘,4);

本盘亿股: CAPITAL/1000000,;

VARF:=(涨幅>VARDD AND 角度<-30 AND 涨幅>3);

CROSS(VARBB,VARCC) AND VARCC<29;

CROSS(VARCC,VARBB) AND VARCC>58;

STICKLINE(VOL AND VAR33>VAR44,0,VOL,2.5,1),COLORRED;

STICKLINE(VOL AND VAR33<=VAR44,0,VOL,2.5,1),COLORCYAN;

STICKLINE(买盘>0,0,买盘,2,0),COLORRED;

STICKLINE(卖盘>0,0,卖盘,0.8,0),COLOR00FF00;

原创文章,作者:TTone,如若转载,请注明出处:https://www.qianglongwang.com/61905.html

联系我们