1. 股票论坛首页
  2. 股票公式
  3. 通达信公式

五里短线副图指标 源码 通达信

指标代码及说明:

							

{多空短线买点}

VAR1:=(H+L+O+3*C)/6;

WLT:=EMA(VAR1,3);

WLTA:=EMA(WLT,1),COLORFFFFFF;

空:HHV(MA(H,3),2),LINETHICK2,COLOR00DD00;

多:LLV(MA(H,3),1),LINETHICK2,COLOR0000DD;

JCBT:=LAST(多<空,9,1) AND 多=空;

STICKLINE(JCBT,O,(O+C)/2,4,0),COLOR0000FF;

DRAWTEXT(JCBT,L*0.98,'短B'),COLOR0000FF;

{超跌反弹买点}

VARA:=(C-REF(O,21))/REF(O,21)*100;

VARB:=EMA(0.667*REF(VARA,1)+0.333*VARA,5);

WLBT1:=V>=1.3*MA(V,5) AND REF(L,1)=LLV(L,55) AND VARA>=VARB AND VARA<-6.18;

WLBT2:=V>=1.3*MA(V,5) AND CROSS(VARA,VARB) AND VARA<-10.18;

WLBT:=WLBT1 OR WLBT2;

DRAWTEXT(WLBT,L*0.98,'反弹'),COLOR00FFFF;

STICKLINE(WLBT,C,O,3,0),COLOR00FFFF;

{卖点设置}

S1:=EMA(EMA(EMA(C,8),13),55);

S2:=(REF(H,1)+REF(L,1))/2;

S3:=MA(C,21)+2*STD(C,21);

ST11:=CROSS(S2,S3);

S4:=REF(C,1);

S5:=SMA(MAX(C-S4,0),7,1)/SMA(ABS(C-S4),7,1)*100;

S6:=CROSS(80,S5);

ST2:=FILTER(S6,5);

V1:=EMA(EMA(EMA(C,8),13),55);

V2:=(REF(H,1)+REF(L,1))/2;

V3:=MA(C,21)+2*STD(C,21);

V4:=REF(C,1);

V5:=SMA(MAX(C-V4,0),7,1)/SMA(ABS(C-V4),7,1)*100;

V6:=CROSS(80,V5);

ST:=FILTER(V6,5);

DRAWICON(ST11,H*1.030,19);

DRAWICON(ST2,HIGH*1.033,12);

DRAWTEXT(ST OR CROSS(V2,V3),HIGH*1.02,'卖'),COLORGREEN;

{乖离共振买点}

BIAS6:=(C-MA(C,6))/MA(C,6)*100;

BIAS12:=(C-MA(C,12))/MA(C,12)*100;

BIAS24:=(C-MA(C,24))/MA(C,24)*100;

TJ1:=BIAS6<=-8;

TJ2:=BIAS12<=-12;

TJ3:=BIAS24<=-18;

BBT:=(TJ1 AND TJ2 AND TJ3) OR (TJ1 AND TJ2 ) OR (TJ1 AND TJ3);

BTJ5:=CROSS(BIAS6,-10);

BTJ6:=CROSS(BIAS6,-6.2);

BIASXG:=FILTER(BBT OR BTJ5 OR BTJ6,3);

STICKLINE(BIASXG,C,O,0.11,0),COLOR0078FF;

DRAWTEXT(BIASXG,L*0.98,'BIAS'),COLOR0078FF;

{以上3组信号综合或共振买点}

WLTBT:=COUNT(WLBT OR JCBT OR BIASXG,2);

XG1:=WLTBT>=2;

XG:=FILTER(XG1,3);

DRAWTEXT(XG,L*0.99,'金牛'),COLOR00FFFF;

{选股及成功率统计}

年选股:SUM(XG,250),NODRAW;

设定利润:=REF(XG,20) AND HHV(H,20)>=REF(C,20)*1.15;{20个交易日内涨15%}

成功数:SUM(设定利润,250),NODRAW;

成功率%:成功数/年选股*100,NODRAW;

{基本面技术面数据解盘}

套牢盘%:=100*(1-WINNER(C));

获利盘%:=100*WINNER(C);

集中度90%:=(COST(95)-COST(5))/(COST(100))*100;

集中度70%:=(COST(85)-COST(15))/(COST(100))*100;

平均成本:=COST(50);

主力成本:=COST(5);

最高:=HHV(H,21);

最低:=LLV(L,21);

PT:=REF(HIGH,1)-REF(LOW,1);

中价:=(H+L+C)/3;

近高:=2*中价-LOW;

近低:=2*中价-HIGH;

短期压力:=中价+PT;

短期支撑:=中价-PT;

DRAWTEXT_FIX(1,0.02,0.00,0,'【获利盘%】'),COLORRED;

DRAWTEXT_FIX(1,0.02,0.06,0,'【套牢盘%】'),COLOR00FF00;

DRAWTEXT_FIX(1,0.02,0.12,0,'【90%成本】'),COLORYELLOW;

DRAWTEXT_FIX(1,0.02,0.18,0,'【70%成本】'),COLOR008FFF;

DRAWTEXT_FIX(1,0.02,0.24,0,'【平均成本】'),COLORFF99FF;

DRAWTEXT_FIX(1,0.02,0.30,0,'【主力成本】'),COLORFF00FF;

DRAWTEXT_FIX(1,0.02,0.36,0,'【短期压力】'),COLORFFFFBF;

DRAWTEXT_FIX(1,0.02,0.42,0,'【短期支撑】'),COLORF0F000;

DRAWTEXT_FIX(1,0.3,0.00,0,'【中价】'),COLORWHITE;

DRAWTEXT_FIX(1,0.3,0.06,0,'【近高】'),COLORFFFFBF;

DRAWTEXT_FIX(1,0.3,0.12,0,'【近低】'),COLORF0F000;

DRAWTEXT_FIX(1,0.3,0.18,0,'【最高】'),COLORFF99FF;

DRAWTEXT_FIX(1,0.3,0.24,0,'【最低】'),COLORFF00FF;

DRAWNUMBER_FIX(1,0.16,0.00,0,CONST(获利盘%)),COLORRED;

DRAWNUMBER_FIX(1,0.16,0.06,0,CONST(套牢盘%)),COLOR00FF00;

DRAWNUMBER_FIX(1,0.16,0.12,0,CONST(集中度90%)),COLORYELLOW;

DRAWNUMBER_FIX(1,0.16,0.18,0,CONST(集中度70%)),COLOR008FFF;

DRAWNUMBER_FIX(1,0.16,0.24,0,CONST(平均成本)),COLORFF99FF;

DRAWNUMBER_FIX(1,0.16,0.30,0,CONST(主力成本)),COLORFF00FF;

DRAWNUMBER_FIX(1,0.16,0.36,0,CONST(短期压力)),COLORFFFFBF;

DRAWNUMBER_FIX(1,0.16,0.42,0,CONST(短期支撑)),COLORF0F000;

DRAWNUMBER_FIX(1,0.38,0.00,0,CONST(中价)),COLORWHITE;

DRAWNUMBER_FIX(1,0.38,0.06,0,CONST(近高)),COLORFFFFBF;

DRAWNUMBER_FIX(1,0.38,0.12,0,CONST(近低)),COLORF0F000;

DRAWNUMBER_FIX(1,0.38,0.18,0,CONST(最高)),COLORFF99FF;

DRAWNUMBER_FIX(1,0.38,0.24,0,CONST(最低)),COLORFF00FF;

DRAWTEXT_FIX(1,0.5,0.0,0,'【每股收益 (元)】:'),COLOR0000FF;

DRAWNUMBER_FIX(1,0.63,0.00,0,FINANCE(33)),COLOR0000FF;

DRAWTEXT_FIX(1,0.5,0.06,0,'【每股净资产(元)】:'),COLOR00FFFF;

DRAWNUMBER_FIX(1,0.63,0.06,0,FINANCE(34)),COLOR00FFFF;

BHD:=(AMOUNT/C)/HHV((AMOUNT/C),26)*100;

DRAWTEXT_FIX(1,0.5,0.12,0,'【量能饱和度℅】:'),COLORFF00FF;

DRAWNUMBER_FIX(1,0.63,0.12,0,CONST(BHD)),COLORFF00FF;

PSY:=COUNT(C>REF(C,1),34)/34*100;

DRAWTEXT_FIX(1,0.5,0.18,0,'【心理乐观度℅】:')COLOR00FF00;

DRAWNUMBER_FIX(1,0.63,0.18,0,CONST(PSY)),COLOR00FF00;

{五里头操作理念}

DRAWTEXT_FIX(1,0.0,0.98,0,'★五里理念★: 改掉恶习,严守纪律,趋势为先,波段操作;

安全第一,坚决止损! ★:本指标依据:多空转化→【短B】、超跌反弹→【反弹】、

BIAS共振→【BIAS】3组指标指示买点!'),COLOR0078FF;

原创文章,作者:TTone,如若转载,请注明出处:https://www.qianglongwang.com/62003.html

联系我们