1. 股票论坛首页
  2. 股票公式
  3. 同花顺公式

同花顺 MACD主图★ 源码

指标说明及代码

DDIF:EMA(CLOSE,12)-EMA(CLOSE,26),NODRAW;

DDEA:EMA(DDIF,9),NODRAW;

DMACD:(DDIF-DDEA)*2,NODRAW;

上市天数:=BARSCOUNT(C);

N:=IF(上市天数<90,上市天数-1,90);

基点:=CONST(LLV(L,N));

基:=CONST(HHV(H,N))-基点;

分:=CONST(LLV(DDIF,N));

百:=CONST(HHV(DDIF,N))-分;

CC比:=(DDIF-分)/百;

XCX:=CC比*基+基点;

DIF:=XCX;

NOTEXTDDIF:DIF,colorwhite;

DEA:=EMA(DIF,9);

NOTEXTDDEA:DEA,coloryellow;

基准零线:=(0-分)/百*基+基点;

NOTEXT基准零线:基准零线,POINTDOT,colorlired;

MACD:=(DIF-DEA)*2;

STICKLINE(MACD>=0,基准零线,基准零线+MACD,0,0),colorlired;

STICKLINE(MACD<0,基准零线,基准零线+MACD,0,0),colorlicyan;

VERTLINE(CROSS(DDIF,DDEA),1),Color0000FF;

VERTLINE(CROSS(DDEA,DDIF),1),colorgreen;

s:=FROMNIGHT;

HORLINE(s=0,CLOSE,4,1),coloryellow;

原创文章,作者:TTone,如若转载,请注明出处:https://www.qianglongwang.com/62071.html

联系我们