1. 股票论坛首页
  2. 股票公式
  3. 同花顺公式

同花顺 仓位柱 源码

指标说明及代码

同花顺大盘仓位,结合MACD指标波段判断趋势和买卖点及其有用

IF(PERIODNAME<>"日线")

{

统计:"该指标只在日线周期下有效。";

RETURN;

}

m3:=MA(CLOSE,2);

Ms5:=SMA(m3,5,3);

Ms13:=SMA(CLOSE,13,2);

Ms21:=SMA(CLOSE,21,1);

RSV=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

a=SMA(RSV,3,1);

b=SMA(a,3,1);

大单净差BBD:=BIGBUYCOUNT1+WAITBUYCOUNT1-BIGSELLCOUNT1-WAITSELLCOUNT1;

DIFF:=EMA(大单净差BBD,6) - EMA(大单净差BBD,13);

DIFF2:=EMA(大单净差BBD,9) - EMA(大单净差BBD,20);

m1=0;

m2=0;

m3=0;

m4=0;

m5=0;

m6=0;

IF(Ms5>REF(Ms5,1))

m1=10;

ELSE IF(Ms5<REF(Ms5,1))

m1=-10;

IF(Ms5<C)

m2=5;

ELSE IF(Ms5>C)

m2=-5;

IF(Ms13>REF(Ms13,1))

m3=5;

ELSE IF(Ms13<REF(Ms13,1))

m3=-5;

IF(Ms21>REF(Ms21,1))

m4=10;

ELSE IF(Ms21<REF(Ms21,1))

m4=-10;

IF(b>90)

m5=-10;

ELSE IF(b<90 AND b>10)

m5=0;

ELSE IF(b<10)

m5=10;

IF(diff>0 AND diff2>0)

m6=10;

ELSE IF(diff>0 OR diff2>0)

m6=0;

ELSE IF(diff<0 AND diff2<0)

m6=-10;

大盘仓位指标为:(m1+m2+m3+m4+m5+m6+50);

原创文章,作者:TTone,如若转载,请注明出处:https://www.qianglongwang.com/62076.html

联系我们