1. 股票论坛首页
  2. 股票公式
  3. 通达信公式

背离提示副图指标 源码 通达信

指标代码及说明:

							

N:=9;M1:=3;M2:=3;P:=9;

RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;

K:=SMA(RSV,M1,1),COLORRED,LINETHICK2;

D:=SMA(K,M2,1),COLOR00FF00;

JJ:=P*(3*D-2*K),COLOR00FF00;

J:=((3 * K) - (2 * D));

MAIRU:= CROSS(K,D) AND K<20;

MAICHU:= CROSS(D,K) AND D>80;

VAR2:=REF(LOW,1);

VAR3:=SMA(ABS(LOW-VAR2),3,1)/SMA(MAX(LOW-VAR2,0),3,1)*100;

VAR4:=EMA(IF(CLOSE*1.3,VAR3*10,VAR3/10),3);

VAR5:=LLV(LOW,30);

VAR6:=HHV(VAR4,30);

VAR7:=IF(MA(CLOSE,58),1,0);

VAR8:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7;

VAR9:IF(VAR8>100,100,VAR8);

快线:(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,COLORFF937F;

A:=快线>REF(快线,1) AND REF(快线,1)<REF(快线,2);

A1:=BARSLAST(A);

A2:=REF(A1,1);

B1:=REF(快线,1);

B2:=REF(快线,A2+2);

C1:=REF(L,1);

C2:=REF(L,A2+2);

背离:=B1>B2 AND C1<C2 AND A > 0 AND 快线< 50;

背离*50,COLORYELLOW;

DRAWTEXT(背离,60,'背离');

原创文章,作者:TTone,如若转载,请注明出处:https://www.qianglongwang.com/62179.html

联系我们