1. 股票论坛首页
  2. 股票公式
  3. 通达信公式

通达信短线波段副图指标详源码

以下是通达信短线波段副图指标详源码(无源码的请下载附件导入)


很久没有写指标了,因为感觉传统的指标会用、用好就足够了。这里给大家一个综合运用KDJ和RSI的指标,期间做了一点改动,有点灵活运用的意思。呵呵。

希望大家喜欢。至于用法,看图就会的。特别要注意信号的共振哦。参数自己填上:

RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;

快:SMA(RSV,3,1),COLORGREEN;

慢:SMA(快,3,1);

快慢比:快/慢,NODRAW;

DRAWBAND(快,RGB(155,50,50),慢,RGB(0,100,50));

介入:IF(快<M,20,10)COLORLIRED;

M:=INTPART(3*10/5);

A12:=REF(快,M)=HHV(快,2*M+1);
B12:=FILTER(A12,M);
C12:=BACKSET(B12,M+1);
D12:=FILTER(C12,M);{高点}
R112:=BACKSET(ISLASTBAR,BARSLAST(D12)+1); S112:=R112>REF(R112,1);

短压:DRAWLINE(D12,快,S112,快,1),COLORFF9966;

M1:=INTPART(3*20/5);

A111:=REF(快,M1)=HHV(快,2*M1+1);
B111:=FILTER(A111,M1);
C111:=BACKSET(B111,M1+1);
D1:=FILTER(C111,M1);{高点}
R11:=BACKSET(ISLASTBAR,BARSLAST(D1)+1); S11:=R11>REF(R11,1);

长压:DRAWLINE(D1,快,S11,快,1),COLORFF99FF;


LC:=REF(CLOSE,1);

RSI1:SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*100,NODRAW;

DRAWICON(REF(RSI1,1)<=10 AND RSI1>REF(RSI1,1),10,1);

DRAWICON(REF(RSI1,1)>=80 AND RSI1<REF(RSI1,1),90,2);


极强:STICKLINE(CLOSE>0,80,80,0.8,1)COLORGREEN;

极弱:STICKLINE(CLOSE>0,20,20,0.8,1)COLORMAGENTA;

原创文章,作者:TTone,如若转载,请注明出处:https://www.qianglongwang.com/62207.html

联系我们