1. 股票论坛首页
  2. 股票公式
  3. 通达信公式

通达信再次分享一个老师们的指标公式

以下是通达信再次分享一个老师们的指标公式(无源码的请下载附件导入)

DA1:=IF(130>TOTALBARSCOUNT,TOTALBARSCOUNT,130);

DA:=IF(CURRBARSCOUNT>DA1,0,DA1);

HI:=REFDATE(HHV(H,DA),DATE);

LO:=REFDATE(LLV(L,DA),DATE);

C1:=IF(CURRBARSCOUNT<=DA,C,DRAWNULL);

GZ:=EXP(LN(HI/LO)/10);


LH1:=SUM(IF(C1>=(HI/GZ),V,0),DA);

LH2:=SUM(IF(C1>=(HI/POW(GZ,2)) AND C1<(HI/GZ),V,0),DA);

LH3:=SUM(IF(C1>=(HI/POW(GZ,3)) AND C1<(HI/POW(GZ,2)),V,0),DA);

LH4:=SUM(IF(C1>=(HI/POW(GZ,4)) AND C1<(HI/POW(GZ,3)),V,0),DA);

LH5:=SUM(IF(C1>=(HI/POW(GZ,5)) AND C1<(HI/POW(GZ,4)),V,0),DA);

LH6:=SUM(IF(C1>=(HI/POW(GZ,6)) AND C1<(HI/POW(GZ,5)),V,0),DA);

LH7:=SUM(IF(C1>=(HI/POW(GZ,7)) AND C1<(HI/POW(GZ,6)),V,0),DA);

LH8:=SUM(IF(C1>=(HI/POW(GZ,8)) AND C1<(HI/POW(GZ,7)),V,0),DA);

LH9:=SUM(IF(C1>=(LO*GZ) AND C1<LO*POW(GZ,2),V,0),DA);

LH10:=SUM(IF(C1>=LO AND C1<LO*GZ,V,0),DA);

L1:=REFDATE(HHV(LH1,DA),DATE),LINETHICK0;

L2:=REFDATE(HHV(LH2,DA),DATE),LINETHICK0;

L3:=REFDATE(HHV(LH3,DA),DATE),LINETHICK0;

L4:=REFDATE(HHV(LH4,DA),DATE);

L5:=REFDATE(HHV(LH5,DA),DATE);

L6:=REFDATE(HHV(LH6,DA),DATE);

L7:=REFDATE(HHV(LH7,DA),DATE);

L8:=REFDATE(HHV(LH8,DA),DATE);

L9:=REFDATE(HHV(LH9,DA),DATE);

L10:=REFDATE(HHV(LH10,DA),DATE);

SS:=(L1+L2+L3+L4+L5+L6+L7+L8+L9+L10);

STICKLINE(CEILING(DA*L1/SS)*3>=CURRBARSCOUNT,HI*99/100,HI/GZ,9,0)COLOR3C3C3A,LINETHICK3;

STICKLINE(CEILING(DA*L2/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,1)*99/100,HI/POW(GZ,2),9,0)COLOR3C3C3A,LINETHICK3;

STICKLINE(CEILING(DA*L3/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,2)*99/100,HI/POW(GZ,3),9,0)COLOR3C3C3A,LINETHICK3;

STICKLINE(CEILING(DA*L4/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,3)*99/100,HI/POW(GZ,4),9,0)COLOR3C3C3A,LINETHICK3;

STICKLINE(CEILING(DA*L5/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,4)*99/100,HI/POW(GZ,5),9,0)COLOR3C3C3A,LINETHICK3;

STICKLINE(CEILING(DA*L6/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,5)*99/100,HI/POW(GZ,6),9,0)COLOR3C3C3A,LINETHICK3;

STICKLINE(CEILING(DA*L7/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,6)*99/100,HI/POW(GZ,7),9,0)COLOR3C3C3A,LINETHICK3;

市场成本:(COST(25)+COST(75)+ COST(11)+COST(21)+COST(46)+COST(96))/6,POINTDOT,LINETHICK4,COLORWHITE;

主力成本0:COST(5),POINTDOT,LINETHICK4,COLORBLUE;

二分位:(H+L)/2 ,LINETHICK4,COLORRED,POINTDOT;

【H】:HHV(HIGH,10),LINETHICK2,COLORGRAY,NODRAW;

【L】:LLV(LOW,10),LINETHICK2,COLORGRAY,NODRAW;

LL1:LLV(CLOSE,20),LINETHICK2,COLORBLUE;

HH1:HHV(CLOSE,21),LINETHICK2,COLORBLUE;

箱体中轨:(LL1+HH1)/2,COLORBLUE;

LLV(CLOSE,8),LINETHICK1,COLORWHITE;

RSV:=(CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10))*100;

K:=SMA(RSV,5,1);

D:=SMA(K,5,1);

J:=3*K-2*D;

X:=REF(J,1)<10 AND H>REF(H,1) AND C>REF(C,1) AND C>REF(O,1) AND L>REF(L,1);

STICKLINE(X,L ,L,20,0),COLOR008888;

STICKLINE(X,L ,H,0,0),COLORFF00FF;

STICKLINE(X,C ,O,2,0),COLORFF00FF;

RSV0:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;

K0:=SMA(RSV0,5,1);

D0:=SMA(K0,5,1);

J0:=3*K0-2*D0;

X0:=REF(J0,1)>90 AND H>REF(H,1) AND C>REF(C,1) AND C>REF(O,1) AND L>REF(L,1);

STICKLINE(X0,L ,L,20,0),COLOR008888;

STICKLINE(X0,L ,H,0,0),COLORWHITE;

STICKLINE(X0,C ,O,1,0),COLORWHITE;

AAF:LLV(LOW,34),LINETHICK1,COLORFFFFCC;

BBF:MA(AAF,4),LINETHICK1,COLORYELLOW;
LC:=REF(CLOSE,1);

RSI:=((SMA(MAX((CLOSE – LC),0),3,1) / SMA(ABS((CLOSE – LC)),3,1)) * 100);

FF:=EMA(CLOSE,3);

MA15:=EMA(CLOSE,21);

DRAWTEXT(CROSS(FF,MA15),BBF,’底背离’),COLORFFFF00;

DRAWTEXT(CROSS(88,RSI),(HIGH*1.02),’顶背离’),COLOR0000FF;

XA:=(C+L+H)/3;

BB13:=ATAN(EMA(XA,13)-REF(EMA(XA,13),1))*3.1416*10;

EMA8:=EMA(C,8);

DRAWTEXT(FILTER(BB13>1 AND EMA(XA,13)>REF(EMA(XA,8),1),10),
EMA8,’∠45′),COLORWHITE;

X1:=(CLOSE+LOW+HIGH)/3;

X2:=EMA(X1,6);

X3:=EMA(X2,5);

STICKLINE(CROSS(X2,X3),OPEN,CLOSE,2,0),COLORBROWN;

RSV1:=(CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10))*100;

K1:=SMA(RSV1,5,1);

D1:=SMA(K1,5,1);

X8:=REF(K1,1)>80 AND H>REF(H,1) AND C>REF(C,1) AND C>REF(O,1) AND L>REF(L,1);

STICKLINE(X8,C ,O,2,0),COLOR1880FF;

STICKLINE(X8,L ,H,0,0),COLOR1880FF;

STICKLINE(X8,L ,L,20,0),COLOR1880FF;

AA1:=AMOUNT/V;

BB1:=L<AA1*0.9;

CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;

DD1:=L<MA(C,5)*0.921;

EE1:=V<MA(V,5)*1.5;

老鼠仓:=BB1 AND CC1 AND DD1 AND EE1,LINETHICK0;

DRAWTEXT(老鼠仓,(LOW* 0.99),’老鼠仓’),COLORYELLOW;

DRAWTEXT(LLV(VOL,13)=VOL AND C>=REF(C,1),O,’缩量’),COLORYELLOW;

AA0:=SUMBARS(VOL,CAPITAL);

DRAWTEXT(IF(CAPITAL=0,AMOUNT=LLV(AMOUNT,34),VOL<MA(VOL,AA0)/3),L,’地量’),COLORWHITE;

VAR2:=(2*CLOSE+HIGH+LOW)/4;
VAR3:=IF(YEAR>=2099 AND MONTH>2,0,1);
VAR4:=LLV(LOW,5); VAR5:=HHV(HIGH,4);
散户:=EMA((VAR2-VAR4)/(VAR5-VAR4)*100,4)*VAR3;
庄家:=EMA(0.667*REF(散户,1)+0.333*散户,2)*VAR3;

DRAWICON(CROSS(散户,庄家) AND 散户<10,L-0.05,1);
DRAWICON(CROSS(庄家,散户) AND 散户>20,H+0.05,2);
VAR9:=CLOSE-REF(CLOSE,5);
VARA:=EMA(EMA(VAR9,5),5)/EMA(EMA(ABS(VAR9),5),5);
VARC:=EMA(EMA(VAR9,10),10)/EMA(EMA(ABS(VAR9),20),20);
卖出:=IF(VARA>0 AND CROSS(VARC,VARA),90,100);
DRAWICON(卖出<0,H+0.05,2); 买线:=EMA(CLOSE,2);
卖线:=EMA(SLOPE(CLOSE,11)*10+CLOSE,22);
B1:IF(CROSS(买线,卖线),L-0.05,DRAWNULL),CROSSDOT,LINETHICK3,COLORMAGENTA;
S1:IF(CROSS(20,RSI)*10,H+0.05,DRAWNULL),CROSSDOT,LINETHICK3,COLORYELLOW;
VC:=((CLOSE-MA(CLOSE,5))/MA(CLOSE,5)*100+(CLOSE-MA(CLOSE,20))/MA(CLOSE,20)*100+(CLOSE-MA (CLOSE,32))/MA(CLOSE,32)*100)/3;

S2:=IF(VC>20 AND FILTER(VC< REF(VC,1),5),H+0.05,DRAWNULL),CIRCLEDOT,LINETHICK3,COLORGREEN;
A0:=(L+H+C*2)/4;

A1:EMA(A0,5)COLORBLUE,LINETHICK2;

A2:=EMA(A0,10)COLORLIBLUE,LINETHICK2;

A1X:=(A1-REF(A1,1))/REF(A1,1)*100,NODRAW;

A2X:=(A2-REF(A2,1))/REF(A2,1)*100,NODRAW;

看多:IF(A1X>=0 AND BARSLAST(CROSS(A1X,0))>0,REF((C+O)/2,BARSLAST(CROSS(A1X,0))),DRAWNULL),COLORMAGENTA{,LINETHICK2};

逃顶:IF(A1X<0 AND BARSLAST(CROSS(0,A1X))>0,REF((C+O)/2,BARSLAST(CROSS(0,A1X))),DRAWNULL),COLORCYAN,{LINETHICK2};

买入持股:IF(A1X>=0,A1,DRAWNULL)COLORRED,LINETHICK3;

原创文章,作者:(大熊)与水晶,如若转载,请注明出处:https://www.qianglongwang.com/62230.html

联系我们