1. 股票论坛首页
  2. 股票公式
  3. 通达信公式

润泽6981 集合竞价抓涨停成功率98%以上的自创绝技金钻200

指标代码及说明:

竞价选股【加进了虚拟量大3倍和量比大于10】

小于点2亿:=FINANCE(7)<120000000;

点2亿到3亿:=FINANCE(7)<300000000 AND FINANCE(7)>120000000;

叁亿到5亿:=FINANCE(7)<500000000 AND FINANCE(7)>300000000;

伍亿到8亿:=FINANCE(7)<800000000 AND FINANCE(7)>500000000;

捌亿到13亿:=FINANCE(7)<1300000000 AND FINANCE(7)>800000000;

A:=DYNAINFO(14)<0.03 AND DYNAINFO(14)>0.006 AND DYNAINFO(17)>10 AND V*200/FROMOPEN/REF(MA(V,5),1)>3;;

B:=DYNAINFO(9);

XG:(小于点2亿 AND A=1 AND B>1200) OR (点2亿到3亿 AND A=1 AND B>3000)OR (叁亿到5亿 AND A=1 AND B>5000)OR (伍亿到8亿 AND A=1 AND B>8000)OR (捌亿到13亿 AND A=1 AND B>13000);

背离macd附图【我在里边添加了斐波那契数列和超卖信号,供大家参考】

DIF:EMA(CLOSE,5)-EMA(CLOSE,26);

DEA:EMA(DIF,50);

MACD:(DIF-DEA)*2,COLORSTICK;

M:=BARSLAST(H=HHV(H,40));

DRAWTEXT(M>30 AND DEA<-0.35 AND ABS(DEA/C)>0.035 AND DIF>REF(DIF,1),DEA,'超卖'),COLORMAGENTA;

DRAWTEXT(M>30 AND DIF<-0.6 AND ABS(DIF/C)>0.06,DIF,'超卖'),COLORMAGENTA;

TJ:=MACD>0;T:=MACD<0;

A:=LLV(MACD,50)=MACD;

DRAWICON(A AND FILTERX(A,20), MACD,1);

DRAWTEXT(BARSLAST(TJ)=1,MACD,'1'),COLORYELLOW;

DRAWTEXT(BARSLAST(TJ)=2,MACD,'2'),COLORYELLOW;

DRAWTEXT(BARSLAST(TJ)=3,MACD,'3'),COLORYELLOW;

DRAWTEXT(BARSLAST(TJ)=5,MACD,'5'),COLORYELLOW;

DRAWTEXT(BARSLAST(TJ)=8,MACD,'8'),COLORYELLOW;

DRAWTEXT(BARSLAST(TJ)=13,MACD,'13'),COLORYELLOW;

DRAWTEXT(BARSLAST(TJ)=21,MACD,'21'),COLORYELLOW;

DRAWTEXT(BARSLAST(TJ)=34,MACD,'34'),COLORYELLOW;

DRAWTEXT(BARSLAST(TJ)=55,MACD,'55'),COLORYELLOW;

DRAWTEXT(BARSLAST(T)=1,MACD,'1'),COLORGREEN;

DRAWTEXT(BARSLAST(T)=2,MACD,'2'),COLORGREEN;

DRAWTEXT(BARSLAST(T)=3,MACD,'3'),COLORGREEN;

DRAWTEXT(BARSLAST(T)=5,MACD,'5'),COLORGREEN;

DRAWTEXT(BARSLAST(T)=8,MACD,'8'),COLORGREEN;

DRAWTEXT(BARSLAST(T)=13,MACD,'13'),COLORGREEN;

DRAWTEXT(BARSLAST(T)=21,MACD,'21'),COLORGREEN;

DRAWTEXT(BARSLAST(T)=34,MACD,'34'),COLORGREEN;

DRAWTEXT(BARSLAST(T)=55,MACD,'55'),COLORGREEN;

润泽分时主图【因为里边有未来函数,所以那些笑脸,钻石只做参考,不作买卖依据,重点的使用方法在下边,解析在图上已做了标记】

A1:=(VOL/CLOSE)/3;

A2:=SUM((IF(((A1>40) AND (CLOSE>(REF(CLOSE,1)))),A1,0)),0);

A3:=SUM((IF(((A1>40) AND (CLOSE<(REF(CLOSE,1)))),A1,0)),0);

A4:=SUM((IF(((A1<40) AND (CLOSE>(REF(CLOSE,1)))),A1,0)),0);

A5:=SUM((IF(((A1<40) AND (CLOSE<(REF(CLOSE,1)))),A1,0)),0);

A6:=((A2+A3)+A4)+A5;

A7:=IF((BARSTATUS=2),((100*A2)/A6),0);

A8:=((IF((BARSTATUS=2),((100*A3)/A6),0)));

A9:=((IF((BARSTATUS=2),((100*A4)/A6),0)));

A10:=((IF((BARSTATUS=2),((100*A5)/A6),0)));

机构买盘:=(A2),LINETHICK2;

机构卖盘:=(A3),LINETHICK2;

散户买盘:=(A4);

散户卖盘:=(A5);

DRAWTEXT_FIX(1,0.000,1-0.05,0,STRCAT(STRCAT('【机构买盘】',CON2STR(机构买盘,2)),'万')),COLORRED;

DRAWTEXT_FIX(1,0.250,1-0.05,0,STRCAT(STRCAT('【机构卖盘】',CON2STR(机构卖盘,2)),'万')),COLOR00FF00;

DRAWTEXT_FIX(1,0.500,1-0.05,0,STRCAT(STRCAT('【散户买盘】',CON2STR(散户买盘,2)),'万')),COLORRED;

DRAWTEXT_FIX(1,0.745,1-0.05,0,STRCAT(STRCAT('【散户卖盘】',CON2STR(散户卖盘,2)),'万')),COLOR00FF00;

突破:=REF(EMA(C,14),1);

A1X:=(EMA(C,10)-突破)/突破*100;

多方:=IF(A1X>=0,REF(EMA(C,10),BARSLAST(CROSS(A1X,0))+1),DRAWNULL);

空方:=IF(A1X<0,REF(EMA(C,10),BARSLAST(CROSS(0,A1X))+1),DRAWNULL);

STICKLINE(A1X>=0,多方,突破,0,0),COLOR000099;

STICKLINE(A1X<0,空方,突破,0,0),COLOR00CC66;

最新:CLOSE,LINETHICK1,COLORWHITE;

AA:=SUM(AMOUNT,BARSCOUNT(C))/SUM(VOL*100,BARSCOUNT(C));

BB:=BETWEEN(C/AA,C+H,C-H);

DRAWTEXT( ISLASTBAR AND 最新>REF(最新,1),最新,STRCAT(' 涨▲',CON2STR(最新,2))),COLORMAGENTA;

DRAWTEXT( ISLASTBAR AND 最新<REF(最新,1),最新,STRCAT(' 跌▼',CON2STR(最新,2))),COLOR00FF00;

DRAWTEXT_FIX(1,0.880,1-0.97,0,DYBLOCK),COLORWHITE;

DRAWTEXT_FIX(1,0.940,1-0.97,0,HYBLOCK),COLORYELLOW;

均价:SUM(C*V,240)/SUM(V,240),COLORYELLOW,LINETHICK1;

DXJP:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,21)-LLV(LOW,34))*100;

FSZX:=(EMA(DXJP,3)-50)*2,COLORGRAY;

BGTYU:=IF(DATE<=1150530,1,0);

GHYJKU:=BETWEEN((DCLOSE*BGTYU)/(SUM(AMOUNT,BARSCOUNT((DCLOSE*BGTYU)))/SUM(VOL*100,BARSCOUNT((DCLOSE*BGTYU)))),1.05,0.95);

VBNH:=IF(GHYJKU=0,MA((DCLOSE*BGTYU),BARSCOUNT((DCLOSE*BGTYU))),(SUM(AMOUNT,BARSCOUNT((DCLOSE*BGTYU)))/SUM(VOL*100,BARSCOUNT((DCLOSE*BGTYU)))));

DRAWICON(FSZX<=-95,C,38);

DRAWTEXT(CROSS(EXPMA((DCLOSE/VBNH),20),1.04),C,'板'),COLORCYAN;

DRAWTEXT(CROSS(EXPMA((DCLOSE/VBNH),20),1.02),C,'追'),COLORYELLOW;

DRAWICON(CROSS(EXPMA((DCLOSE/VBNH),120),1.004),C,17);

H1:=MAX(DYNAINFO(3),DYNAINFO(5));

L1:=MIN(DYNAINFO(3),DYNAINFO(6));

P1:=H1-L1;

阻力:=L1+P1*7/8,COLORGREEN;

支撑:=L1+P1*0.5/8,COLORMAGENTA;

DRAWICON(LONGCROSS(支撑,C,2),C,5);

DRAWICON(LONGCROSS(C,阻力,2),C,6);

VARJ1:=EMA(EMA(CLOSE,13),13);

控盘2:=(VARJ1-REF(VARJ1,1))/REF(VARJ1,1)*1000;

STJ01:=控盘2<REF(控盘2,1) AND 控盘2>0.5;

STJ02:=控盘2>0;

BTJ2:=控盘2>REF(控盘2,1) AND 控盘2<-0.2;

BTJ22:=控盘2>REF(控盘2,1) AND 控盘2<0 ;

JJ:=DYNAINFO(11);

P:=55;S:=8;M1:=3;

能量:=(EMA(CLOSE,S)-EMA(C,P))*10;

空头:=EMA(能量,M1),COLOR00FF00;

BTJ1:=(CLOSE-JJ)/JJ<-0.005;

BTJ11:=(CLOSE-JJ)/JJ<-0.03;

BTJ12:=COUNT(JJ>=REF(JJ,1),5)>=4 AND (CLOSE-JJ)/JJ<0.005;

STJ1:=(C-JJ)/JJ>0.005;

BTJ3:=CROSS(能量,空头) AND 能量<-0.3;

BTJ32:=CROSS(能量,空头) AND 能量<-0.1;

STJ31:=CROSS(空头,能量);

STJ32:=CROSS(空头,能量) AND 能量>1.618;

A:=8;

BTJ81:=FILTER(BTJ1 AND BTJ2 AND BTJ3,A);

BTJ811:=FILTER(BTJ11 AND BTJ2 AND BTJ3,A);

BTJ82:=FILTER(BTJ12 AND BTJ22 AND BTJ32,A);

时长:=IF(HOUR>=9 AND HOUR<14 ,1,0);{9点至 14点}

捡钱:=BTJ811 AND TIME>15 AND 时长;

DRAWICON(捡钱,C,27);

AYGB1:=(DVOL/C)/2,NODRAW;

AYGB2:=SUM(IF(AYGB1>100 AND CLOSE>REF(CLOSE,1),AYGB1,0),0);

AYGB3:=SUM(IF(AYGB1>100 AND CLOSE<REF(CLOSE,1),AYGB1,0),0);

AYGB4:=SUM(IF(AYGB1<100 AND CLOSE>REF(CLOSE,1),AYGB1,0),0);

AYGB5:=SUM(IF(AYGB1<100 AND CLOSE<REF(CLOSE,1),AYGB1,0),0);

AYGB6:=AYGB2+AYGB3+AYGB4+AYGB5;

机买:=(AYGB2/AYGB6)*100-100,LINETHICK1,COLORRED;

机卖:=(AYGB3/AYGB6)*100-100,LINETHICK1,COLORGREEN;

主力差:=机买-机卖;

LQH:=主力差>0 AND REF(主力差,1)<=0;

DRAWICON(LQH,C,25);

JJXX:=IF(BETWEEN(C/(SUM(AMOUNT,0)/SUM(VOL*100,0)),1.05,0.95)=0,MA(C,0),(SUM(AMOUNT,0)/SUM(VOL*100,0))),COLORYELLOW;

JJXXH:=(JJXX*1.007 ),COLORFF6600;

FFLL:=SUM(VOL,6)>REF(MA(VOL,30),1)*10;

HHPP:=((HHV(CLOSE,BARSCOUNT(CLOSE))-LLV(CLOSE,BARSCOUNT(CLOSE)))/CLOSE)<1;

HHZZ:=HHPP AND FFLL AND (C>JJXXH);

TTPP2:=FILTER(HHZZ,100);

DRAWICON(TTPP2,C,26);

ZS:=DYNAINFO(3);

KP:=DYNAINFO(4);

ZX:=DYNAINFO(7);

ZG:=DYNAINFO(5);

ZD:=DYNAINFO(6);

MA5:='FSKY.MA5#DAY';

DRAWTEXT_FIX(ISLASTBAR,0.9,1-0.2,0,STRCAT('A5 : ',CON2STR(MA5,2))),COLORWHITE;

MA10:='FSKY.MA10#DAY';

DRAWTEXT_FIX(ISLASTBAR,0.9,1-0.15,0,STRCAT('A10 : ',CON2STR(MA10,2))),COLORWHITE;

MA20:='FSKY.MA20#DAY';

DRAWTEXT_FIX(ISLASTBAR,0.9,1-0.1,0,STRCAT('A20 : ',CON2STR(MA20,2))),COLORWHITE;

MA60:='FSKY.MA60#DAY';

DRAWTEXT_FIX(ISLASTBAR,0.9,1,0,STRCAT('A60 : ',CON2STR(MA60,2))),COLORWHITE;

分时均价线:SUM(C*V,240)/SUM(V,240),COLORYELLOW;

昨高:='FSKY.ZH#DAY';

昨低:='FSKY.ZL#DAY';

DRAWTEXT_FIX(ISLASTBAR,0.9,1-0.25,0,STRCAT('昨低 : ',CON2STR(昨低,2))),COLORWHITE;

DRAWTEXT_FIX(ISLASTBAR,0.9,1-0.3,0,STRCAT('昨高 : ',CON2STR(昨高,2))),COLORWHITE;

分时顶:HHV(H,480),COLORGREEN,DOTLINE;

使用方法:1】股价放量过前高回踩不破可买入;2】股价新低后不再创新低,且股价下跌,macd绿柱缩短或向上与股价形成底背离,买入;

3】卖出:股价创新高,macd不创新高,形成顶背离,卖出;

4】股价创新高后回踩不再创新高,也就是第二波的高点不能超过前高点,卖出;

具体的另外一些分时买卖方法,因为不属于咱们抓涨停战法的范围,所以,有时间的时候再说,以上的方法如果能够领会透彻,已经可以很好地操作了!

分时背离macd指标只是把软件里的macd修改一下参数,就行了,原来的是 12,26,9,现改为5 25 50就行了,

使用方法跟平常的方法一样!另外,还有个参数组合适合在日线图上看短线,周线图上也可看买卖趋势的,分别是:5,34,5,供大家参考

原创文章,作者:TTone,如若转载,请注明出处:https://www.qianglongwang.com/62320.html

联系我们