1. 股票论坛首页
  2. 股票公式
  3. 飞狐公式

庄影难逃

指标说明及代码

VAR100:=IF(DATE<=1080228,1,1);

DRAWGBK(CLOSE>0,COLORRGB(180,180,180),COLORRGB(65,75,86),1);

VAR1:=VOL/((HIGH-LOW)*2-(ABS(CLOSE-OPEN)))*VAR100;

成交:=VOL*VAR100;

买盘:=(IF(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE<OPEN,VAR1*(HIGH-OPEN+CLOSE-LOW),VOL/2)))*VAR100;

卖盘:=(IF(CLOSE>OPEN,-VAR1*(HIGH-CLOSE+OPEN-LOW),IF(CLOSE<OPEN,-VAR1*(HIGH-LOW),-VOL/2)))*(VAR100);

买卖差:=(买盘+卖盘)*VAR100;

STICKLINE(VOL>0,VOL,0,4,1),colorFFFFFF;

STICKLINE(买卖差>0,0,买卖差,4,0),colorFF;

STICKLINE(买卖差<0,0,买卖差,4,0),LINETHICK3,color33FF33;

量比:=VOL/MA(VOL,5)*VAR100;

VAR10:=买盘*VAR100;

VAR20:=卖盘*VAR100;

JX1:=BARSSINCE(买盘)*VAR100;

JY1:=(IF(121>JX1 AND JX1>0,JX1,120))*VAR100;

JY2:=(IF(4>JX1 AND JX1>0,JX1,3))*VAR100;

VAR30:=MA(VOL,JY2)*VAR100;

动神:=买盘*VAR100;

鬼力:=VAR20*VAR100;

神比:=动神/VAR30*VAR100;

鬼比:=鬼力/VAR30*VAR100;

VAR2:=(HIGH-LOW)*VAR100;

VAR3:=(ABS(OPEN-CLOSE))*VAR100;

VAR4:=(HIGH-(IF(CLOSE>OPEN,CLOSE,OPEN)))*VAR100;

VAR5:=(IF(CLOSE>OPEN,OPEN,CLOSE)-LOW)*VAR100;

VAR6:=VAR3/VAR2*VOL*VAR100;

VAR7:=VAR4/VAR2*VOL*VAR100;

VAR8:=VAR5/VAR2*VOL*VAR100;

VAR9:=(IF(VOL/CAPITAL>0.001,1,EXP(ABS(LOG(VOL/CAPITAL*100)))))*VAR100;

VARA:=(CLOSE-MA(CLOSE,5))/MA(CLOSE,5)*100*VAR100;

VARB:=(MA(CLOSE,5)>MA(CLOSE,10) AND MA(CLOSE,10)>MA(CLOSE,30) AND MA(CLOSE,30)>MA(CLOSE,60))*VAR100;

VARC:=(MA(CLOSE,5)<MA(CLOSE,10) AND MA(CLOSE,10)<MA(CLOSE,30))*VAR100;

VARD:=REF(CLOSE,1)*VAR100;

VARE:=(SMA(MAX(CLOSE-VARD,0),6,1))/(SMA(ABS(CLOSE-VARD),6,1))*100*VAR100;

DRAWICON(CROSS(84,VARE),HIGH,2),colorFFFF;

VAR40:=(IF(VAR6>=VAR7 AND VAR6>=VAR8 AND CLOSE>OPEN,VAR6,动神)+动神)/2*VAR100;

VAR41:=(IF(VAR7>VAR6 AND VAR7>VAR8,VAR7,动神)+动神)/2*VAR100;

VAR42:=(IF(VAR8>VAR6 AND VAR8>VAR7,VAR8,动神)+动神)/2*VAR100;

VAR50:=(IF(VAR6>=VAR7 AND VAR6>=VAR8 AND CLOSE<OPEN,VAR6,鬼力)+鬼力)/2*VAR100;

三日上攻:=MA((VAR40+VAR41+VAR42)/3,JY2)*VAR100;

三日下攻:=MA(VAR50,JY2)*VAR100;

STICKLINE(CLOSE>MA(CLOSE,30),0,VOL,8,1),colorFF;

STICKLINE(CLOSE<MA(CLOSE,30),0,VOL,8,1),colorFF00;

STICKLINE(鬼力>0,鬼力,0,8,0),colorFF3399;

STICKLINE(VAR6>=VAR7 AND VAR6>=VAR8 AND CLOSE>OPEN,0,VAR6,6,0),colorFFFF;

STICKLINE(VAR6>=VAR7 AND VAR6>=VAR8 AND CLOSE<OPEN,0,VAR6,6,0),colorFF0000;

STICKLINE(VAR8>VAR6 AND VAR8>VAR7,0,VAR8,6,0),colorFFFFFF;

STICKLINE(VAR7>VAR6 AND VAR7>VAR8,0,VAR7,6,0),colorFF00FF;

相对地量:=STICKLINE(VAR9>2 AND VOL<MA(VOL,5)/2,0,VOL,3,0);

地量:=DRAWTEXT(VAR9>2 AND VOL<MA(VOL,5)/2,VOL,'地量');

放量:=STICKLINE(VOL>MA(VOL,5)*2.5,0,VOL,3,0);

STICKLINE(动神>0,动神,0,1.5,0),colorFF;

上攻:=MA((VAR40+VAR41+VAR42)/3,JY2)*VAR100;

下攻:=MA(VAR50,JY2)*VAR100;

上攻均量:=MA(VAR10,JY1)*VAR100;

下攻均量:=MA(VAR20,JY1)*VAR100;

逢高出货:=DRAWTEXT(VAR7>VAR6 AND VARA>2 AND VAR9>VAR8 AND CLOSE>MA(CLOSE,5) AND CLOSE>MA(CLOSE,30) AND HIGH>MA(CLOSE,60) AND VOL>MA(VOL,5) AND VAR7>=MA(VOL,5),VOL,'▼出货');

逢低跟进:=DRAWTEXT(VAR8>VAR6 AND VAR8>VAR7 AND VARA<-2 AND CLOSE<MA(CLOSE,30) AND VAR8<MA(VOL,5)/2 AND MA(VOL,5)<MA(VOL,10),VOL,'◆低进');

低进:IF(VAR8>VAR6 AND VAR8>VAR7 AND VARA<-2 AND CLOSE<MA(CLOSE,30) AND VAR8<MA(VOL,5)/2 AND MA(VOL,5)<MA(VOL,10),1,0),LINETHICK0;

强势参与:=DRAWICON(VAR6>MA(VOL,5)*2 AND VAR6>=VAR7 AND VAR6>=VAR8 AND CLOSE>OPEN OR VOL>MA(VOL,5)*3 AND VARB,VOL,1);

强势:IF(VAR6>MA(VOL,5)*2 AND VAR6>=VAR7 AND VAR6>=VAR8 AND CLOSE>OPEN OR VOL>MA(VOL,5)*3 AND VARB,1,0),LINETHICK0;

DRAWTEXT(VAR6>=VAR7 AND VAR6>=VAR8 AND CLOSE<OPEN AND VAR6/VOL>0.7 AND VARC AND VAR6>MA(VOL,5),VAR6*2,'▼空头');

空头:IF(VAR6>=VAR7 AND VAR6>=VAR8 AND CLOSE<OPEN AND VAR6/VOL>0.7 AND VARC AND VAR6>MA(VOL,5),1,0),LINETHICK0;

DRAWTEXT(量比>1 AND 动神/三日上攻>1.58 AND IF(三日上攻>上攻均量,三日上攻>三日下攻,三日上攻>REF(三日上攻,1)) AND 三日下攻<REF(三日下攻,1) AND (CLOSE-REF(CLOSE,3))/REF(CLOSE,3)*100<14,动神*1.3,'★参与'),colorFFFF;

参与:IF(量比>1 AND 动神/三日上攻>1.58 AND IF(三日上攻>上攻均量,三日上攻>三日下攻,三日上攻>REF(三日上攻,1)) AND 三日下攻<REF(三日下攻,1) AND (CLOSE-REF(CLOSE,3))/REF(CLOSE,3)*100<14,1,0);

MFI:=(HIGH-LOW)*1000000/VOL*VAR100;

换手率:DYNAINFO(37)*VAR100;

DRAWTEXT(VOL/(REF(SUM(VOL,5)/5,1))>=2 AND 换手率>1,VOL*1.1,'●量变'),colorFFFF;

量:(IF(CLOSE>200,VOL/1000000,VOL/100))*VAR100,LINETHICK0;

振幅:(HIGH-LOW)/LOW*100*VAR100,LINETHICK0;

STICKLINE(CLOSE>=OPEN AND 换手率>=3 AND 换手率<5,0,量,80,1),color33AAFF;

原创文章,作者:(大熊)与水晶,如若转载,请注明出处:https://www.qianglongwang.com/62419.html

联系我们