1. 股票论坛首页
  2. 股票公式
  3. 通达信公式

通达信分时阻力支撑高抛低吸主图指标源码

指标代码及说明:

以下是通达信分时阻力支撑高抛低吸主图指标源码(无源码的请下载附件导入)


昨开:='REF(O,1)#DAY',NODRAW;

昨高:='REF(H,1)#DAY',NODRAW;

昨低:='REF(L,1)#DAY',NODRAW;

昨收:=DYNAINFO(3),NODRAW;

A1:=CROSS(C,昨高);

B:=CROSS(昨高,C);

DRAWTEXT_FIX(CURRBARSCOUNT=1,0.01,0.01,0,STRCAT('昨高: ',CON2STR(昨高,2))),COLORYELLOW;

DRAWTEXT_FIX(CURRBARSCOUNT=1,0.01,0.06,0,STRCAT('昨低: ',CON2STR(昨低,2))),COLORMAGENTA;

DRAWTEXT_FIX(CURRBARSCOUNT=1,0.01,0.11,0,STRCAT('昨收: ',CON2STR(昨收,2))),COLORGREEN;

DRAWTEXT_FIX(CURRBARSCOUNT=1,0.01,0.16,0,STRCAT('昨开: ',CON2STR(昨开,2))),COLORWHITE;

HH:=MAX(DYNAINFO(3),DYNAINFO(5));

LL:=MIN(DYNAINFO(3),DYNAINFO(6));

PP:=HH-LL;

阻力:LL+PP*7/8,COLOR00DD00;

支撑:LL+PP*0.5/8,COLORMAGENTA;

现价:CLOSE;

STICKLINE(CROSS(支撑,现价),支撑,(支撑+阻力)/2,2,0),COLORRED;
STICKLINE(CROSS(现价,阻力),阻力,(支撑+阻力)/2,2,0),COLORGREEN;
DRAWTEXT(LONGCROSS(支撑,现价,2),支撑*1.001,'★吸'),LINETHICK2,,COLORYELLOW;

DRAWTEXT(LONGCROSS(现价,阻力,2),现价,'★抛'),LINETHICK2,COLORRED;

原创文章,作者:(大熊)与水晶,如若转载,请注明出处:https://www.qianglongwang.com/62456.html

联系我们