1. 股票论坛首页
  2. 股票公式
  3. 通达信公式

通达信逢低买指标公式源码附图

以下是通达信逢低买指标公式源码附图(无源码的请下载附件导入)

逢低买入
F:=100*(C-REF(C,1))/REF(C,1);
今小昨:=IF(C<REF(O,1) AND F<0,1,0);
S1:=今小昨;
今小前:=IF(C<REF(O,2) AND F<0,1,0),LINETHICK0;
S2:=今小前;
A1:=S1=0 AND REF(S1,1)=1 AND S2=0 AND REF(S2,1)=1 AND CROSS(ZIG(3,3) ,REF(ZIG(3 ,3),1));

A2:=S1=0 AND REF(S1,1)=1 AND S2=0 AND REF(S2,1)=1 AND CROSS(ZIG(3,5) ,REF(ZIG(3 ,5),1));

A3:=S1=0 AND REF(S1,1)=1 AND S2=0 AND REF(S2,1)=1 AND CROSS(ZIG(3,10) ,REF(ZIG(3 ,10),1));

STICKLINE(A1 AND A2 ,0,3,3,0)COLORGREEN;

STICKLINE(A1 AND A2 ,0,1,3,0)COLORBLUE;

STICKLINE(A1 AND A2 AND A3,0,5,3,0)COLORYELLOW;

STICKLINE(A1 AND A2 AND A3,0,3,3,0)COLORFF00FF;

STICKLINE(A1 AND A2 AND A3,0,1,3,0)COLORBLUE;

DRAWTEXT(A3=1,3.8,’☆全仓杀入’),COLORYELLOW;

智勇出击: ZIG(3,6)>REF(ZIG(3,6),1)AND REF(ZIG(3,6),1)<REF(ZIG
(3,6),2),COLORWHITE,LINETHICK2;

DRAWTEXT(智勇出击=1,0.8,’突袭!’),COLORWHITE;

小获且退: ZIG(3,10)<REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)>REF(ZIG
(3,10),2),COLORYELLOW,LINETHICK2;

DRAWTEXT(小获且退=1,1.3,’撤退!’),COLORYELLOW;

VAR3:=PEAKBARS(3,15,1)<10;

VAR5:=IF(VAR3=1,2,0);

顶:= IF(VAR5=2,2,0);

大胜且归:IF(顶>REF(顶,1),2,0),COLORRED,LINETHICK2;

DRAWTEXT(大胜且归=2,2,’将大跌逢高清跌完再买!’),COLORGREEN;

VAR200:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;

VAR300:=SMA(SMA(VAR200,3,1),3,1)/28.57;

VAR400:=EMA(VAR300,5);

操盘:=3*VAR300-2*VAR400;

A4:=CROSS(操盘,VAR300) AND VAR300<2.1 AND C>O;

DRAWTEXT(A4,0.2.1,’关注’),COLORYELLOW;

选底:TROUGHBARS(3,15,1)<4,NODRAW;

DRAWTEXT(FILTER(选底=1,3),0.2,’准备抄底’),COLOR00FF00;

出★逢低买:CROSS(ZIG(3,10) ,REF(ZIG(3 ,10),1)) ;

DRAWTEXT(出★逢低买>0,2,’☆逢低买’);

原创文章,作者:(大熊)与水晶,如若转载,请注明出处:https://www.qianglongwang.com/62466.html

联系我们