1. 股票论坛首页
  2. 股票公式
  3. 通达信公式

通达信 嘿马买卖王 源码

指标说明及代码

N:=20;RLN:=6;智:=10; STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,3,0),COLORAAAAAA; STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,3,0),COLORBBBBBB; STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,0.3,0),COLORCCCCCC; STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,0.0,0),COLORDDDDDD; STICKLINE((CLOSE > OPEN),CLOSE,OPEN,3,0),COLOR6666CC; STICKLINE((CLOSE > OPEN),CLOSE,OPEN,3,0),COLOR7777DD; STICKLINE((CLOSE > OPEN),CLOSE,OPEN,0.3,0),COLOR8888EE; STICKLINE((CLOSE > OPEN),CLOSE,OPEN,0.0,0),COLOR9999FF; STICKLINE((CLOSE > OPEN),OPEN,LOW,0.0,0),COLOR1199FF; STICKLINE((CLOSE > OPEN),CLOSE,HIGH,0.0,0),COLOR1199FF; STICKLINE((OPEN >= CLOSE),CLOSE,LOW,0.0,0),COLORCCCCCC;

Y:=SUMBARS(VOL,(CAPITAL * 1)); A:=(SUM(COST(20),Y) / Y); A2:=(SUM(COST(10),Y) / Y); A1:=(SUM(COST(30),Y) / Y); A3:=(SUM(COST(40),Y) / Y); A4:=(SUM(COST(50),Y) / Y); A5:=(LLV(LOW,250) = LOW); E:=BARSLAST(A5); OK:((((((5 * A2) + (4 * A)) + (3 * A1)) + (2 * A3)) + A4) / 15),CIRCLEDOT,COLORRED ; OK1:STICKLINE((CROSS(CLOSE,OK) AND (E >= 40)),OPEN,CLOSE,5,0) ; E1:=(((CLOSE - LLV(LOW,13)) / (HHV(HIGH,13) - LLV(LOW,13))) * 100); RSV:=SMA(E1,3,1); K:=SMA(RSV,3,1); D:=((3 * RSV) - (2 * K)); J:=(((CLOSE - LLV(LOW,34)) / (HHV(HIGH,34) - LLV(LOW,34))) * 100); RSV12:=SMA(J,3,1); K12:=SMA(RSV12,3,1); D12:=((3 * RSV12) - (2 * K12)); J12:=(((CLOSE - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100); RSV24:=SMA(J12,3,1); K24:=SMA(RSV24,3,1); D24:=((3 * RSV24) - (2 * K24)); 支撑位:IF(CROSS(D,D24),LOW,REF(LOW,BARSLAST(CROSS(D,D24)))),LINETHICK1,COLOR80A810; J24:=IF((CLOSE >= MA(CLOSE,N )),80,50); U2L:=IF((CLOSE >= MA(CLOSE,RLN)),50,20); L2L:=IF(((D > U2L) AND (REF(D,1) <= U2L)),LLV(REF(LOW,1),(BARSLAST(((D <= U2L) AND (REF(D,1) > U2L))) - 1)),REF(LLV(REF(LOW,1),(BARSLAST(((D <= U2L) AND (REF(D,1) > U2L))) - 1)),BARSLAST(((D > U2L) AND REF(D,1))))); RL1:=IF((LOW < L2L),HIGH,REF(HIGH,BARSLAST((LOW < L2L)))); RL4:=IF((LOW < L2L),D,REF(D,BARSLAST((LOW < L2L)))); 抄底:IF((((LOW < RL1) AND (D > RL4)) AND (D > D24)),LOW,REF(LOW,BARSLAST((((LOW < RL1) AND (D > RL4)) AND (D > D24))))),COLOR10FF10; RL42:=IF(((D < J24) AND (REF(D,1) >= J24)),HHV(REF(HIGH,1),(BARSLAST(((D >= J24) AND (REF(D,1) < J24))) - 1)),REF(HHV(REF(HIGH,1),(BARSLAST(((D >= J24) AND (REF(D,1) < J24))) - 1)),BARSLAST(((D < J24) AND REF(D,1))))); RH1:=IF((HIGH > RL42),LOW,REF(LOW,BARSLAST((HIGH > RL42)))); RH4:=IF((HIGH > RL42),D,REF(D,BARSLAST((HIGH > RL42)))); 压力位:IF(CROSS(D24,D),HIGH,REF(HIGH,BARSLAST(CROSS(D24,D)))),LINETHICK1,COLORFF6600; 拦顶:IF((((HIGH > RH1) AND (D < RH4)) AND (D < D24)),HIGH,REF(HIGH,BARSLAST((((HIGH > RH1) AND (D < RH4)) AND (D < D24))))),COLOR10FFFF; RH42:=((AMOUNT / VOL) / 100); CB:=((RH42 > HIGH) OR (RH42 < LOW)); STICKLINE((CB < 1),(RH42 - 0.002),(RH42 + 0.002),6,1) ; 导航:MA(CLOSE,CB ),COLOR1010FF; CD:=EMA(CLOSE,7); VAR1:=EMA(CLOSE,21); VAR2:=EMA(VAR1,7); VAR3:=EMA(VAR2,27); VAR4:=EMA(VAR1,100); VAR5:=EMA(VAR4,100); VAR6:=MA(CLOSE,5); VAR7:=(((((CD > VAR1) AND (VAR1 > VAR2)) AND (VAR2 > VAR3)) AND (VAR3 > VAR4)) AND (VAR4 > VAR5)); VAR8:=(((((VAR1 > REF(VAR1,1)) AND (VAR2 > REF(VAR2,1))) AND (VAR3 > REF(VAR3,1))) AND (VAR4 > REF(VAR4,1))) AND (VAR5 > REF(VAR5,1))); VAR9:=((((LOW + HIGH) + CLOSE) + OPEN) / 4); VARA:=MA(CLOSE,34); VARB:=MA(CLOSE,60); VARC:=((((2 * CLOSE) + HIGH) + LOW) / 4); VARD:=((600 * (EMA(CLOSE,3) - EMA(LOW,30))) / EMA(LOW,30)); VARE:=EMA(VARD,7); VARF:=LLV(LOW,34); VAR10:=HHV(HIGH,34); VAR11:=EMA((((VARC - VARF) / (VAR10 - VARF)) * 100),6); VAR12:=EMA(((0.667 * REF(VAR11,1)) + (0.333 * VAR11)),4); VAR13:=LLV(LOW,120); VAR14:=HHV(HIGH,120); VAR15:=(VAR14 - VAR13); VAR16:=REF(CLOSE,1); VAR17:=(((0 - 100) * (WINNER(((120 * CLOSE) / 100)) - WINNER(((100 * CLOSE) / 100)))) + 5); VAR18:=((WINNER(((120 * CLOSE) / 100)) - WINNER(((100 * CLOSE) / 100))) * 100); VAR19:=((SMA(MAX((CLOSE - VAR16),0),6,1) / SMA(ABS((CLOSE - VAR16)),6,1)) * 100); VAR1A:=MA(VAR9,5); VAR1B:=HHV(VAR1A,20); VAR1C:=HHV(VAR1A,60); VAR1D:=LLV(VAR1A,20); VAR1E:=FORCAST(CLOSE,10); VAR1F:=EMA((VAR1E * 1.05),3); VAR20:=EMA((VAR1E * 0.95),4); VAR21:=((100 * (CLOSE - VAR20)) / (VAR1F - VAR20)); DRAWTEXT((((((VAR18 + VAR17) < 7) AND CROSS(VARD,VARE)) AND (VARE < (0 - 18))) AND (VARE < VAR17)),(LOW - 0.2),'←短买') ; DRAWTEXT(FILTER((((VAR8 AND VAR7) AND (COUNT((CD < REF(CD,1)),5) > 2)) AND (CD > REF(CD,1))),3),(LOW - 0.2),'←回补') ; DRAWTEXT((((((COUNT((CLOSE < REF(CLOSE,1)),8) / 8) > 0.3) AND COUNT((VAR11 > VAR12),3)) AND (REF(LOW,1) = LLV(LOW,120))) AND (CLOSE > OPEN)),(LOW - 0.2),'←低买'),COLORFF0000; DRAWTEXT((((REF(VAR21,1) > VAR21) AND (REF(VAR21,1) > 100)) AND (CLOSE > REF(CLOSE,1))),(HIGH + 0.2),'←短出'),COLORFFFF00; DRAWTEXT(CROSS(84,VAR19),(HIGH + 0.2),'←高出1'),COLORRED; DRAWTEXT(FILTER(((VAR1C > REF(VAR1C,1)) AND (VAR1D > REF(VAR1D,1))),5),(HIGH + 0.2),'←高出2'),COLORMAGENTA ;

原创文章,作者:TTone,如若转载,请注明出处:https://www.qianglongwang.com/62556.html

联系我们