1. 股票论坛首页
  2. 股票公式
  3. 通达信公式

通达信《瓜子涨不停》副图源码 贴图

指标代码及说明:

							

瓜子涨不停 分享于我改写成益盟操盘手平台,借此分享给大家,指标不加密,通达信、益盟操盘手平台均可用。

MID9:=(3*CLOSE+LOW+OPEN+HIGH)/6;

牛线1:=(20*MID9+19*REF(MID9,1)+18*REF(MID9,2)+17*REF(MID9,3)+16*REF(MID9,4)+15*REF(MID9,5)+14*REF(MID9,6)+13*REF(MID9,7)+12*REF(MID9,8)+11*REF(MID9,9)+10*REF(MID9,10)+9*REF(MID9,11)+8*REF(MID9,12)+7*REF(MID9,13)+6*REF(MID9,14)+5*REF(MID9,15)+4*REF(MID9,16)+3*REF(MID9,17)+2*REF(MID9,18)+REF(MID9,20))/210,COLORGREEN{COLORRED};

马线1:=MA(牛线1,6),COLORMAGENTA{COLORYELLOW};

STICKLINE(C>牛线1,-1.9,-0.4,4,0),COLOR000099{COLOR017700},LINETHICK2;

STICKLINE(C<马线1,-1.9,-0.4,4,0),COLOR017700{COLOR000099},LINETHICK2;

STICKLINE(牛线1>=C AND C>=马线1,-1.9,-0.4,8,0),,COLOR017700{COLOR000099},LINETHICK2;

MID1:=(3*CLOSE+LOW+OPEN+HIGH)/6;

牛线:=(20*MID1+19*REF(MID1,1)+18*REF(MID1,2)+17*REF(MID1,3)+16*REF(MID1,4)+15*REF(MID1,5)+14*REF(MID1,6)+13*REF(MID1,7)+12*REF(MID1,8)+11*REF(MID1,9)+10*REF(MID1,10)+9*REF(MID1,11)+8*REF(MID1,12)+7*REF(MID1,13)+6*REF(MID1,14)+5*REF(MID1,15)+4*REF(MID1,16)+3*REF(MID1,17)+2*REF(MID1,18)+REF(MID1,20))/210,COLORGREEN{COLORRED};

马线:=MA(牛线,3),COLORMAGENTA{COLORYELLOW};

GB:=(C-牛线);

换手:=V*100/CAPITAL;

主:=MA(换手,5);

大:=MA(换手,12);

中:=MA(换手,34);

散:=MA(换手,55);

均:=(主+大+中+散)/4;

GBB:=(主-散);

GB1:=GB+GBB;

STICKLINE(GB1>=0,2.5,4,4,0),COLOR000099{COLOR017700},LINETHICK2;

STICKLINE(GB1<0,2.5,4,4,0),COLOR017700{COLOR000099},LINETHICK2;

AA:=MAX(MA(C,60),MA(C,120));

BB:=MIN(MA(C,60),MA(C,120));

成交量:=V,COLORWHITE,LINETHICK0;

Q:=EMA(V,5);

Q1:=EMA(V,50);

OBV:=SUM(IF(CLOSE>REF(CLOSE,1),VOL,IF(CLOSE<REF(CLOSE,1),-VOL,0)),0);

OBV1:=EMA(OBV,5);

OBV2:=EMA(OBV,50);

W:=(Q-Q1)*0.00001;

W1:=(OBV1-OBV2)*0.000001;

W2:=W+W1;

STICKLINE(W2>=0,0.3,1.8,4,0),COLOR000099{COLOR017700},LINETHICK2;

STICKLINE(W2<0,0.3,1.8,4,0),COLOR017700{COLOR000099},LINETHICK2;

J:=MAX(MA(C,30),MA(C,60));

K:=MIN(MA(C,30),MA(C,60));

MID:=(3*CLOSE+LOW+OPEN+HIGH)/6;

DKX:=(20*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+

16*REF(MID,4)+15*REF(MID,5)+14*REF(MID,6)+

13*REF(MID,7)+12*REF(MID,8)+11*REF(MID,9)+

10*REF(MID,10)+9*REF(MID,11)+8*REF(MID,12)+

7*REF(MID,13)+6*REF(MID,14)+5*REF(MID,15)+

4*REF(MID,16)+3*REF(MID,17)+2*REF(MID,18)+REF(MID,20))/210;

MADKX:=MA(DKX,6);

MDD:=(DKX-MADKX)*1.2;

V1:=(C*2+H+L)/4*10;

V2:=EMA(V1,6)-EMA(V1,55);

V3:=EMA(V2,6);

V4:=2*(V2-V3)*5.5;

V5:=(V2-V3)*0.06;

V6:=MDD+V5;

STICKLINE(V6>=0,-4.1,-2.6,4,0),COLOR000099{COLOR017700},LINETHICK2;

STICKLINE(V6<0,-4.1,-2.6,4,0),COLOR017700{COLOR000099},LINETHICK2;

BQIUV:(GB1),COLORWHITE,NODRAW;

BQIUSV:(W2),COLORYELLOW,NODRAW;

WWW:(C-牛线1),COLORYELLOW,NODRAW;

XEV:(V6),COLORGREEN,NODRAW;

XG:=CROSS(GB1+W2+ V6+C>牛线1,0.5),NODRAW ;

选股1: GB1>=0 AND W2>=0 AND V6>=0 AND C>牛线1,NODRAW;

选股2:XG,,NODRAW;

STICKLINE(XG,-4.2,4,3,0),COLORYELLOW;

DRAWTEXT(ISLASTBAR=1,IF(V>=0,3.2,0),'散户'),COLORBLUE;

DRAWTEXT(ISLASTBAR=1,IF(V>=0,1,0),'游资'),COLORBLUE;

DRAWTEXT(ISLASTBAR=1,IF(V>=0,-3.4,0),'主力'),COLORBLUE;

DRAWTEXT(ISLASTBAR=1,IF(V>=0,-1,-0.4),'机构'),COLORBLUE;

原创文章,作者:TTone,如若转载,请注明出处:https://www.qianglongwang.com/62565.html

联系我们