1. 股票论坛首页
  2. 股票公式
  3. 通达信公式

通达信黄金坑N天内有黄金坑指标公式

以下是通达信黄金坑N天内有黄金坑指标公式(无源码的请下载附件导入)

{公式名称: 黄金坑1

公式描述: N天内有黄金坑

参数数量: 1

参数1: 天数, 最小: 0, 最大: 10, 缺省: 1, 日线: 3

公式类型: 条件选股公式-其他类型

公式版本: 0

参数精灵:

请设置计算参数:

天数: PARAM#0 (0.00–10.00)

用法注释:无

公式源码:}

VAR1:=LLV(HIGH,240);

VAR2:=100*(CLOSE-VAR1)/VAR1;

VAR3:=(CLOSE-LLV(LOW,528))/(HHV(HIGH,528)-LLV(LOW,528))*100;

VAR4:=(CLOSE-LLV(CLOSE,530))/(HHV(CLOSE,530)-LLV(CLOSE,530))*100;

VAR5:=SMA(MAX(CLOSE-REF(CLOSE,1),0),34,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),7,1)*100;

VAR6:=SMA(MAX(CLOSE-REF(CLOSE,1),0),13,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),13,1)*100;

VAR7:=BARSCOUNT(CLOSE);

VAR8:=VAR5<20 AND VAR6<23 AND VAR7>35;

VAR9:=VAR8 AND COUNT(VAR8,1)=1;

VAR10:=EMA(CLOSE,21)-EMA(CLOSE,8);

VAR11:=EMA(VAR10,5);

VAR12:=TROUGHBARS(3,6,1)<4 AND CROSS(VAR10,VAR11);

VAR13:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0);

VAR14:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);

VAR15:=ZIG(3,6)=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);

VAR16:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);

VAR17:=ZIG(3,22)=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);

VAR18:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);

VAR19:=ZIG(3,51)=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);

VAR20:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);

VAR21:=ZIG(3,72)=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);

VAR22:=EMA(CLOSE,2)-EMA(CLOSE,150);

VAR23:=EMA(VAR22,100);

VAR24:=2*(VAR22-VAR23);

VAR25:=POW(VAR24,3)*0.1+POW(VAR24,1);

VAR26:=SQRT(SQRT(LOW*HIGH*OPEN*CLOSE));

VAR27:=EMA(VAR26*0.97,3);

VAR28:=(HIGH+LOW+CLOSE)/3;

VAR29:=(VAR28-MA(VAR28,14))/(0.015*AVEDEV(VAR28,14));

VAR30:=CROSS(VAR27,LOW);

VAR31:=VAR13;

VAR32:=VAR14+VAR16+VAR18+VAR20;

VAR33:=VAR15+VAR17+VAR19+VAR21;

VAR34:=IF(VAR24>0.1,VAR25,0)*1;

VAR35:=EMA(WINNER(CLOSE)*100,5);

VAR36:=EMA(VAR35,2);

VAR37:=EMA(VAR36,2);

VAR38:=EMA(VAR37,2);

VAR39:=EMA(VAR38,2);

VAR40:=EMA(VAR39,2);

VAR41:=EMA(VAR40,2);

VAR42:=EMA(VAR41,2);

VAR43:=EMA(VAR42,2);

VAR44:=EMA(VAR43,2);

VAR45:=EMA(VAR44,2);

VAR46:=EMA(VAR45,2);

VAR47:=EMA(VAR46,2);

VAR48:=EMA(VAR47,2);

VAR49:=5;

VAR50:=VAR35;

VAR51:=DRAWLINE(VAR50>=HHV(VAR50,VAR49)=1,VAR50,VAR50<=LLV(VAR50,VAR49)=1,VAR50,1);

VAR52:=REF(VAR50,1)=REF(VAR51,1) AND VAR50>REF(VAR50,1);

VAR53:=VAR52>0;

VAR54:=VAR32 AND VAR53;

VAR55:=VAR32 AND REF(VAR31,1) AND VAR54;

DTO:EXIST(VAR55,天数);

原创文章,作者:TTone,如若转载,请注明出处:https://www.qianglongwang.com/62581.html

联系我们