1. 股票论坛首页
  2. 股票公式
  3. 同花顺公式

同花顺 傲悦波段指标 源码

指标说明及代码

VAR1:=(CLOSE+HIGH+LOW+OPEN)/4;

VAR2:=SUMBARS(VOL,CAPITAL);

VAR3:=HHV(VAR1,VAR2);

VAR4:=LLV(VAR1,VAR2);

VAR5:=(2*VAR1-VAR4-REF(VAR4,1))/(VAR3-VAR4);

VAR6:=(VAR1-VAR4)/(VAR3-VAR4);

VAR7:=IF(VAR1<=VAR4,VAR5*60,VAR6*60);

VAR8:=600*(EMA(CLOSE,3)-EMA(LOW,30))/EMA(LOW,30);

VAR9:=EMA(VAR8,7);

VARA:=(WINNER(120*CLOSE/100)-WINNER(100*CLOSE/100))*100;

VARB:=(-100)*(WINNER(120*CLOSE/100)-WINNER(100*CLOSE/100))+5;

VARC:=HHV(HIGH,9)-LLV(LOW,9);

VARD:=HHV(HIGH,9)-CLOSE;

VARE:=CLOSE-LLV(LOW,9);

VARF:=VARD/VARC*100-70;

VAR10:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;

VAR11:=(2*CLOSE+HIGH+LOW)/4;

VAR12:=SMA(VARE/VARC*100,3,1);

VAR13:=LLV(LOW,34);

VAR14:=SMA(VAR12,3,1)-SMA(VARF,9,1);

VAR15:=IF(VAR14>100,VAR14-100,0);

VAR16:=HHV(HIGH,34);

VAR17:=EMA((VAR11-VAR13)/(VAR16-VAR13)*100,8);//

VAR18:=EMA(VAR17,5);//

//VAR171:=EMA(EMA((VAR11-VAR13)/(VAR16-VAR13)*100,8),5);//

//VAR181:=EMA(EMA(VAR171,5),13);//

//DRAWICON(CROSS(VAR171,VAR181),VAR171,1);

//DRAWICON(CROSS(VAR181,VAR171),VAR181,2);

//STICKLINE(VAR17-VAR18>0,VAR17,VAR18,8,1),colorred ;//

//STICKLINE(VAR17-VAR18<0,VAR17,VAR18,8,1),colorgreen ;//

KQY1:VAR17,colorwhite;

KQY2:VAR18,coloryellow;

STICKLINE(VAR17-VAR18>0,VAR17,VAR18,8,1),colorred ;

STICKLINE(VAR17-VAR18<0,VAR17,VAR18,8,1),colorgreen ;

Q1:=(CLOSE-REF(CLOSE, 1))/REF(CLOSE, 1)*100;

Q2:=(CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*100;//

Q3:=SMA(Q2,9,1);//

Q4:=SMA(Q3,3,1);//

AA:=3*Q3-2*Q4,coloryellow;//

//DRAWTEXT(KQY3>REF(KQY3,1) AND AA>REF(AA,1) AND REF(AA,1)<REF(AA,2),AA*0.85,"B");Q5:=AA>1*REF(AA, 1);

Q6:=LLVBARS(LOW, 50);

Q7:=SUM(VOL, Q6);

Q8:=HHVBARS(HIGH, 50);

Q9:=SUM(VOL, Q8);

Q10:=(CLOSE-REF(OPEN, Q8))/REF(OPEN, Q8)*100;

Q11:=HHV(AA,5);

A1:=EMA(Q3,3) , COLORFFDDCC;//

//DRAWICON(CROSS(AA,A1),AA,1);

//DRAWICON(CROSS(A1,AA),A1,2);

//A2:EMA(A1, 3) , COLORFFBBCC;

//A3:EMA(A2, 3) , COLORFF99CC;

//A4:EMA(A3, 3) , COLORFF55CC;

//A5:EMA(A4, 3) , COLORFF33CC;

//A6:EMA(A5, 3) , COLORFF11CC;

A6:=EMA(EMA(EMA(EMA(EMA(A1, 3), 3), 3), 3), 3) , COLORFF11CC;//

//A:EMA(EMA(EMA(EMA(A1, 3), 3), 3), 3), COLORFF00CC;

//DRAWTEXT(CROSS(AA, 20) AND Q10<-13,10,'!'), COLOR00FF00;

//DRAWTEXT(CROSS(AA, EMA(EMA(EMA(EMA(A1, 3), 3), 3), 3)) AND REF(AA,1)<34,REF(AA,1),'!'), colorred ;

//DRAWTEXT(CROSS(A1, AA) AND REF(AA,1)>80, REF(AA,3), '!'), COLORCFB53B ;

//DRAWTEXT(CROSS(AA, A1) AND Q5 AND A1<20 AND Q1>9 OR A1>1*REF(A1, 1)

//AND Q1>4 AND A1<60, 30, 'i'), COLORFFFFCC;

//

B:=ZIG(3,10),colorred;

G:=MA(B,2),coloryellow;

D:=EMA(B,34),colorgreen;

J:=EMA(B,144),colorligreen;

DRAWTEXT(CROSS(B,G),KQY1*0.7,"建仓"),coloryellow;

DRAWTEXT(CROSS(G,B),KQY1*1.1,"清仓"),colorgreen;

F:=100*(C-REF(C,1))/REF(C,1);

JD:=IF(C<REF(O,1) AND F<0,1,0);

S1:=JD;

MR:=IF(C<REF(O,2) AND F<0,1,0),LINETHICK0;

S2:=MR;

A1:=S1=0 AND REF(S1,1)=1 AND S2=0 AND REF(S2,1)=1 AND CROSS(ZIG(3,3) ,REF(ZIG(3 ,3),1));

A2:=S1=0 AND REF(S1,1)=1 AND S2=0 AND REF(S2,1)=1 AND CROSS(ZIG(3,5) ,REF(ZIG(3 ,5),1));

DRAWTEXT(A1 AND A2 OR D<0,KQY1,'加仓'),coloryellow;

VAR3:=PEAKBARS(3,5,1)<10;

VAR5:=IF(VAR3=1,2,0);

顶:= IF(VAR5=2,2,0);

顶A:=IF(顶>REF(顶,1),1,0),STICK,colorcyan, LINETHICK2;//

DRAWTEXT(顶A=1,KQY1*1.15,'减仓'),colorgreen;

//DRAWICON(KQY1>REF(KQY1,1) AND REF(KQY1,1)<REF(KQY1,2),KQY1,1),coloryellow;//不删

//DRAWICON(KQY1<REF(KQY1,1) AND REF(KQY1,1)>REF(KQY1,2),KQY1,2),colorgreen;//不删

DRAWICON(CROSS(KQY1,KQY2),KQY1,1);

DRAWICON(CROSS(KQY2,KQY1),KQY2,2);

//布林指标

MID=MA(CLOSE,26);

UPPER:=MID + 2*STD(CLOSE,26),colorwhite;//上轨

LOWER:=MID - 2*STD(CLOSE,26),coloryellow;//下轨

DRAWTEXT(CROSS(CLOSE,LOWER),KQY1*0.01,"布林买"),coloryellow;

DRAWTEXT(CROSS(CLOSE,UPPER),KQY2*1.25,"布林卖"),colorgreen;

VERLINE(CROSS(kqy1,KQY2),1),colorlimagenta;//画加仓建仓垂线

VERLINE(CROSS(kqy2,KQY1),1),colorgreen;//画加仓建仓垂线

DRAWICON(CROSS(INDEXC,MA(INDEXC,5)),KQY1,5);

DRAWICON(CROSS(MA(INDEXC,5),INDEXC),KQY1,6);

原创文章,作者:TTone,如若转载,请注明出处:https://www.qianglongwang.com/62705.html

联系我们