1. 股票论坛首页
  2. 股票公式
  3. 通达信公式

通达信深水金叉副图公式源码

以下是通达信深水金叉副图公式源码(无源码的请下载附件导入)

LC:=REF(CLOSE,1);

RSI11:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100,COLORMAGENTA;

RSI22:=SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100,COLORWHITE;

RSI33:=SMA(MAX(CLOSE-LC,0),24,1)/SMA(ABS(CLOSE-LC),24,1)*100,COLORYELLOW,DOTLINE;

RSI50安全线:(RSI11>49 AND RSI22>49 AND RSI33>49)NODRAW,COLOR00FFFF;

STICKLINE(RSI50安全线,10,15,1,0)COLOR00FFFF;

好线:=38,COLORFF3311;

平线:=51,COLORFF1155;

深水:15,COLORFFFF80,DOTLINE;

OK:=REF(CLOSE,1);

RSI1:=SMA(MAX(CLOSE-OK,0),7,1)/SMA(ABS(CLOSE-OK),7,1)*100,COLORWHITE;

RSI2:=SMA(MAX(CLOSE-OK,0),7,1)/SMA(ABS(CLOSE-OK),7,1)*100,COLORWHITE;

鱼:SMA(MAX(CLOSE-OK,0),7,1)/SMA(ABS(CLOSE-OK),7,1)*100,COLORRED,DOTLINE;

RSI4:=SMA(鱼,7,1),LINETHICK1,COLORWHITE;

趋势A:=MA(((CLOSE-LLV(LOW,48))/(HHV(HIGH,48)-LLV(LOW,48))*50),17)+9,COLORFFFFFF;

趋势B:=MA(((CLOSE-LLV(LOW,53))/(HHV(HIGH,53)-LLV(LOW,53))*50),17)+9,COLOR3377DD;

趋势C:=EMA(((CLOSE-LLV(LOW,38))/(HHV(HIGH,38)-LLV(LOW,38))*50),17)+18,COLORYELLOW,LINETHICK1;

A1:=MA(趋势A,7)*1.372,COLORGREEN,LINETHICK1;

A2:=A1*1.0887;

A3:=(1.5*(趋势B+RSI4)-(A2+A1))+12,COLORGREEN,LINETHICK1,DOTLINE;

鱼网:IF((CROSS(RSI2,RSI4) OR CROSS(RSI2,A3) AND A3<好线 AND RSI1<平线),48,38),COLORBLUE,LINETHICK1;

白绿线:SMA(鱼,7,1),LINETHICK1,COLORWHITE;

鱼网蓝柱:鱼网=48 AND CROSS(鱼,好线) AND REF(MA(C,3),1)<=MA(C,3),COLORBLUE;

STICKLINE(鱼网蓝柱,50,70,3,0)COLORRED;

镶黄柱:C>MA(C,3) AND C>=MA(C,7) AND EVERY(C>O,2) AND 鱼网蓝柱;

STICKLINE(镶黄柱,30,50,1,0)COLORYELLOW;

NOTEXTD101:IF(白绿线<REF(白绿线,1),白绿线,DRAWNULL),COLORGREEN;

HH:=BARSLAST(鱼<=15)<5;

深水鱼:CROSS(鱼,RSI4) AND HH AND 白绿线>15,NODRAW,COLORFFFFFF;{BUYHAOGU.COM}

STICKLINE(深水鱼,80,70,1,0)COLORFFFFFF;

三七金叉:BARSLAST(鱼网蓝柱)<5 AND CROSS(MA(C,3),MA(C,7))NODRAW,COLORFF00FF;

STICKLINE(三七金叉,50,70,1,0)COLORFF00FF;

阳后小双阴:(REF(C,2)-REF(C,3))/REF(C,2)>0.04 AND COUNT(C<REF(C,1),2)=2 AND C>MA(C,7)COLOR0080FF;

STICKLINE(阳后小双阴,70,80,1,0)COLOR0080FF;

阴线买入:C>O AND MA(C,5)<MA(C,10) AND REF(C<O,1) AND REF(C<O,2) AND REF(C<O,3) AND (REF(C,1)<REF(C,4)*0.88 OR REF(C,1)<REF(O,4)*0.88)COLORGREEN;

STICKLINE(阴线买入,70,80,1,0)COLORGREEN;

BIAS1:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;

BIAS2:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;

BIAS3:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,11)*100;

底1:BIAS1<-10 AND BIAS2<=-10 AND BIAS3<0;

DIF:=EMA(CLOSE,12)-EMA(CLOSE,150);

DEA:=EMA(DIF,9);

MACD:=(DIF-DEA)*2;

底2:MACD<0 AND MACD>REF(MACD,1) AND REF(MACD,1)<REF(MACD ,2)

AND REF(MACD,2)<REF(MACD,3)

AND REF(MACD,3)<REF(MACD,4);

VAR1:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

VAR2:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;

VAR3:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;

VAR4:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;

VAR5:=(VAR2+2*VAR3+3*VAR4)/6;

VAR6:=MA(VAR5,3);

底3:VAR6<=-10;

VAR11:=CLOSE/MA(CLOSE,20)*100<80;

VAR12:=CLOSE/MA(CLOSE,40)*100<78;

VAR13:=CLOSE/MA(CLOSE,60)*100<72;

VAR14:=HIGH>LOW*1.051;

VAR15:=VAR14 AND COUNT(VAR14,5)>1;

底4:VAR15 AND (VAR11 OR VAR12 OR VAR13);

趋势线:=(CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*100 ;

AA:=((REF(趋势线,1)<REF(趋势线,2) AND 趋势线<-30) AND 趋势线>=REF(趋势线,1)) OR (REF(CROSS(-30,趋势线),1) AND CROSS(趋势线,-30)) OR 趋势线=-30;

BB:=((REF(趋势线,1)<REF(趋势线,2) AND 趋势线<-20 AND 趋势线>-25) AND 趋势线>=REF(趋势线,1)) OR (REF(CROSS(-20,趋势线),1) AND CROSS(趋势线,-20));

底5:BB;

A:=SMA((CLOSE-LLV(LOW,14))/(HHV(HIGH,14)-LLV(LOW,14))*100,4,1);

B:=SMA((CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100,4,1);

MB:=SMA((B-50)*2,3,1)+SMA((A-50)*2,3,1)/2;

金底:MB<-90;

综合选股:IF(金底 AND COUNT(底5,5)>=1 AND COUNT(底4,3)>=1 AND COUNT(底1,3)>=1 AND 底3 AND 底2,1,0),COLORMAGENTA,LINETHICK3;

原创文章,作者:TTone,如若转载,请注明出处:https://www.qianglongwang.com/62743.html

联系我们