1. 股票论坛首页
  2. 股票公式
  3. 同花顺公式

同花顺 稳步盈利指标 源码

指标说明及代码

A1:= 3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1);

A2:= (EMA(A1,5)-REF(EMA(A1,5),1))/REF(EMA(A1,5),1)*100;

A3:= (C-LLV(L,21))/(HHV(H,21)-LLV(L,21))*100;

趋势线:= MA(3*SMA(A3,6,1)-2*SMA(SMA(A3,5,1),5,1),2);

VAR8:= LLV(L,5)=LLV(L,45) AND C>=O*1.04;

VAR9:= C>(REF(H,1)+REF(L,1))/2;

VAR10:= VAR8 AND VAR9;

VAR14:= LLV(L,1)=LLV(L,35) AND C>=O*1.04;

VAR17:= ((C-MA(C,6))/MA(C,6)*100+(C-MA(C,24))/MA(C,24)*100+(C-MA(C,32))/MA(C,32)*100)/3;

VAR27:= MA(HHV(HIGH,485),17);

VAR28:= MA(HHV(HIGH,222),17);

VAR29:= MA(HHV(HIGH,96),17);

VAR30:= MA(LLV(LOW,485),17);

VAR31:= MA(LLV(LOW,222),17);

VAR32:= MA(LLV(LOW,96),17);

//////强龙网www_qianglongwang_com

VAR33:= MA((VAR30*0.96+VAR31*0.96+VAR32*0.96+VAR27*0.558+VAR28*0.558+VAR29*0.558)/6,17);

VAR34:= MA((VAR30*1.25+VAR31*1.23+VAR32*1.2+VAR27*0.55+VAR28*0.55+VAR29*0.65)/6,17);

VAR35:= MA((VAR30*1.3+VAR31*1.3+VAR32*1.3+VAR27*0.68+VAR28*0.68+VAR29*0.68)/6,17);

VAR36:= LLV(LOW,30);

VAR37:= MA((VAR33*3+VAR34*2+VAR35)/6*1.738,17);

VAR38:= VAR37;

VAR39:= LOW;

VAR40:= REF(LOW,1);

VAR41:= SMA(ABS(VAR39-VAR40),3,1)/SMA(MAX(VAR39-VAR40,0),3,1)*100;

VAR42:= MA(IF(CLOSE*1.35<=VAR38,VAR41*10,VAR41/10),3);

VAR43:= HHV(VAR42,30);

VAR73:= (CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;

VAR75:= SMA(VAR73,3,1);

绝佳买点:= MA(IF(LOW<=VAR36,(VAR42+VAR43*2)/2,0),3);

跑:= FILTER(REF(EMA(A1,5),1)>90 AND A2<0 ,7);

买线:= EMA(CLOSE,2);

卖线:= EMA(SLOPE(CLOSE,21)*20+CLOSE,42);

龙:= VAR10;

AA1:= AMOUNT/VOL;

BB1:= LOW<AA1*0.9;

CC1:= (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>1.2;

DD1:= LOW<MA(CLOSE,5)*0.921;

EE1:= VOL<MA(VOL,5)*1.5;

FF1:= BB1 AND CC1 AND DD1 AND EE1;

二十天最低跌幅:= HHV(CLOSE,20)/LLV(CLOSE,20);

RSV:= (CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

K:= SMA(RSV,3,1);

D:= SMA(K,3,1);

J:= 3*K-2*D;

X:= LLV(J,2)=LLV(J,8);

长期底部:= LLV(HIGH,30);

上:= SMA(LOW,5,2)*0.96;

短期底部:= LLV(HIGH,30)*0.93;

LC:= REF(CLOSE,1);

RSI:= SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;

大顶:= FILTER(VAR17>20 AND FILTER(VAR17<REF(VAR17,1),5),5);

VAR76:= (OPEN+LOW+HIGH+CLOSE)/4;

短底2:= EMA(VAR76,5);

支撑:= HHV(短底2,60);

VAR77:= (HHV(HIGH,36)-CLOSE)/(HHV(HIGH,36)-LLV(LOW,36))*100;

VAR78:= SMA(VAR77,5,1);

VAR79:= SMA(VAR78,8,1);

VAR80:= CROSS(VAR78,VAR79) AND VAR79<5;

VAR81:= CLOSE>LLV(CLOSE,60)+0.3*LLV(CLOSE,60) AND VAR80;

VAR82:= IF(CLOSE>1000,VAR80,VAR81);

VAR93:= 100-3*SMA((C-LLV(L,75))/(HHV(H,75)-LLV(L,75))*100,20,1)+2*SMA(SMA((C-LLV(L,75))/(HHV(H,75)-LLV(L,75))*100,20,1),15,1);

VAR94:= 100-3*SMA((O-LLV(L,75))/(HHV(H,75)-LLV(L,75))*100,20,1)+2*SMA(SMA((O-LLV(L,75))/(HHV(H,75)-LLV(L,75))*100,20,1),15,1);

VAR95:= VAR93 AND REF(V,1) AND C>REF(C,1);

大资金入场:=VAR95 AND COUNT(VAR95,30)=1;

DRAWTEXT(VAR95 AND COUNT(VAR95,30)=1,HIGH*1.095,'大资金'),coloryellow;

DRAWTEXT(VAR95 AND COUNT(VAR95,30)=1,HIGH*1.06,'进场'),coloryellow;

逃:= FILTER(HIGH>支撑 AND CLOSE<支撑 AND CLOSE/OPEN>0-1.06 AND CLOSE<OPEN,5);

选逃:= FILTER(VAR82>0 OR 逃 OR CROSS(84,RSI) OR 大顶,3);

卖8:=CROSS(卖线,买线);

散户:= SMA(VAR75,3,1);

新庄:= SMA(散户,3,1);

买8:= CROSS(买线,卖线);

大黑马:= CROSS(趋势线,0) AND EMA(A1,5)<40;

大买:= FILTER(绝佳买点>30000,5);

买1:= CROSS(J,REF(J+0.01,1)) AND X AND J<20 AND 二十天最低跌幅>=1.3;

买2:= FILTER(FF1,3);

买3:= VAR14;

选底:= FILTER(LOW<=上 AND HIGH>=短期底部 AND CLOSE>=长期底部 AND CLOSE/OPEN>1.03,3);

选买:= FILTER(买2 OR 选底,3) AND COUNT(买1+买3+龙,3)>0 ;

STICKLINE(选买,C,HHV(H,10)*0.94,0.3,0),COLORFF0000;

DRAWTEXT(选买,HHV(HIGH,10)*1,'稳赚 '),COLORFF0000;

DRAWTEXT(选买,HHV(HIGH,10)*0.97,'10%'),COLORFF0000;

DRAWTEXT(买8,L,'买'),COLOR0000FF;

DRAWTEXT(大黑马,LOW*0.98,'大黑马'),COLORFFFFFF;

DRAWTEXT(大买,L*0.98,'大买'),COLOR0000FF;

DRAWTEXT(IF(选底,100,0),LOW*0.995,'底'),COLOR399C71;

DRAWTEXT(卖8,H,'卖'),COLOR00FFFF;

DRAWTEXT(选逃,HIGH*1.04,'逃'),COLOR00FFFF;

DRAWTEXT(跑,H*1.02,'跑'),COLOR00FFFF;

DRAWTEXT(CROSS(新庄,散户) AND 新庄>75,HIGH*1.04,'抛'),COLOR00FFFF;

神奇线:MA(C,19),coloryellow,LINETHICK2;

原创文章,作者:TTone,如若转载,请注明出处:https://www.qianglongwang.com/62838.html

联系我们