1. 股票论坛首页
  2. 股票公式
  3. 通达信公式

通达信狂牛主图指标 源码

指标代码及说明:

{狂牛主图}

LS3:=LLV(HIGH,240);

LS4:=100*(CLOSE-LS3)/LS3;

LS5:=REF(LLV(CLOSE,480),1);

LS6:=REF(HHV(CLOSE,480),1);

LS7:=100*(CLOSE-LS5)/(LS6-LS5);LS8:=(CLOSE-LLV(CLOSE,981))/(HHV(CLOSE,981)-LLV(CLOSE,981))*100;

LS9:=(CLOSE-LLV(CLOSE,393))/(HHV(CLOSE,393)-LLV(CLOSE,393))*100;

LSA:=(CLOSE-LLV(LOW,981))/(HHV(HIGH,981)-LLV(LOW,981))*100;

LSB:=(CLOSE-LLV(LOW,393))/(HHV(HIGH,393)-LLV(LOW,393))*100;

LSC1:=EMA(100*(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100)),5);

LSC:=LSC1/4;

LSD:=IF(LSC>23.6,LSC,0);

LSE:=LSC<1;

LSF:=LSD;

LS10:=LS4<LS7 AND LS4<0;

LS11:=1;

LS12:=(HIGH+LOW+CLOSE*2)/4*LS11;

LS13:=EMA(LS12,21);

LS14:=STD(LS12,21);

LS15:=((LS12-LS13)/LS14*100+200)/4*LS11;

LS161:=EMA(LS15,89);

LS16:=(LS161-25)*1.56*LS11;

LS171:=EMA(LS16,5);

LS17:=LS171*1.22*LS11;

LS181:=EMA(LS17,3);

LS18:=LS181*LS11;

LS19:=3*LS17-2*LS18*LS11;

LS1A:=IF(CROSS(LS19,LS17)AND CROSS(LS19,LS18)AND CROSS(LS17,LS18),1,0);

LS1B:=IF(CROSS(LS17,LS19)AND CROSS(LS18,LS19)AND CROSS(LS18,LS17),1,0);

LS1C:=EMA(100*(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100)),13)/4;

LS1D1:=EMA(CLOSE,2);

LS1D2:=EMA(CLOSE,89);

LS1D:=LS1D1-LS1D2;

LS1E:=EMA(LS1D,30);

LS1F:=(LS1D-LS1E)*20;

LS20:=POW(LS1F,3)*0.1+POW(LS1F,2);

LS21:=SQRT(SQRT(LOW*HIGH*OPEN*CLOSE));

LS22:=EMA(LS21*0.97,3);

LS23:=(HIGH+LOW+CLOSE)/3;

LS24:=(LS23-MA(LS23,14))/(0.015*AVEDEV(LS23,14));

LS25:=IF(LS1F>0.015,LS20,0)/45;

庄拉线:=LS25;

LS261:=EMA(CLOSE,2);

LS262:=EMA(CLOSE,150);

LS26:=LS261-LS262;

LS27:=EMA(LS26,100);

LS28:=2*(LS26-LS27);

LS29:=POW(LS28,3)*0.1+POW(LS28,1);

LS2A:=SQRT(SQRT(LOW*HIGH*OPEN*CLOSE));

LS2B:=EMA(LS2A*0.97,3);

LS2C:=(HIGH+LOW+CLOSE)/3;

LS2D:=(LS2C-MA(LS2C,14))/(0.015*AVEDEV(LS2C,14));

黑马线:=IF(LS28>0.1,LS29,0)*5;

量价线:=(CLOSE-MA(CLOSE,21))/MA(CLOSE,21)*100;

{黑马精准线 参数 顶底开关 0 1 0 点位差0 1 0 指定点 0 1000 0}

DRAWGBK(O>0,RGB(33,47,58),RGB(0,0,0),0,'02',0);

{标缺口}

LL:=REF(L,1);HH:=REF(H,1);上跳:=L>HH;下跳:=H<LL;

STICKLINE(L>REF(H,1),L,REF(H,1),3.1,-1),COLORRED;

STICKLINE(REF(L,1)>H,REF(L,1),H,3.1,-1),COLORGREEN;

{灰色}

STICKLINE(O>=C,H,L,0,0),COLOR909090;

STICKLINE(O>=C,C,O,3.1,0),COLOR606060;

STICKLINE(O>=C,C,O,2.1,0),COLOR707070;

STICKLINE(O>=C,C,O,1.2,0),COLOR808080;

STICKLINE(O>=C,C,O,0.2,0),COLOR909090;

STICKLINE(O<=C,H,L,0,0),COLOR666B6F;

STICKLINE(C>O,C,O,3.1,1),COLOR666B6F;

V2V:=V/REF(V,1)>=1.9 AND C>REF(C,1);

{金黄色}

STICKLINE(V2V,H,L,0,0),COLORYELLOW;

STICKLINE(V2V,O,C,3.1,0),COLOR0033FF;

STICKLINE(V2V,O,C,2.1,0),COLOR0077FF;

STICKLINE(V2V,O,C,1.1,0),COLOR00BBFF;

STICKLINE(V2V,O,C,0.1,0),COLOR00FFFF;

{涨停粉}

ZT:=C/REF(C,1)>1.097;

ZT数:COUNT(ZT,BARSSINCE(ZT)),NODRAW;

{涨停红色}

ZDF:=(C-REF(C,1))/REF(C,1)*100;

STICKLINE(ZDF>9.5,C,O,3.1,0),COLOR0000CC;

STICKLINE(ZDF>9.5,C,O,2.1,0),COLOR0000DD;

STICKLINE(ZDF>9.5,C,O,1.2,0),COLOR0000EE;

STICKLINE(ZDF>9.5,C,O,0.2,0),COLOR0000FF;

STICKLINE(ZDF>9.5,H,L,0,0),COLOR0000FF;

{跌停绿色}

STICKLINE(ZDF<-9.9,O,C,3.1,0),COLOR66CC66;

STICKLINE(ZDF<-9.9,O,C,2.1,0),COLOR77DD77;

STICKLINE(ZDF<-9.9,O,C,1.2,0),COLOR88EE88;

STICKLINE(ZDF<-9.9,O,C,0.2,0),COLOR99FF99;

STICKLINE(ZDF<-9.5,H,L,0,0),COLOR99FF99;

均价:=AMO/VOL/100;

假阴真阳:=C<O AND C>=REF(MIN(C,O),1) AND 均价>REF(均价,1);

{蓝}

DT:=假阴真阳;

STICKLINE(DT,H,L,0,0),COLORFFAA00;

STICKLINE(DT,O,C,3,0),COLORFF3300;

STICKLINE(DT,O,C,2,0),COLORFF7700;

STICKLINE(DT,O,C,1,0),COLORFFAA00;

STICKLINE(DT,O,C,0.1,0),COLORFFFF00;

YX:=REF(O,BARSLAST(假阴真阳));

假阴实顶:YX,COLORFF7700,NODRAW;

STICKLINE(V,YX,YX,1,0),COLORFF7700;

L0:=点位差/100;

前极点精准线:IF(顶底开关=0,CONST(REF(L,指定点)),CONST(REF(H,指定点))),COLOR178448;

DRAWICON(ABS(L-前极点精准线)<=L0,前极点精准线*0.99,38);

DRAWICON(ABS(H-前极点精准线)<=L0,前极点精准线*1.01,39);

{H极点精准线:CONST(REF(H,指定点)),COLOR7777FF;

DRAWICON(ABS(H极点精准线-H)<=L0,H极点精准线*1.01,35);

DRAWICON(ABS(H极点精准线-L)<=L0,H极点精准线*0.99,34);}

{极点精准线:CONST(L),COLOR0077FF;

DRAWICON(ABS(L-极点精准线)<=L0,极点精准线*0.99,1);

DRAWICON(ABS(H-极点精准线)<=L0,极点精准线*1.01,2);

同向极点精准数:COUNT(ABS(L-极点精准线)<=L0,60)-1,COLOR0077FF,NODRAW;

异向极点精准数:COUNT(ABS(H-极点精准线)<=L0,60),COLOR0077FF,NODRAW;

XG:=同向极点精准数>0 AND 异向极点精准数>0;}

{DIFF:=10*(EMA(CLOSE,12)-EMA(CLOSE,26));

DEA:=EMA(DIFF,9);

MACD:=2*(DIFF-DEA);

量缩价涨:=C<REF(O,1) AND V<REF(V,1) AND MACD>REF(MACD,1) AND C>REF(C,1) AND REF(C<O,1) AND C>O;

阴KDAY:=BARSLAST(量缩价涨)+1;

STICKLINE(V,REF(O,阴KDAY),REF(O,阴KDAY),3.5,0),COLORMAGENTA;

DRAWICON(CROSS(C,REF(O,阴KDAY)),L,1);}

{梅开二度}

EMA13:=EMA(C,13),COLORWHITE,LINETHICK2;

EMA34:=EMA(C,34),COLORYELLOW;

EMA55:=EMA(C,55),COLORFF00FF;

EMA120:=EMA(C,120),COLORFFCC66;

{STICKLINE(ER,H,L,0.5,1),COLOR0099FF;

STICKLINE(ER,O,C,6,1),LINETHICK2,COLOR0099FF;}

FR:=BARSLAST(REF(CROSS(EMA34,EMA13),1)) AND CROSS(EMA13,EMA34);

{DRAWTEXT(FR,L-0.09,'梅开二度'),COLORWHITE;}

DRAWICON(FR,L*0.95,1);

个股能量线:=EMA(100*(C-LLV(LOW,34))/(HHV(H,34)-LLV(LOW,34)),3);

大盘能量线:=EMA(100*(INDEXC-LLV(INDEXL,34))/(HHV(INDEXH,34)-LLV(INDEXL,34)),3);

N:=14;

LC:=REF(CLOSE,1);

RSI7:=SMA(MAX(CLOSE-LC,0),N,1)/SMA(ABS(CLOSE-LC),N,1)*100,COLORMAGENTA,LINETHICK2;

G1:=个股能量线>70 AND

个股能量线<85 AND RSI7>58.67;

G2:=

个股能量线>59 AND

个股能量线<70;

G3:=

个股能量线>

大盘能量线;

{天量}

M1:=5;

M2:=10;

{VVOL:=IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL);}

VOLUME:=VOL,VOLSTICK;

MAVOL1:=MA(VOLUME,M1);

MAVOL2:=MA(VOLUME,M2);

VAR2:=1*AMOUNT;

MA1:=1*MA(AMOUNT,5);

MA2:=1*MA(AMOUNT,10);

三十日天量:=HHV(VAR2,30)=VAR2;

六十日天量:=HHV(VAR2,60)=VAR2;

百日天量:=HHV(VAR2,100)=VAR2;

一年天量:=HHV(VAR2,250)=VAR2;

TL2:=三十日天量 OR 六十日天量 OR 百日天量 OR 一年天量;

{倍量}

VVOL:=IF(CURRBARSCOUNT=1 AND PERIOD=5,V*240/FROMOPEN,DRAWNULL);

量:=V;

倍量:=(V/REF(V,1)>=1.91 AND COUNT(C>O,1)) OR (L>REF(H,1) AND COUNT(O>C,1) AND V/REF(V,1)>=1.91);

倍缩:=V<=REF(V,1)*0.5;

DRAWICON(TL2=0 AND 倍量=0 AND FR AND ((G1 OR G2 AND G3 )) AND 倍缩=0,H,2);

{***************************}

{}

AA1:=REF(CLOSE,2)<REF(OPEN,2);

AA21:=REF(CLOSE,1)<REF(OPEN,1);

AA22:=REF(CLOSE,1)>REF(OPEN,1);

AA2:=AA21 OR AA22;

AA3:=REF(VOL,1)<REF(VOL,2);

AA4:=VOL>REF(VOL,2);

AA:=AA1 AND AA2 AND AA3 AND AA4;

BB1:=VOL/REF(VOL,1)>1.8;

BB2:=VOL/REF(VOL,1)<2.5;

BB:=BB1 AND BB2;

CC:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>0.02;

单阳:=AA AND BB AND CC;

TJ2:=(V/REF(V,1)>=1.9 AND (C>REF(C,1) OR C>=O)) AND (2.2>=V/REF(V,1) AND (C>REF(C,1) OR C>=O)) ;

TJ3:=RANGE(C/REF(C,1),0.999,1.031);

JD:=ATAN((MA(C,13)/REF(MA(C,13),1)-1)*100)*57.3;

单阳2:=TJ2 AND TJ3 AND JD>8;

STICKLINE(单阳,OPEN,CLOSE,1,0),COLORGREEN;

高不破价:=REF(C,BARSLAST(单阳));

中不破价:=REF((C+L)/2,BARSLAST(单阳));

低不破价:=REF(L,BARSLAST(单阳));

单阳不破:=CURRBARSCOUNT<100

AND BARSLAST(单阳)<11 AND (LLV(L,BARSLAST(单阳))>低不破价 OR

LLV(L,BARSLAST(单阳))=低不破价);

STICKLINE(单阳不破,低不破价-低不破价*0.003,低不破价,4,0),COLORRED;

DRAWTEXT(BARSLAST(单阳)=1

AND 单阳不破,低不破价*0.98,'1'),COLORGREEN;

DRAWTEXT(BARSLAST(单阳)=2 AND

单阳不破,低不破价*0.98,'2'),COLORGREEN;

DRAWTEXT(BARSLAST(单阳)=3 AND

单阳不破,低不破价*0.98,'3'),COLORGREEN;

DRAWTEXT(BARSLAST(单阳)=4 AND

单阳不破,低不破价*0.98,'4'),COLORGREEN;

DRAWTEXT(BARSLAST(单阳)=5 AND

单阳不破,低不破价*0.98,'5'),COLORGREEN;

DRAWTEXT(BARSLAST(单阳)=6 AND

单阳不破,低不破价*0.98,'6'),COLORGREEN;

DRAWTEXT(BARSLAST(单阳)=7 AND

单阳不破,低不破价*0.98,'7'),COLORGREEN;

DRAWTEXT(BARSLAST(单阳)=8 AND

单阳不破,低不破价*0.98,'8'),COLORGREEN;

DRAWTEXT(BARSLAST(单阳)=9 AND

单阳不破,低不破价*0.98,'9'),COLORGREEN;

DRAWTEXT(BARSLAST(单阳)=10 AND

单阳不破,低不破价*0.98,'10'),COLORGREEN;

{};

两天:=LLV(L,BARSLAST(单阳))>低不破价 OR

LLV(L,BARSLAST(单阳))=低不破价;

较强:=LLV(L,BARSLAST(单阳)-2)>中不破价 OR LLV(L,BARSLAST(单阳)-2)=中不破价;

较强选股:STICKLINE(CURRBARSCOUNT<100 AND BARSLAST(单阳)<9 AND 两天 AND 较强,中不破价,中不破价,2,0),COLOR0088FF;

最强:=LLV(L,BARSLAST(单阳)-3)>高不破价 OR LLV(L,BARSLAST(单阳)-2)=高不破价;

最强选股:STICKLINE(CURRBARSCOUNT<100 AND BARSLAST(单阳)<9 AND 两天 AND 最强,高不破价,高不破价,2,0),COLOR00FFFF;

原创文章,作者:TTone,如若转载,请注明出处:https://www.qianglongwang.com/62887.html

联系我们