1. 首页
  2. 同花顺答疑

出“黄金底”字样选股公式

强龙网解答: 网友求助:求助修改为同花顺选股公式,要求出 黄金底 字样的下面是源码VAR1:= DM

强龙网==》同花顺公式答疑栏目解答:

 网友求助:

求助修改为同花顺选股公式,要求出 黄金底 字样的
下面是源码
VAR1:= DMI.+DI
VAR2:= DMI.-MDI
VAR3:=VAR1 65 AND VAR1 REF(VAR1,1);
VAR4:=LLV(VAR1,0);
VAR5:=BARSLAST(VAR4=VAR1);
VAR6:=(0-REF(VAR2,4))/(VAR4-REF(VAR2,VAR5))
VAR7:=VAR1 REF(VAR1,1);
VAR8:=VOL 2*MA(VOL,30);
VAR9:= DMI.ADX (12,6);
VARA:= DMI.ADXR (12,6);
VARB:=CLOSE MA(CLOSE,30) AND CLOSE MA(CLOSE,30)*1.04;
VARC:=MA(CLOSE,30) REF(MA(CLOSE,30),1);
VARD:=BARSLAST(CROSS(MA(CLOSE,5),MA(CLOSE,10))) BARSLAST(CROSS(MA(CLOSE,10),MA(CLOSE,5)));
VARE:=0- MACD.DIFF (7,21,3);
VARF:=TROUGHBARS(3,15,1)
VAR10:=EMA(CLOSE,30) REF(EMA(CLOSE,30),2);
VAR11:=IF(VARF=1,50,0);
VAR12:=CROSS(VAR2,VAR1) AND CROSS(VARA,VAR9);
VAR13:=CROSS(VAR2,VAR1) AND CROSS(VAR9,VARA);
VAR14:=VARB AND VARC AND VARD AND VAR10 AND VAR6 AND VAR7 AND VAR8*50;
VAR15:=BARSLAST(CROSS(VAR2,VAR1)=1);
VAR16:=BARSLAST(CROSS(VAR1,VAR2)=1);
VAR17:=HHV(VAR1,VAR16);
VAR18:=BARSLAST(VAR1=VAR17);
多空:EMA((CLOSE-MA((2*CLOSE+HIGH+LOW)/4,30))/MA((2*CLOSE+HIGH+LOW)/4,30)*100,3),colorwhite;
0,colorred;
STICKLINE(FILTER(VARF=1,5) AND 多空 -10,50,0,30,0),coloryellow;
STICKLINE(FILTER(VARF=1,5),50,0,10,0),coloryellow;
VAR19:=VAR3 OR VAR12 OR VAR13*100;
VAR1A:=VAR13*100;
DRAWICON(FILTER(VARF=1,3),50,1);
DRAWTEXT(FILTER(VARF=1,3),25,'黄金底'),coloryellow;
STICKLINE(多空 -10,0,多空,1,0),coloryellow;
STICKLINE(多空 10,0,多空,1,0),colorred;
    解答如下: VARF:=TROUGHBARS(3,15,1)
有未来,慎用!
 

 

原创文章,作者:不将就的人生,如若转载,请注明出处:https://www.qianglongwang.com/72540.html

联系我们