1. 首页
  2. 同花顺答疑

计算macd面积与股价走势背离的公式

强龙网解答: 网友求助:求计算macd面积与股价走势背离的公式,比如macd绿色面积比前面小而股价却

强龙网==》同花顺公式答疑栏目解答:

 网友求助:

求计算macd面积与股价走势背离的公式,比如macd绿色面积比前面小而股价却创前面新低形成背离。   解答如下: DIFF : EMA(CLOSE,SHORT) - EMA(CLOSE,LONG);
DEA : EMA(DIFF,M);
MACD : 2*(DIFF-DEA), COLORSTICK;
JC := DEA-DIFF;
绿柱面积:=IF(MACD 0,SUM(MACD,BARSLAST(JC 0)),0);
红柱面积:=IF(MACD 0,SUM(MACD,BARSLAST(JC 0)),0);
本次最低价:=LLV(L,BARSLAST(JC
本次最高价:=HHV(H,BARSLAST(JC
X1:=IF (MACD 0,BARSLAST(CROSS(DIFF,DEA)),0);
前次绿柱面积:=REF(绿柱面积,X1+1);
前次最低价:=REF(本次最低价,X1+1);
Y1:=IF((绿柱面积 0 AND ABS(绿柱面积) ABS(前次绿柱面积)
AND 本次最低价 前次最低价 ),1,0);
RS1:= MACD 0 AND REF(MACD,1) 0 AND C 前次最低价
AND ABS(绿柱面积) ABS(前次绿柱面积) AND ABS(MACD) ABS(REF(MACD,1));
底背驰:= IF (CROSS(DIFF,DEA),REF(Y1,1),0);
DRAWTEXT(底背驰,0.3,'积底背'),COLOR00FFFF;
STICKLINE(底背驰,0,0.3,4,0),COLOR0000FF;
DRAWICON(底背驰,0,23),COLORYELLOW;
DRAWBAND(DIFF,RGB(200,50,55),DEA,RGB(50,100,10));
遵:IF(DIFF =DEA,DIFF,DRAWNULL),COLORRED;
守:IF(DEA =DIFF,DEA,DRAWNULL),COLORFF9900;
纪:IF(DIFF =DEA,DEA,DRAWNULL),COLOR00FFFF;
律:IF(DEA =DIFF,DIFF,DRAWNULL),COLOR00FF00;

X2:=IF (MACD 0,BARSLAST(CROSS(DEA,DIFF)),0);
前次红柱面积:=REF(红柱面积,X2+1);
前次最高价:=REF(本次最高价,X2+1);
Y2:=IF((红柱面积 0 AND 红柱面积 前次红柱面积 AND 本次最高价 前次最高价 ),1,0);
RS2:= MACD 0 AND REF(MACD,1) 0 AND C 前次最高价 AND ABS(红柱面积) ABS(前次红柱面积) AND ABS(MACD) ABS(REF(MACD,1));
顶背驰:= IF (CROSS(DEA,DIFF),REF(Y2,1),0);
DRAWICON(顶背驰,0,19),COLOR00FF00;
STICKLINE(顶背驰,0,-0.3,4,0),COLOR00FF00;
DRAWTEXT(顶背驰,-0.3,'积顶背'),COLORFF0000;

如果说面积全坛只有这个公式是TDX用的非童话顺!
 

 

原创文章,作者:不将就的人生,如若转载,请注明出处:https://www.qianglongwang.com/72566.html

联系我们