1. 首页
  2. 股票指标
  3. ADL

通达信CCI买卖点优化指标公式

DRAWGBK(O>C,RGB(40,40,40),RGB(0,0,40),0,’01’,0); {背景不要可删除}
N:=14;
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:(TYP-MA(TYP,N))/(0.015*AVEDEV(TYP,N));
RSI1:=CCI;
AA:=REF(RSI1,N)=HHV(RSI1,2*N+1);
BB:=BACKSET(AA,N+1);
CC:=FILTER(BB,N) AND RSI1=HHV(RSI1,N+1);
A1:=BARSLAST(REF(CC,1));
顶背离:REF(CLOSE,A1+1)RSI1 AND CC;
DRAWLINE(CC,RSI1,FILTER(顶背离>0,5),RSI1,0),COLORGREEN,LINETHICK1;
DRAWICON(顶背离,CCI*0.9,6);
AA2:=REF(RSI1,N)=LLV(RSI1,2*N+1);
BB2:=BACKSET(AA2,N+1);
CC2:=FILTER(BB2,N) AND RSI1=LLV(RSI1,N+1);
A2:=BARSLAST(REF(CC2,1));
底背离:REF(CLOSE,A2+1)>CLOSE AND REF(RSI1,A2+1)0,5),RSI1,0),COLORMAGENTA,LINETHICK1;
DRAWICON(底背离,CCI*1.1,5);
上升:IF(CCI>REF(CCI,1),CCI,DRAWNULL),LINETHICK1,COLORRED,DOTLINE;
X:=CROSS(CCI,-100);
DRAWICON(X,-150,7);
M:=CROSS(100,CCI);
DRAWICON(M,150,8);
IF(CCI>=100,CCI,DRAWNULL),COLORGREEN;
IF(CCI<=-100,CCI,DRAWNULL),COLORRED; 顶部:100,COLORBLUE,LINETHICK1; 底部:-100,COLORRED,LINETHICK1; STICKLINE(CCI>100,100,CCI,0.5,0), COLORGREEN;
STICKLINE(CCI<-100,-100,CCI,0.5,0), COLORRED;

原创文章,作者:不将就的人生,如若转载,请注明出处:https://www.qianglongwang.com/73859.html

联系我们